Changed Hover.com password results in Thunderbird saying that there is a network problem.

RESOLVED FIXED in Thunderbird 15.0

Status

Thunderbird
Account Manager
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: mconley, Assigned: Bienvenu)

Tracking

(Blocks: 1 bug)

Trunk
Thunderbird 15.0
x86
All
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird13- fixed, thunderbird14+ fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
When I change my Mailbox password (through Hover)
The next time I go into Thunderbird,  it gives that message "Server <email@address.com>  has disconnected.  The server may have gone down or there may be a network problem."   instead of prompting for the password again (like it would do before, when no password was being set at all).
(Reporter)

Comment 1

5 years ago
David says that this is happening because Hover.com is dropping the connection when the auth attempt fails, and that our IMAP code is kinda busted in that situation.

What do we want to do about this?
(Assignee)

Comment 2

5 years ago
Created attachment 629299 [details] [diff] [review]
proposed fix

Mike, you want to try with this patch? It's fairly safe, as last minute changes go.
Assignee: nobody → dbienvenu
Attachment #629299 - Flags: review?(mconley)
(Reporter)

Comment 3

5 years ago
Comment on attachment 629299 [details] [diff] [review]
proposed fix

Review of attachment 629299 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. Now the question is, what do we do with this?
Attachment #629299 - Flags: review?(mconley) → review+
(Reporter)

Comment 4

5 years ago
Mark:

Are we effectively past the point where something could get slipped into beta?

-Mike
(Reporter)

Comment 5

5 years ago
landed on trunk - http://hg.mozilla.org/comm-central/rev/ebe999a8371e
Status: NEW → RESOLVED
Last Resolved: 5 years ago
tracking-thunderbird13: --- → ?
tracking-thunderbird14: --- → ?
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 15.0
(Assignee)

Comment 6

5 years ago
Comment on attachment 629299 [details] [diff] [review]
proposed fix

[Triage Comment]
I'll land this on aurora in a bit, maybe later today.
Attachment #629299 - Flags: approval-comm-aurora+
(Assignee)

Comment 7

5 years ago
pushed to aurora - http://hg.mozilla.org/releases/comm-aurora/rev/648090f7ec78
(Assignee)

Comment 8

5 years ago
Comment on attachment 629299 [details] [diff] [review]
proposed fix

[Approval Request Comment]
I'll let Standard8 make the call about beta/final.

I doubt that it's only hover affected by this issue, so there is a more general upside to taking this patch.
Attachment #629299 - Flags: approval-comm-beta?
(Reporter)

Updated

5 years ago
Blocks: 757501
status-thunderbird14: --- → fixed
tracking-thunderbird13: ? → -
tracking-thunderbird14: ? → +
Comment on attachment 629299 [details] [diff] [review]
proposed fix

This is now on the beta channel.
Attachment #629299 - Flags: approval-comm-beta?
Comment on attachment 629299 [details] [diff] [review]
proposed fix

[Triage Comment]
We've not heard any issues with this, so we'll take it in 13.0.1.
Attachment #629299 - Flags: approval-comm-release+
Fixed for 13.0.1:

https://hg.mozilla.org/releases/comm-release/rev/0c203b72f169
status-thunderbird13: --- → fixed
You need to log in before you can comment on or make changes to this bug.