The default bug view has changed. See this FAQ.

Port |Bug 728141 - Replace old synchronous favicons calls in browser| to Thunderbird

RESOLVED FIXED in Thunderbird 16.0

Status

Thunderbird
Toolbars and Tabs
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Ian Neal, Assigned: Ian Neal)

Tracking

Trunk
Thunderbird 16.0
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird14 fixed, thunderbird15 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Created attachment 629590 [details] [diff] [review]
Switch to Asynchronous Favicons [Checked in: Comment 2 & 4]

References:
Bug 713642 - (asyncFaviconCallers) Replace all old synchronous favicons calls in the codebase.
Bug 713269 - Use Asynchronous Favicons API for PlacesUtils.jsm.
Bug 728141 - Replace old synchronous favicons calls in browser.
Attachment #629590 - Flags: review?(mconley)
(Assignee)

Updated

5 years ago
Assignee: nobody → iann_bugzilla
Status: NEW → ASSIGNED
Comment on attachment 629590 [details] [diff] [review]
Switch to Asynchronous Favicons [Checked in: Comment 2 & 4]

Review of attachment 629590 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, thanks.
Attachment #629590 - Flags: review?(mconley) → review+
(Assignee)

Comment 2

5 years ago
Comment on attachment 629590 [details] [diff] [review]
Switch to Asynchronous Favicons [Checked in: Comment 2 & 4]

http://hg.mozilla.org/comm-central/rev/f6e3760f12cc
Attachment #629590 - Attachment description: Switch to Asynchronous Favicons → Switch to Asynchronous Favicons [Checked in: Comment 2]
(Assignee)

Comment 3

5 years ago
Comment on attachment 629590 [details] [diff] [review]
Switch to Asynchronous Favicons [Checked in: Comment 2 & 4]

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: Favicon may not be correct for any browser pages, so probably not very visible.
Testing completed (on c-c, etc.): c-c
Risk to taking this patch (and alternatives if risky): Low risk, ported patch landed on Firefox 13.
Attachment #629590 - Flags: approval-comm-beta?
Attachment #629590 - Flags: approval-comm-aurora?
(Assignee)

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 16.0
Attachment #629590 - Flags: approval-comm-beta?
Attachment #629590 - Flags: approval-comm-beta+
Attachment #629590 - Flags: approval-comm-aurora?
Attachment #629590 - Flags: approval-comm-aurora+
Checked in:

https://hg.mozilla.org/releases/comm-aurora/rev/6573c4a21686
https://hg.mozilla.org/releases/comm-beta/rev/709068332aaf
status-thunderbird14: --- → fixed
status-thunderbird15: --- → fixed
(Assignee)

Updated

5 years ago
Attachment #629590 - Attachment description: Switch to Asynchronous Favicons [Checked in: Comment 2] → Switch to Asynchronous Favicons [Checked in: Comment 2 & 4]
You need to log in before you can comment on or make changes to this bug.