Note: There are a few cases of duplicates in user autocompletion which are being worked on.

extra ")" makes Firefox RPM Nightly build failed

RESOLVED FIXED in Firefox 16

Status

Firefox Graveyard
Webapp Runtime
RESOLVED FIXED
5 years ago
a year ago

People

(Reporter: Takanori MATSUURA, Assigned: Takanori MATSUURA)

Tracking

Trunk
Firefox 16
Bug Flags:
in-moztrap -

Details

(Whiteboard: [qa-])

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Created attachment 630497 [details] [diff] [review]
Fix

See bug 746156 comment #11 and bug 746156 comment #13.

By removing extra ")" from toolkit/mozapps/installer/packager.mk, Firefox RPM Nightly build is successful.
Attachment #630497 - Flags: review?(benjamin)
Attachment #630497 - Flags: review?(benjamin) → review+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
(Assignee)

Updated

5 years ago
Assignee: nobody → t.matsuu
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
Comment on attachment 630497 [details] [diff] [review]
Fix

https://hg.mozilla.org/integration/mozilla-inbound/rev/2b0ec0df160c
Attachment #630497 - Flags: checkin+
Keywords: checkin-needed

Updated

5 years ago
Whiteboard: [qa-]

Comment 2

5 years ago
https://hg.mozilla.org/mozilla-central/rev/2b0ec0df160c
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 16
Duplicate of this bug: 762214

Updated

5 years ago
Flags: in-moztrap-

Updated

5 years ago
QA Contact: jsmith
Comment on attachment 630497 [details] [diff] [review]
Fix

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 746156
User impact if declined: There is no user impact, but various build steps will fail when Firefox is built in certain configurations, including the one described in this bug and the one described in bug 773706.
Testing completed (on m-c, etc.): This landed on mozilla-central a while ago and has not caused any problems there.
Risk to taking this patch (and alternatives if risky): It's a simple, obvious fix and thus seems very low-risk.
String or UUID changes made by this patch: None.
Attachment #630497 - Flags: approval-mozilla-aurora?

Comment 5

5 years ago
Comment on attachment 630497 [details] [diff] [review]
Fix

[Triage Comment]
If this somehow manages to regress us, my faith will be shaken. Approved for Aurora 15.
Attachment #630497 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Comment 6

5 years ago
(please land ASAP to make it in before Monday's merge)
https://hg.mozilla.org/releases/mozilla-aurora/rev/5a17af2f7a20
status-firefox15: --- → fixed
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.