mozIDOMApplicationMgmt install/uninstall events broken since bug 762007

RESOLVED DUPLICATE of bug 761729

Status

()

Core
DOM
RESOLVED DUPLICATE of bug 761729
6 years ago
5 years ago

People

(Reporter: vlad, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

In bug 762007, mozIDOMApplicationEvent was changed to just be nsISupports, since nsIDOMEvent is [builtinclass]

-[scriptable, uuid(870bfbdc-3e13-4042-99dd-18e25720782d)]
-interface mozIDOMApplicationEvent : nsIDOMEvent
+[scriptable, uuid(f1dd58d8-5211-46ce-8470-d54dde596725)]
+interface mozIDOMApplicationEvent : nsISupports

this change breaks fennec about:apps -- http://mxr.mozilla.org/mozilla-central/source/dom/interfaces/apps/nsIDOMApplicationRegistry.idl#54 defines oninstall/onuninstall as nsIDOMEventListener, which won't work any more as mozIDOMWebApplicationEvent is no longer a nsIDOMEvent.  Calling handleEvent as in http://mxr.mozilla.org/mozilla-central/source/dom/apps/src/Webapps.js#367 throws an exception, because the event arg is not a nsIDOMEvent.

What's the right way to fix this?  Given the builtinclass stuff, do we need a mozIDOMWebApplicationEventListener or something?
Ah, this should be fixed by bug 761729.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 761729
(Assignee)

Updated

5 years ago
Component: DOM: Mozilla Extensions → DOM
Product: Core → Core
You need to log in before you can comment on or make changes to this bug.