Last Comment Bug 762303 - [css3-transitions] unprefix CSS Transition properties
: [css3-transitions] unprefix CSS Transition properties
Status: RESOLVED FIXED
[qa+]
: dev-doc-complete
Product: Core
Classification: Components
Component: CSS Parsing and Computation (show other bugs)
: Trunk
: All All
: -- normal with 2 votes (vote)
: mozilla16
Assigned To: Emmanuele Bassi (:ebassi)
:
: Jet Villegas (:jet)
Mentors:
Depends on: 789747 790761
Blocks: unprefix 772342 772456 772460 832139
  Show dependency treegraph
 
Reported: 2012-06-06 16:26 PDT by Tantek Çelik
Modified: 2013-12-27 14:27 PST (History)
16 users (show)
ryanvm: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+


Attachments
preliminary patch (82.25 KB, patch)
2012-07-02 11:47 PDT, Emmanuele Bassi (:ebassi)
no flags Details | Diff | Splinter Review
unprefix CSS Transition properties and provide temporary aliases for -moz-transition and exposed subproperties (80.20 KB, patch)
2012-07-03 09:36 PDT, Emmanuele Bassi (:ebassi)
dbaron: feedback+
Details | Diff | Splinter Review
Bug 762303 - [css3-transitions] unprefix CSS Transition properties and provide temporary aliases for -moz-transition and exposed subproperties (82.03 KB, patch)
2012-07-04 06:32 PDT, Emmanuele Bassi (:ebassi)
dbaron: review+
Details | Diff | Splinter Review

Description Tantek Çelik 2012-06-06 16:26:44 PDT
The CSS Working Group has agreed to give the go-ahead to browser implementers to unprefix CSS3 Transitions, Transforms, and Animations:

http://lists.w3.org/Archives/Public/www-style/2012Jun/0105.html
Comment 1 Jason Smith [:jsmith] 2012-06-06 16:44:52 PDT
Nominating for k9o - this identified as a top pain point from John Jensen's report for web compatibility.
Comment 2 Lawrence Mandel [:lmandel] (use needinfo) 2012-06-13 12:25:31 PDT
Jet - What are your thoughts on blocking k9o on the unprefixing these properties?
Comment 3 Jason Smith [:jsmith] 2012-06-17 10:02:17 PDT
(In reply to Lawrence Mandel [:lmandel] from comment #2)
> Jet - What are your thoughts on blocking k9o on the unprefixing these
> properties?

As a point of comparison, we are currently blocking on bug 745523 (the transforms unprefixing) based on the same rationale in comment 1. Should this be a blocker for the same reason?
Comment 4 Jet Villegas (:jet) 2012-06-20 10:52:43 PDT
Yes, these should be k9o blockers.
Comment 5 Jet Villegas (:jet) 2012-06-29 07:23:13 PDT
Assigning to Emmanuele as his first official bug.
Comment 6 Emmanuele Bassi (:ebassi) 2012-07-02 11:47:32 PDT
Created attachment 638436 [details] [diff] [review]
preliminary patch

I have a preliminary patch ready; needs testing on the try server, for which I requested a level 1 commit access in bug 770124.

I mostly followed the pattern of the unprefixing of -moz-border-image (cfr commit https://hg.mozilla.org/mozilla-central/rev/8ff7563000f5).
Comment 7 Emmanuele Bassi (:ebassi) 2012-07-03 09:36:03 PDT
Created attachment 638769 [details] [diff] [review]
unprefix CSS Transition properties and provide temporary aliases for -moz-transition and exposed subproperties

new version of the patch in attachment 638436 [details] [diff] [review]; this one actually provides -moz aliases for transition and its sub-properties, as they have been exposed already.

a simple grep on mozilla-central shows a lot of hits in browser/themes and toolkit/themes for -moz-transition; I wonder if a supplemental patch should be provided now, before we remove the aliases, to avoid doing it later.
Comment 8 David Baron :dbaron: ⌚️UTC-10 2012-07-03 12:09:54 PDT
Comment on attachment 638769 [details] [diff] [review]
unprefix CSS Transition properties and provide temporary aliases for -moz-transition and exposed subproperties

You should actually run unit tests to make sure this doesn't make anything fail.  I think you're missing reordering of the table near the end of layout/style/nsComputedDOMStyle.cpp (which will cause a test to fail, since the order of that list is exposed to JS), but otherwise this looks fine.

In the future it may make sense to separate the renaming patch from the go-through-the-tree patch, though there's no need to do that after-the-fact here.  (The first patch needs to have the layout/style/test/ changes to avoid failing tests.)
Comment 9 Emmanuele Bassi (:ebassi) 2012-07-04 06:32:50 PDT
Created attachment 639077 [details] [diff] [review]
Bug 762303 - [css3-transitions] unprefix CSS Transition properties and provide temporary aliases for -moz-transition and exposed subproperties

updated patch after feedback.

try output: https://tbpl.mozilla.org/?tree=Try&rev=bc9718b535f8
try log: http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/ebassi@mozilla.com-bc9718b535f8/
Comment 10 Emmanuele Bassi (:ebassi) 2012-07-04 06:34:06 PDT
ugh, copy and paste failure.

try output: https://tbpl.mozilla.org/?tree=Try&rev=00cf7dc7ee59
try log: http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/ebassi@mozilla.com-00cf7dc7ee59/
Comment 11 David Baron :dbaron: ⌚️UTC-10 2012-07-05 15:49:11 PDT
Comment on attachment 639077 [details] [diff] [review]
Bug 762303 - [css3-transitions] unprefix CSS Transition properties and provide temporary aliases for -moz-transition and exposed subproperties

r=dbaron
Comment 12 JP Rosevear [:jpr] 2012-07-08 16:37:11 PDT
Guessing checkin-needed since EB is new :-)
Comment 13 Ryan VanderMeulen [:RyanVM] 2012-07-08 18:30:59 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/137f4655cf25

I had to un-bitrot this a bit. Please look it over to make sure I didn't mess anything up. Also, please make sure that future patches have all the needed checkin info. It makes life easier for those checking in on your behalf. Thanks!
https://developer.mozilla.org/en/Creating_a_patch_that_can_be_checked_in
Comment 14 David Baron :dbaron: ⌚️UTC-10 2012-07-08 19:38:53 PDT
looks fine to me
Comment 15 Ed Morley [:emorley] 2012-07-09 04:49:39 PDT
https://hg.mozilla.org/mozilla-central/rev/137f4655cf25

Note You need to log in before you can comment on or make changes to this bug.