The default bug view has changed. See this FAQ.

Unprefix CSS3 transforms, Transition properties, Animation etc in Comm-Central.

RESOLVED FIXED in Thunderbird 20.0

Status

MailNews Core
Backend
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Philip Chee, Assigned: stefanh)

Tracking

Trunk
Thunderbird 20.0
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Bug 762303 [css3-transitions] unprefix CSS Transition properties
Bug 745523 [css3-transforms] Unprefix transforms

s/-moz-transform/transform/g
s/mozTransform/transform/g
s/-moz-transition/transition/g
s/-mozTransition/transition/g

Anything else I've missed?
(Reporter)

Updated

5 years ago
Summary: unprefix CSS3 transforms and CSS3 Transition properties → Unprefix CSS3 transforms and CSS3 Transition properties in SeaMonkey
patches coming...

also:

 s/-moz-animation/animation/g
 s/MozAnimation/animation/g
Assignee: nobody → ebassi
(Reporter)

Comment 2

5 years ago
> patches coming...
Ah if you intend to work on this. I suggest you do a sweep of all comm-central not just SeaMonkey.
Yes, it seems we use this some in comm-central and I wouldn't say no to get rid of the prefix part.
http://mxr.mozilla.org/comm-central/search?string=moz-transform
http://mxr.mozilla.org/comm-central/search?string=moz-transition
(Reporter)

Updated

5 years ago
Component: General → Backend
Product: SeaMonkey → MailNews Core
Summary: Unprefix CSS3 transforms and CSS3 Transition properties in SeaMonkey → Unprefix CSS3 transforms, Transition properties, Animation etc in Comm-Central.
I'm already doing a sweep for those three recently unprefixed properties in mozilla-central, doing comm-central is not going to cost me much more time. :-)
(Reporter)

Updated

5 years ago
Duplicate of this bug: 772936
(Reporter)

Updated

5 years ago
Depends on: 762302, 752187, 771678

Comment 6

5 years ago
Below is the list that still appear to be prefixed in Fx16.0.1 (and Fx17.0b1) Winstripe theme and that generate Java Console errors when un-prefixed and, thus, are not processed:

-moz-transform
-moz-linear-gradient
-moz-radial-gradient
-moz-calc
-moz-animation-duration
-moz-animation-name
-moz-transform-origin
-moz-animation-timing-function
(Assignee)

Comment 7

4 years ago
Created attachment 692642 [details] [diff] [review]
Unprefix moz-transform/transition/calc/animation in c-c

Fallen for calendar/ changes, Ratty for suite/ and Standard8 for mail/

These changes are quite mechanical, so I didn't do -moz-linear-gradient since (iirc) that might require changing the syntax. I'll open a new bug for the gradient stuff so we can close this one.
Assignee: ebassi → stefanh
Status: NEW → ASSIGNED
Attachment #692642 - Flags: review?(philipp)
Attachment #692642 - Flags: review?(philip.chee)
Attachment #692642 - Flags: review?(mbanner)
Comment on attachment 692642 [details] [diff] [review]
Unprefix moz-transform/transition/calc/animation in c-c

Review of attachment 692642 [details] [diff] [review]:
-----------------------------------------------------------------

r=philipp for Calendar, thanks!
Attachment #692642 - Flags: review?(philipp) → review+
Attachment #692642 - Flags: review?(mbanner) → review+
(Assignee)

Comment 9

4 years ago
Filed bug 823673 for the removal of -moz-prefixed gradients
No longer depends on: 752187
(Assignee)

Comment 10

4 years ago
Comment on attachment 692642 [details] [diff] [review]
Unprefix moz-transform/transition/calc/animation in c-c

Trying Neil, since I'll be away from sunday and Ratty seems busy atm.
Attachment #692642 - Flags: review?(philip.chee) → review?(neil)
Comment on attachment 692642 [details] [diff] [review]
Unprefix moz-transform/transition/calc/animation in c-c

Assuming the suite ones are all transforms or transitions, rs=me.
Attachment #692642 - Flags: review?(neil) → review+
(Assignee)

Comment 12

4 years ago
http://hg.mozilla.org/comm-central/rev/aa3f7180ac2c
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 20.0
You need to log in before you can comment on or make changes to this bug.