Slow and jerky slideshow on http://iweb.com/ since Firefox 16

RESOLVED FIXED

Status

defect
RESOLVED FIXED
7 years ago
3 months ago

People

(Reporter: epinal99-bugzilla2, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(firefox15 unaffected, firefox16 affected)

Details

(URL)

(Reporter)

Description

7 years ago
STR: open http://iweb.com/

Firefox displays a white overlay which disappears progressively when the website is loading. In addition the slideshow is jerky and slow (click on the dots to animate).

Mozreg range:

m-c
good=2012-07-09
bad=2012-07-10
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b6fb3d9bd1b9&tochange=02b26fb307b4

m-i
good=2012-07-08
bad=2012-07-09
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=fa1bf35aae2e&tochange=8129536fb25c
(Reporter)

Updated

7 years ago
(Reporter)

Updated

7 years ago

Comment 1

7 years ago
Profile trace. Doesn't look like a performance issue

http://people.mozilla.com/~bgirard/cleopatra/?report=92285549af462185f5314011c4c0bc2e36d0a128

I'd hazard a guess that the issue here is the unprefixing of CSS animation properties in Bug 762302 that broke the page. Editing the transition property at line 954 of /screen.css to have a 1 second value (as opposed to 20) makes the switching mostly smooth. You can use the style sidebar to do this on the fly after selecting one of the slide elements). The fact they don't pause but keep scrolling could be a similar issue too.

(Why was I CC'ed? Anyway, I was bored so it doesn't matter.)

Comment 2

7 years ago
(Disregard the last sentence, I CC'ed myself yesterday)

Comment 3

7 years ago
This issue happens after landing Bug 762303.

The problem is the following CSS
* {
  transition: all 20s !important; }
in http://iweb.com/sites/default/themes/privatewhisper/assets/css/screen.css

So, I think this is the site problem,
Assignee: nobody → english-us
Blocks: 762303
Component: Layout → English US
Product: Core → Tech Evangelism
Version: 16 Branch → unspecified
OS: Windows 7 → All
Hardware: x86_64 → All
Did anyone contact the site yet?  Or should I?
I sent them some mail...
tested with Firefox 32.0.3 and working
Assignee: english-us → nobody
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Component: English US → Desktop
Resolution: --- → FIXED
(Assignee)

Updated

3 months ago
Component: Desktop → Desktop
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.