Last Comment Bug 762588 - channel-prefs.js is at the wrong location in FF-on-XR setups
: channel-prefs.js is at the wrong location in FF-on-XR setups
Status: RESOLVED FIXED
: regression
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: 13 Branch
: All All
: -- normal (vote)
: Firefox 16
Assigned To: Mike Hommey [:glandium]
:
:
Mentors:
Depends on: 769130
Blocks: 756325 760792
  Show dependency treegraph
 
Reported: 2012-06-07 10:52 PDT by Mike Hommey [:glandium]
Modified: 2012-06-27 19:44 PDT (History)
2 users (show)
bugzillamozillaorg_serge_20140323: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
Install channel-prefs.js in PREF_DIR when building Firefox as a XULRunner app (2.75 KB, patch)
2012-06-07 11:45 PDT, Mike Hommey [:glandium]
robert.strong.bugs: review+
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2012-06-07 10:52:37 PDT
In Xulrunner applications, the defaults/pref/ directory under the application directory is not used for preferences, which means channel-prefs.js, being installed there unconditionally, is never going to be read.
Comment 1 Mike Hommey [:glandium] 2012-06-07 11:45:02 PDT
Created attachment 631062 [details] [diff] [review]
Install channel-prefs.js in PREF_DIR when building Firefox as a XULRunner app
Comment 2 Robert Strong [:rstrong] (use needinfo to contact me) 2012-06-07 12:11:14 PDT
FYI: The changes that caused this bug also landed on Aurora and are on beta as well now.
Comment 3 Mike Hommey [:glandium] 2012-06-07 12:14:29 PDT
(In reply to Robert Strong [:rstrong] (do not email) from comment #2)
> FYI: The changes that caused this bug also landed on Aurora and are on beta
> as well now.

Which is why I had set status-firefox14: affected :)
Comment 5 Ed Morley [:emorley] 2012-06-08 14:00:05 PDT
https://hg.mozilla.org/mozilla-central/rev/22a835a8a15f
Comment 6 Mike Hommey [:glandium] 2012-06-11 07:41:50 PDT
Comment on attachment 631062 [details] [diff] [review]
Install channel-prefs.js in PREF_DIR when building Firefox as a XULRunner app

[Approval Request Comment]
Bug caused by bug 756325, which was a late landing on aurora (a few days before beta merge).
User impact if declined: Only a problem for people building firefox as a xulrunner application.
Risk to taking this patch (and alternatives if risky): The patch doesn't change anything for mozilla builds.
Comment 8 Serge Gautherie (:sgautherie) 2012-06-27 04:35:36 PDT
Comment on attachment 631062 [details] [diff] [review]
Install channel-prefs.js in PREF_DIR when building Firefox as a XULRunner app

Review of attachment 631062 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/app/Makefile.in
@@ +142,5 @@
>  libs:: $(srcdir)/profile/channel-prefs.js
>  	$(NSINSTALL) -D $(DIST)/bin/defaults/pref
>  	$(PYTHON) $(topsrcdir)/config/Preprocessor.py $(PREF_PPFLAGS) $(ACDEFINES) $^ > $(DIST)/bin/defaults/pref/channel-prefs.js
> +else
> +PREF_JS_EXPORTS += $(srcdir)/profile/channel-prefs.js

I'm a little confused.
Isn't it useless to set PREF_JS_EXPORTS _after_ including rules.mk?
http://mxr.mozilla.org/comm-central/search?string=PREF_JS_EXPORTS&case=on
Comment 9 Mike Hommey [:glandium] 2012-06-27 04:41:42 PDT
(In reply to Serge Gautherie (:sgautherie) from comment #8)
> Comment on attachment 631062 [details] [diff] [review]
> Install channel-prefs.js in PREF_DIR when building Firefox as a XULRunner app
> 
> Review of attachment 631062 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> ::: browser/app/Makefile.in
> @@ +142,5 @@
> >  libs:: $(srcdir)/profile/channel-prefs.js
> >  	$(NSINSTALL) -D $(DIST)/bin/defaults/pref
> >  	$(PYTHON) $(topsrcdir)/config/Preprocessor.py $(PREF_PPFLAGS) $(ACDEFINES) $^ > $(DIST)/bin/defaults/pref/channel-prefs.js
> > +else
> > +PREF_JS_EXPORTS += $(srcdir)/profile/channel-prefs.js
> 
> I'm a little confused.
> Isn't it useless to set PREF_JS_EXPORTS _after_ including rules.mk?
> http://mxr.mozilla.org/comm-central/search?string=PREF_JS_EXPORTS&case=on

Mmmm you're right. Can you file a followup bug?
Comment 10 Serge Gautherie (:sgautherie) 2012-06-27 19:44:09 PDT
(In reply to Mike Hommey [:glandium] from comment #9)
> Can you file a followup bug?

Bug 769130 Submitted

Note You need to log in before you can comment on or make changes to this bug.