browser/app/Makefile.in: setting PREF_JS_EXPORTS _after_ including rules.mk is useless

RESOLVED FIXED in Firefox 14

Status

()

Firefox
Build Config
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: sgautherie, Assigned: glandium)

Tracking

({regression})

Trunk
Firefox 16
regression
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox14 fixed, firefox15 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
(In reply to Mike Hommey [:glandium] from bug 762588 comment #9)
> (In reply to Serge Gautherie (:sgautherie) from comment #8)
> > Comment on attachment 631062 [details] [diff] [review]
> > Install channel-prefs.js in PREF_DIR when building Firefox as a XULRunner app
> > 
> > Review of attachment 631062 [details] [diff] [review]:
> > -----------------------------------------------------------------
> > 
> > ::: browser/app/Makefile.in
> > @@ +142,5 @@
> > >  libs:: $(srcdir)/profile/channel-prefs.js
> > >  	$(NSINSTALL) -D $(DIST)/bin/defaults/pref
> > >  	$(PYTHON) $(topsrcdir)/config/Preprocessor.py $(PREF_PPFLAGS) $(ACDEFINES) $^ > $(DIST)/bin/defaults/pref/channel-prefs.js
> > > +else
> > > +PREF_JS_EXPORTS += $(srcdir)/profile/channel-prefs.js
> > 
> > I'm a little confused.
> > Isn't it useless to set PREF_JS_EXPORTS _after_ including rules.mk?
> > http://mxr.mozilla.org/comm-central/search?string=PREF_JS_EXPORTS&case=on
> 
> Mmmm you're right.
(Assignee)

Comment 1

5 years ago
Created attachment 639223 [details] [diff] [review]
Actually install channel-prefs.js in PREF_DIR when building Firefox as a XULRunner app
(Assignee)

Updated

5 years ago
Attachment #639223 - Flags: review?(khuey)
(Reporter)

Comment 2

5 years ago
Comment on attachment 639223 [details] [diff] [review]
Actually install channel-prefs.js in PREF_DIR when building Firefox as a XULRunner app

This looks like what I expected.
Attachment #639223 - Flags: feedback+
Attachment #639223 - Flags: review?(khuey) → review+
(Assignee)

Comment 3

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/a11422072152
Target Milestone: --- → Firefox 16
(Assignee)

Comment 4

5 years ago
Comment on attachment 639223 [details] [diff] [review]
Actually install channel-prefs.js in PREF_DIR when building Firefox as a XULRunner app

[Approval Request Comment]
Bug caused by bug 762588 and initially bug 756325.
User impact if declined: channel-prefs.js is not shipped at all after bug 762588. (only affects Firefox as a xulrunner application, not mozilla builds, nor local builds)
Risk to taking this patch (and alternatives if risky): NPOTB.
String or UUID changes made by this patch: None.
Attachment #639223 - Flags: approval-mozilla-beta?
Attachment #639223 - Flags: approval-mozilla-aurora?

Comment 5

5 years ago
Comment on attachment 639223 [details] [diff] [review]
Actually install channel-prefs.js in PREF_DIR when building Firefox as a XULRunner app

[Triage Comment]
NPOTB, approved for Aurora 15 and Beta 14.
Attachment #639223 - Flags: approval-mozilla-beta?
Attachment #639223 - Flags: approval-mozilla-beta+
Attachment #639223 - Flags: approval-mozilla-aurora?
Attachment #639223 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/a11422072152
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Updated

5 years ago
Flags: in-testsuite-
(Assignee)

Comment 7

5 years ago
http://hg.mozilla.org/releases/mozilla-aurora/rev/5e5ba775818c
http://hg.mozilla.org/releases/mozilla-beta/rev/39f015c65a4b
status-firefox14: affected → fixed
status-firefox15: affected → fixed
You need to log in before you can comment on or make changes to this bug.