Closed Bug 762966 Opened 8 years ago Closed 7 years ago

reset homepage pref for users who have it set to google.com/firefox

Categories

(Firefox :: Preferences, defect)

14 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 18

People

(Reporter: lmandel, Assigned: raymondlee)

References

Details

Attachments

(1 file, 2 obsolete files)

As detailed in bug 710542, a number of users still have the Google hosted Firefox home page (google.com/firefox) set as their default. This page informs the user that their Firefox installation is out of date. The default homepage for all users should be about:home. We should put something in product that automatically detects that google.com/firefox is set as the home page and automatically updates the preference to about:home. We may want to make this a one shot deal in case any user does consciously decide to set the Google page again after we change it. (Wouldn't want to continue to clobber their choice.)

Alternatively, we can consider using an add-on hotfix to change the default page. Not sure where a request would be filed to deliver an add-on hotfix.
I think this shouldn't be totally automatic: the user has to be informed of the change, with a request box.
Especially considering that currently about:home misses many features, especially search as you type and search by hitting return (instead that clicking on the button), which should probably be filed as a bug.
(In reply to Valerio Capello from comment #1)
> I think this shouldn't be totally automatic: the user has to be informed of
> the change, with a request box.
> Especially considering that currently about:home misses many features,
> especially search as you type and search by hitting return (instead that
> clicking on the button), which should probably be filed as a bug.

Yes. We should consider the pros/cons of being noisy with this change in terms of requiring user input or informing the user. As one option, we can change the home page to about:home and inform the user on about:home (possibly via a snippet) that their home page has been updated and giving them an undo option.
(In reply to Valerio Capello from comment #1)
>  search by hitting return

please clarify, for me it works flawlessy.
(In reply to Lawrence Mandel [:lmandel] from comment #2)
>  As one option, we can
> change the home page to about:home and inform the user on about:home
> (possibly via a snippet) that their home page has been updated and giving
> them an undo option.

This would add a lot of code complication, especially for the fact snippets cannot execute privileged code.
(In reply to Marco Bonardo [:mak] from comment #3)
> (In reply to Valerio Capello from comment #1)
> >  search by hitting return
> 
> please clarify, for me it works flawlessy.

It's working now. I couldn't reproduce it.
Is this still an issue? Firefox 3.6 and previous are now redirected to start.mozilla.org which is hosted on Mozilla's servers. This redirect was done via DNS changes and should display in Firefox 3.6 users unless they manually changed their homepage to google.com/firefox. Users are still able to go to google.com/firefox since Mozilla doesn't control that page and Google is not interested in redirecting it to start.mozilla.org.

Christie: Do you have any additional feedback?
The goal of this bug is to add code to reset the preference for users who've custom-set it to http://google.com/firefox, since apparently some users have done that unintentionally.
ok, cool. thanks.
Summary: Change google.com/firefox homepage to about:home → reset homepage pref for users who have it set to google.com/firefox
Attached patch v1 (obsolete) — Splinter Review
I am not sure whether it's the right place to put the code in nsBrowserContentHandler.js.  Please check.
Assignee: nobody → raymond
Status: NEW → ASSIGNED
Attachment #665285 - Flags: review?(gavin.sharp)
Comment on attachment 665285 [details] [diff] [review]
v1

I think you want to put this in nsBrowserGlue.js (_migrateUI).
Attachment #665285 - Flags: feedback-
Attached patch v2 (obsolete) — Splinter Review
Moved code to _migrateUI
Attachment #665285 - Attachment is obsolete: true
Attachment #665285 - Flags: review?(gavin.sharp)
Attachment #665353 - Flags: review?(dao)
Comment on attachment 665353 [details] [diff] [review]
v2

>+    if (currentUIVersion < 8) {
>+      // Reset homepage pref for users who have it set to google.com/firefox
>+      var uri = Services.prefs.getComplexValue("browser.startup.homepage",
>+                                               Ci.nsIPrefLocalizedString).data;
>+      if (uri && /^https?:\/\/(www\.)?google(\.\w{2,3}){1,2}\/firefox\/?$/.test(uri)) {
>+        Services.prefs.clearUserPref("browser.startup.homepage");
>+      }
>+    }

nit: use let instead of var
Attachment #665353 - Flags: review?(dao) → review+
Updated var to let

https://tbpl.mozilla.org/?tree=Try&rev=9685ba5d3a9b
Attachment #665353 - Attachment is obsolete: true
https://hg.mozilla.org/mozilla-central/rev/3eb02ef25ea5
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 18
Blocks: 1077740
You need to log in before you can comment on or make changes to this bug.