Long taps broken on Top Sites tab

VERIFIED FIXED

Status

()

Firefox for Android
General
VERIFIED FIXED
5 years ago
11 months ago

People

(Reporter: wesj, Assigned: wesj)

Tracking

({regression})

Trunk
regression
Points:
---
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(firefox15+ fixed, firefox16 verified, firefox17 verified)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Search suggestions changed something so that now we return an AwesomeBarItem rather than a Cursor when we call getItemFromPosition(). I'm filing this to track, but with the refactoring in bug 759041 this will be cleaner to fix, so I'm planning to just fix it there.
(Assignee)

Updated

5 years ago
Duplicate of this bug: 763963
When I long tap on an entry from Top Sites I get errors like this (one error for each long tap):

E/GeckoAwesomeBar( 9831): item at 0 is not a Cursor
E/GeckoAwesomeBar( 9831): item at 1 is not a Cursor
E/GeckoAwesomeBar( 9831): item at 2 is not a Cursor
E/GeckoAwesomeBar( 9831): item at 3 is not a Cursor

--
Firefox 16.0a1 (2012-06-19)
Device: Galaxy Nexus
OS: Android 4.0.2
Summary: Long taps broken on All Pages tab → Long taps broken on Top Sites tab
The respective patches of bug 759041 were already landed some time ago, even though that bug itself is not fixed yet. Therefore this works now.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
This is still an issue on Firefox Mobile 15.0b2 build 1 on HTC Desire running Android 2.2
Right, the patches landed on m-c when it was 16 and were not uplifted to 15. 
Wes, is it possible to uplift those patches to Beta?
If we do that though, we probably also want to fix bug 777649 for Beta.
Status: RESOLVED → REOPENED
tracking-fennec: --- → ?
status-firefox15: --- → affected
status-firefox16: --- → fixed
status-firefox17: --- → fixed
Resolution: WORKSFORME → ---
Blocks: 777649
(Assignee)

Comment 6

5 years ago
The fix in 16 isn't something I want to push forward. I'll put together a separate patch for 15 if we want it?

Comment 7

5 years ago
I think this is definitely something we need to fix for 15, since it's a regression.
tracking-firefox15: --- → ?
Keywords: regression
(Assignee)

Comment 8

5 years ago
Created attachment 646191 [details] [diff] [review]
Patch for beta

Since this will go straight to beta with no testing on central, thought more eyes would be better. This is pretty similar to what's on central though, without the refactor. Tested locally tapping on different entries in all three panes with and without search suggestions.

I'll ask for approval once the reviews are done.
Assignee: nobody → wjohnston
Attachment #646191 - Flags: review?(mbrubeck)
Attachment #646191 - Flags: review?(bnicholson)
Attachment #646191 - Flags: approval-mozilla-beta?
(Assignee)

Updated

5 years ago
Attachment #646191 - Flags: approval-mozilla-beta?
Attachment #646191 - Flags: review?(mbrubeck) → review+
Wes, is bug 777649 also present in 15? Did you fix it with your patch here? If yes please remember that the other channels need a fix for it as well.
Attachment #646191 - Flags: review?(bnicholson) → review+
(Assignee)

Comment 10

5 years ago
Comment on attachment 646191 [details] [diff] [review]
Patch for beta

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Search suggestions
User impact if declined: No context menu on awesomescreen
Testing completed (on m-c, etc.): Patch on m-c is very similar, but not exactly the same. Tested locally.
Risk to taking this patch (and alternatives if risky): Low risk. Basically adds a new path and a new getter method.
String or UUID changes made by this patch: None.
Attachment #646191 - Flags: approval-mozilla-beta?

Updated

5 years ago
tracking-firefox15: ? → +

Updated

5 years ago
Attachment #646191 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
(Assignee)

Comment 11

5 years ago
https://hg.mozilla.org/releases/mozilla-beta/rev/6932a40200a3
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
status-firefox15: affected → fixed
Resolution: --- → FIXED

Updated

5 years ago
Status: RESOLVED → VERIFIED
status-firefox16: fixed → verified
status-firefox17: fixed → verified

Comment 12

5 years ago
Tcs added in MozTrap for Firefox 15 and later versions both phone and tablet: 

https://moztrap.mozilla.org/manage/case/6030/ Awesomescreen tablet suite - 
Long tap in Top Sites  
https://moztrap.mozilla.org/manage/case/6031/ Awesomescreen suite - 
Long tap in Top Sites
Flags: in-moztrap+
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.