Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Can't save messages as *.txt and *.html

RESOLVED FIXED in Thunderbird 16.0

Status

MailNews Core
Backend
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Bernd, Assigned: Bienvenu)

Tracking

({regression})

Thunderbird 16.0
x86_64
Windows 7
regression

Thunderbird Tracking Flags

(thunderbird13+ fixed, thunderbird14+ fixed, thunderbird15+ fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 631752 [details]
Bild 022.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0
Build ID: 20120601045813

Steps to reproduce:

Try to save a message as *.txt or *.html. 
The message can be a plain text or HTML one.
You can use right click menu -> Save As...
or
File > Save As > file > 
In both cases you have to change the file type in the popping up window.


Actual results:

I get an error message (see attachment in German language) that says:
 "Can't save message. Please, verify file name and try it later."
I can save the mail just as eml.



Expected results:

Thunderbird should save the mail as *.html or *.txt as it does in v. 11.0 without problems.

Updated

5 years ago
Duplicate of this bug: 763281

Updated

5 years ago
Keywords: regression

Comment 2

5 years ago
Regression window
Good:
http://hg.mozilla.org/comm-central/rev/4f7dd383534c
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120307 Thunderbird/13.0a1 ID:20120307030033
Bad:
http://hg.mozilla.org/comm-central/rev/946cf51e8327
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20120308 Thunderbird/13.0a1 ID:20120308030048
Pushlog:
http://hg.mozilla.org/comm-central/pushloghtml?fromchange=4f7dd383534c&tochange=946cf51e8327

Suspected: Bug 186724
Blocks: 186724
Status: UNCONFIRMED → NEW
Component: General → Backend
Ever confirmed: true
Product: Thunderbird → MailNews Core
QA Contact: general → backend

Updated

5 years ago
tracking-firefox14: --- → ?
tracking-firefox15: --- → ?
tracking-firefox16: --- → ?
(Assignee)

Comment 3

5 years ago
Created attachment 631772 [details] [diff] [review]
fix save as txt, html
Assignee: nobody → dbienvenu
Attachment #631772 - Flags: review?(neil)

Updated

5 years ago
Duplicate of this bug: 762008

Comment 5

5 years ago
Oh, this got undetected into 13.0 release :( Candidate for 13.0.1?

Updated

5 years ago
tracking-thunderbird14: --- → ?
tracking-thunderbird15: --- → ?
tracking-firefox14: ? → ---
tracking-firefox15: ? → ---
tracking-firefox16: ? → ---
tracking-thunderbird13: --- → ?
tracking-thunderbird14: ? → +
tracking-thunderbird15: ? → +

Updated

5 years ago
Duplicate of this bug: 763428
Can we get a unit test for saving messages as well, I thought we had one (but maybe that's eml not html/txt)?

Comment 8

5 years ago
Comment on attachment 631772 [details] [diff] [review]
fix save as txt, html

SetSpec can fail for a valid URL? That's unhelpful...
Attachment #631772 - Flags: review?(neil) → review+
(Assignee)

Comment 9

5 years ago
(In reply to neil@parkwaycc.co.uk from comment #8)
> Comment on attachment 631772 [details] [diff] [review]
> fix save as txt, html
> 
> SetSpec can fail for a valid URL? That's unhelpful...

Set spec fails on windows if the file doesn't exist
(Assignee)

Comment 10

5 years ago
fixed on trunk http://hg.mozilla.org/comm-central/rev/71786ff7840c
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Target Milestone: --- → Thunderbird 16.0
Comment on attachment 631772 [details] [diff] [review]
fix save as txt, html

[Triage Comment]
a=me for branches, we also want this for 13.0.1.
Attachment #631772 - Flags: approval-comm-release+
Attachment #631772 - Flags: approval-comm-beta+
Attachment #631772 - Flags: approval-comm-aurora+
Checked in:

https://hg.mozilla.org/releases/comm-aurora/rev/e11e89933363
https://hg.mozilla.org/releases/comm-beta/rev/19c80330f0c4
status-thunderbird14: --- → fixed
status-thunderbird15: --- → fixed
Fixed for 13.0.1:

https://hg.mozilla.org/releases/comm-release/rev/9f64f487a957
status-thunderbird13: --- → fixed
tracking-thunderbird13: ? → +
Duplicate of this bug: 765354
You need to log in before you can comment on or make changes to this bug.