[adbe 3210917] IMEs don't work with Flash Player 11.3 (with Protected Mode enabled)

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: kohei, Unassigned)

Tracking

({jp-critical})

Trunk
x86
Windows 7
jp-critical
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [flash-11.3], URL)

(Reporter)

Description

6 years ago
+++ This bug was initially created as a clone of Bug #763237 +++

The latest Flash Player includes the Protected Mode for Firefox on Windows Vista and 7.
http://forums.adobe.com/message/4476911

With this version, people are saying they can no longer input Japanese characters on Flash forms. This is the same situation as Bug 587667.

STR:

1. Install Google IME http://www.google.co.jp/ime/
2. Go to http://weathernews.jp/
3. Enable IME 
4. input characters on the input widget

Expected:

IME does work like other forms

Actual result:

English characters are entered instead of Japanese.

IME works when the Protected Mode disabled.
http://forums.adobe.com/message/4468493

Looks like the bundled Microsoft IME works even with Protected Mode enabled.
(Reporter)

Comment 1

6 years ago
This can be reproduced both on Release and Nightly.
Summary: IME doesn't work with Flash 11.3 with Protected Mode enabled → IME doesn't work with Flash Player 11.3 with Protected Mode enabled
Version: 13 Branch → Trunk
(Reporter)

Comment 2

6 years ago
We have notified the issue to Japanese Firefox users via Mozilla Japan blog http://mozilla.jp/blog/entry/6738/ and Twitter https://twitter.com/mozillajp/status/212062234996772864
(Reporter)

Comment 3

6 years ago
(In reply to Kohei Yoshino from comment #2)
> We have notified the issue to Japanese Firefox users via Mozilla Japan blog
> http://mozilla.jp/blog/entry/6738/

Nope, our post is http://mozilla.jp/blog/entry/9509/

Comment 4

6 years ago
We tested with system IME before shipping. Is this an issue only with Google IME?

Jeff Mott
Flash Player
(Reporter)

Comment 5

6 years ago
MS-IME did work as far as I tested at http://weathernews.jp/
I haven't tested other IMEs like ATOK.
(Reporter)

Comment 6

6 years ago
I've installed other popular IMEs and tested at http://weathernews.jp/

* ATOK trial version: not affected
* Baidu IME: not affected

Though I cannot guarantee those IMEs work on every forms, please test Google IME as it's free and becoming popular among Japanese Internet users.

Comment 7

6 years ago
Could someone with the right permissions change the title of the bug to "Google IME" rather than "IME" please?
(Reporter)

Updated

6 years ago
Summary: IME doesn't work with Flash Player 11.3 with Protected Mode enabled → Google IME doesn't work with Flash Player 11.3 (with Protected Mode enabled)

Updated

6 years ago
Summary: Google IME doesn't work with Flash Player 11.3 (with Protected Mode enabled) → [adbe 3210917] Google IME doesn't work with Flash Player 11.3 (with Protected Mode enabled)

Comment 9

6 years ago
Hi,

I could reproduce this issue on the following environment:
- Mozilla Firefox 13.0
- Microsoft Windows 7 x64 SP1
- Adobe Flash 11.3.300.257
-- Google Japanese Input 1.5.1111.100
-- Mozc 1.5.1090.102 http://code.google.com/p/mozc/source/detail?r=115

There already is a known issue between Google Japanese Input / Mozc and Adobe Acrobat Reader regarding to the "Protected Mode", and the situation of this case seems to be very similar to it.
Here is the thread I explained the problem to users: https://productforums.google.com/d/topic/ime-ja/MuR7HpHBo9M/discussion

Problem details:

Let me use Mozc ( http://code.google.com/p/mozc/ ) to explain the detailed background so that anyone can investigate what is going on in source level when necessarily.

As far as I have observed, in FlashPlayerPlugin_11_3_300_257.exe, protected mode does not allow mozc_ja.ime to create Win32 namedpipe, through which mozc_ja.ime communicates with the Mozc's conversion process, named mozc_server.exe.
Unfortunately, mozc_ja.ime cannot work as expected in such a situation because it is designed to delegate almost all of the IME tasks to mozc_server.exe through the namedpipe-based IPC. You can see that the CreateFile API returns INVALID_HANDLE_VALUE in the following line.
http://code.google.com/p/mozc/source/browse/trunk/src/ipc/win32_ipc.cc?r=115#299

This is the info what we have found so far.
Hope this helps.
(Reporter)

Comment 10

6 years ago
I was told that Baidu IME http://ime.baidu.jp/ had the same issue. I've tested those again and here's the results:

Unaffected:
* Microsoft IME version 10.1.7601.0
* ATOK 2012 version 25.0.4.0

Affected, but unaffected with Protected Mode disabled
* Google IME version 1.4.1031.0
* Baidu IME version 2.6.1.1

Tested on Windows 7 Pro SP1, Firefox 13.0 and Flash 11.3.300.257.
(Reporter)

Updated

6 years ago
Summary: [adbe 3210917] Google IME doesn't work with Flash Player 11.3 (with Protected Mode enabled) → [adbe 3210917] Google/Baidu IME doesn't work with Flash Player 11.3 (with Protected Mode enabled)
(Reporter)

Updated

6 years ago
Summary: [adbe 3210917] Google/Baidu IME doesn't work with Flash Player 11.3 (with Protected Mode enabled) → [adbe 3210917] Google IME and Baidu IME don't work with Flash Player 11.3 (with Protected Mode enabled)
(Reporter)

Comment 11

6 years ago
ATOK doesn't work on Nico Nico Douga, one of the most popular video site in Japan.
http://www.nicovideo.jp/
Summary: [adbe 3210917] Google IME and Baidu IME don't work with Flash Player 11.3 (with Protected Mode enabled) → [adbe 3210917] IMEs don't work with Flash Player 11.3 (with Protected Mode enabled)
Here is the compatibility table (unofficial, written in Japanese):
http://www.d-toybox.com/studio/weblog/show.php?mode=single;id=2012061400

On Flash, most Japanese IMEs don't work under Kana input mode. I guess that that means IMEs call SetKeyboardState() for Kana-locking in different thread or process from the thread of focused window. So, Flash's protect mode completely broke Japanese IME compatibility.

I think that Adobe should disable protect mode in default settings.
(Reporter)

Comment 13

6 years ago
(Bug 763765 comment 5)
> 763387 is a known design limitation, whereby Flash Player running as a
> low-privilege process (a natural side-effect of the Protected Mode
> enhancements) does not have access to invoke many of the helper DLLs that
> power the popular Microsoft IMEs, and for third-party IMEs that would
> otherwise be invoked by a high-privilege Flash Player dll.  We are exploring
> options for re-enabling IME in future sandboxing release, but this will most
> likely require changes from Microsoft and/or Mozilla.  We're actively
> investigating options for providing full IME support while extending the
> full benefits of Protected Mode to those users.  
> 
> In this instance, Flash Player 10.3 isn't a bad workaround.  We are
> committed to supporting one major version of Flash Player back (10, in this
> case) until that version is 18 months old, or we release a new Major version
> of Flash Player.  
> 
> Users affected by these new IME limitations can revert to Flash Player 10.3
> to get the latest critical security updates while continuing to use their
> preferred IME.
Component: Plug-ins → Flash (Adobe)
Product: Core → Plugins
QA Contact: plugins → adobe-flash
Version: Trunk → 11.x
Whiteboard: [flash-11.3]

Comment 14

6 years ago
it is a known design limitation.  here is the technical summary from
https://bugbase.adobe.com/index.cfm?event=bug&id=3210917

"Those IMEs are set up to have the parent process use its DLL to run the IME. As the Flash Player process is now a low-privilege processes, and given that Microsoft has explicitly prohibited low-privileged processes from having DLL’s run new programs, IME won’t work under protected mode without enhancements to the browser or OS."

Updated

6 years ago
Component: Flash (Adobe) → Plug-ins
Product: Plugins → Core
Version: 11.x → Trunk

Comment 15

6 years ago
Given the current data, there is nothing for Mozilla to do here.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.