Closed Bug 763916 Opened 9 years ago Closed 9 years ago

Mobile viewport regression is yielding minuscule content

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
major

Tracking

(firefox14 verified, firefox15 verified, firefox16 verified, blocking-fennec1.0 soft, fennec15+)

VERIFIED FIXED
Firefox 16
Tracking Status
firefox14 --- verified
firefox15 --- verified
firefox16 --- verified
blocking-fennec1.0 --- soft
fennec 15+ ---

People

(Reporter: aaronmt, Assigned: mbrubeck)

References

Details

(Keywords: regression, reproducible)

Attachments

(1 file)

See directory of screenshots showcasing the apparent issue here: 

http://people.mozilla.com/~atrain/mobile/screenshots/mini/

URL's identified exposing this issue thus far in my testing

* http://www.yahoo.com
* http://www.facebook.com
* http://www.msn.com
* http://www.baidu.com
* http://www.youtube.com

Thus far this is only occurring on inbound as of (06/12)

Tested via:

Samsung Galaxy Nexus (Android 4.0.4)
20120612040225
http://hg.mozilla.org/integration/mozilla-inbound/rev/4a4519b018e9
I tested some inbound builds; this is a regression from bug 762043.
Blocks: 762043
Component: Layout → General
Product: Core → Fennec Native
QA Contact: layout → general
Summary: Mobile layout regression is yielding minuscule content → Mobile viewport regression is yielding minuscule content
Assignee: nobody → mbrubeck
Attached patch patchSplinter Review
(NaN == NaN) is false, so the body of this if statement never executes.

This problem was introduced with bug 744070, but I guess mobile doctypes are more common than HandheldFriendly.
Attachment #632277 - Flags: review?(bugmail.mozilla)
Bug 744070 introduced the code bug, breaking support for the "HandheldFriendly" tag.  This problem exists in Firefox 14 and 15.  Fortunately this tag is not very common in the wild.

Bug 762043 extended the bug, breaking support for WAP/WML/XHTML Mobile doctypes.  This is much more common in the wild.  This problem exists in Firefox 16 only.
blocking-fennec1.0: --- → ?
Blocks: 744070
Attachment #632277 - Flags: review?(bugmail.mozilla) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/7beb43191437
Status: NEW → ASSIGNED
Target Milestone: --- → Firefox 16
Comment on attachment 632277 [details] [diff] [review]
patch

This patch fixes a major regression in Fx16 and a minor regression in Fx14/15.  See comment 4 for details.

I think we should take this in Aurora for Firefox 15 to fix the minor regression.  But since it does not seem to affect many sites in the wild, I think it's okay if we decide it's too late in the release cycle to take for Fx14.  It might also be a good candidate for 14.0.1.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 744070

User impact if declined: Fennec no longer uses a mobile layout for sites with a "HandheldFriendly" meta tag and no "viewport" meta tag.

Testing completed (on m-c, etc.): Landed on m-i on 6/12.  We do not have good automated testing for this feature (bug 756473).

Risk to taking this patch (and alternatives if risky): This is a low-risk, one-line Android-only patch.

String or UUID changes made by this patch: None.
Attachment #632277 - Flags: approval-mozilla-beta?
Attachment #632277 - Flags: approval-mozilla-aurora?
tracking-fennec: --- → 15+
blocking-fennec1.0: ? → soft
Attachment #632277 - Flags: approval-mozilla-beta?
Attachment #632277 - Flags: approval-mozilla-beta+
Attachment #632277 - Flags: approval-mozilla-aurora?
Attachment #632277 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/7beb43191437
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
All links added in this bug are displayed correctly and at the correct zoom level/font size.

Verified fixed on:
Aurora 15.0a2 2012-07-09/Nightly 16.0a1 2012-07-09/ Firefox Mobile 14.0b11
HTC Desire
Android 2.2.2
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.