Closed Bug 744070 Opened 8 years ago Closed 8 years ago

Page starts out zoomed, doesn't resize/scroll correctly

Categories

(Firefox for Android :: General, defect)

All
Android
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 15
Tracking Status
firefox14 --- fixed
firefox15 --- verified
blocking-fennec1.0 --- +

People

(Reporter: toonetown, Assigned: blassey)

References

()

Details

(Keywords: dev-doc-needed)

Attachments

(7 files, 1 obsolete file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_3) AppleWebKit/535.18.5 (KHTML, like Gecko) Version/5.2 Safari/535.18.5

Steps to reproduce:

Using the nightly from 2012-04-10, Loaded the page at http://jobview.monster.com/GetJob.aspx?JobID=108722656&aid=107418909&WT.mc_n=PSAHG10


Actual results:

The page is zoomed in too much (screenshot 1) - You can pan just fine as long as you don't zoom back out - however, zooming out places the same amount of the page in a smaller window, surrounded by checkerboard pattern (screenshot 2).  You can then only scroll within that smaller viewport (screenshot 3).



Expected results:

Ideally, the page should fit in the viewable window when loaded - however, zooming out on the page shouldn't shrink the viewport - and scrolling should behave correctly after zooming out.
Did not mention, I have seen this on both Android 2.3.4 and 4.0.4
I just tried this on Aurora 13a2 from 2012-04-16 and didn't have the issue.
I was able to reproduce this issue on:
Nightly 14.0a1 (2012-04-17) 20120417030641
Samsung Galaxy SII (Android 2.3.4)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attached file Log file
blocking-fennec1.0: --- → ?
Attached image onload screenshot
Attachment #613661 - Attachment is obsolete: true
Martijn, can you get a reduced test case here and see if its a dupe of any other 746185 deps?
Paul, do you think this is related to the issues you saw on your slideshow app?
Keywords: qawanted
pinch zooming out essentially is showing the same problem as the duckduckgo bug. (bug 741992).   awaiting for a reduced testcase in comment 8.
Steps to reproduce:
1. Go to http://jobview.monster.com/GetJob.aspx?JobID=108722656&aid=107418909&WT.mc_n=PSAHG10(shortlink http://bit.ly/J8EDjZ) and select continue to Job skipping the app screen.
2. Double tap on the article.
3. Double tap a second time to zoom out.

Actual results:
 In ~75% of the tries the viewport is created very small loading the page on a quarter of the screen. Similar to Bug 734051. I can also see when trying to scroll the page being disconnected from the background and being scrolled separatly.
 In ~25% of the tries at the first zoom the page becomes unresponsive to zooms and scrolls.
Keywords: qawanted
blocking-fennec1.0: ? → +
Assignee: nobody → bugmail.mozilla
With the latest m-c build the behaviour seems better. The job posting seems to have changed since it's no longer the same as in the attached screenshots, but the page still has overflow:hidden set on the body, which presumably was the cause of the weird behaviour.

The fix from bug 746120 now makes the page render normally on initial load. It is not possible to pan the page, which is expected/desired behaviour (the page is setting overflow:hidden which makes the page not pannable).

Zooming in results in some weird behaviour:
- panning while zoomed is jumpy
- parts of the page render in duplicate/blurry (looks like a tiling issue?, attaching screenshot).
Found another site where the page loads significantly zoomed out.   Reproduces on Galaxy Nexus, 4.0.2, and HTC Sensation, 2.3.4.   UA sniffing is a desktop site.

Stock android sniffs a mobile site, so no repro there.

http://icanhas.cheezburger.com/
Adding dependency on bug 750535 for the issue/screenshot in comment 12.
Depends on: 750535
(In reply to Tony Chung [:tchung] from comment #13)
> Found another site where the page loads significantly zoomed out.  
> Reproduces on Galaxy Nexus, 4.0.2, and HTC Sensation, 2.3.4.   UA sniffing
> is a desktop site.
> 
> Stock android sniffs a mobile site, so no repro there.
> 
> http://icanhas.cheezburger.com/

This is because the website has all sorts of mobile-friendly indicators:

    <meta name="HandheldFriendly" content="True">
    <meta name="MobileOptimized" content="320">
    <meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0">

So we render it at a 1.0 scale as requested. I verified that taking out the HandheldFriendly and viewport tags makes us render it zoomed out as expected. (We don't support the MobileOptimized tag so that has no effect).
Assignee: bugmail.mozilla → blassey.bugs
Attached patch patchSplinter Review
this patch only honors the HandheldFriendly attribute if no viewport meta tag has been specified. This seems like the right thing to do, given that HandheldFriendly isn't very well specified and viewport meta tag is. Also, this fixes this particular website.
Attachment #620357 - Flags: review?(mbrubeck)
Comment on attachment 620357 [details] [diff] [review]
patch

This change seems fine, though it's not clear to me why it fixes http://icanhas.cheezburger.com/ since the viewport meta tag contains basically the same values we use for HandheldFriendly.  (Really I think this is an evangelism bug, since none of those tags make sense for this page.)

Also, this will not fix the monster.com page from comment 0, right?
Attachment #620357 - Flags: review?(mbrubeck) → review+
monster is the site I tested with this patch since its what the bug was filed for. icanhas.cheesebuger.com looks fine, its initially zoomed in as their viewport dictates, but I'm able to pan and zoom and see the entire page.

Anything beyond this fix is certainly an evangelism bug.
Oh, got it.  I didn't realize that monster.com had a HandheldFriendly tag too, since it apparently doesn't serve that to desktop Firefox.  (The cheezburger site serves it to both desktop and mobile.)
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Comment on attachment 620357 [details] [diff] [review]
patch

Mobile only, release blocker.
Attachment #620357 - Flags: approval-mozilla-aurora+
The issue is not reproducible anymore on:
Nightly 15.0a1 (2012-05-21)
Device: HTC Desire Z
OS: Android 2.3.3

Using the STR from comment 11.

The issue still occurs for Aurora Fennec 14.0a2(2012-05-21) on HTC Desire Z
(Android 2.3.3). Bug 757409 was opened for this issue.
Status: RESOLVED → VERIFIED
Depends on: 763916
Blocks: 783565
You need to log in before you can comment on or make changes to this bug.