Crash when Restarting FireFox through the Firefox Add-On Installer with Flash Player

RESOLVED DUPLICATE of bug 747683

Status

()

Core
Plug-ins
RESOLVED DUPLICATE of bug 747683
6 years ago
6 years ago

People

(Reporter: magnus, Unassigned)

Tracking

13 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/536.5 (KHTML, like Gecko) Chrome/19.0.1084.56 Safari/536.5

Steps to reproduce:

1.) Go here: http://www.homestarrunner.com
2.) Click Firefox > Add-Ons
3.) Search for AdBlock Plus (or anything else, really)
4.) Install
5.) When given the restart firefox prompt, click restart
6.) Check out the new crash log in C:\Users\<username>\AppData\Roaming\Mozilla\Firefox\Crash Reports\pending


Actual results:

Crash is silent; there are no visual clues except looking in the pending Crash Reports directory.

This is only reproducible with Flash Player Protected Mode on AND plugin IPC on (running plugins out of process with plugin-container.)  No crash with plugin IPC off.

here's the crash call stack in plugin-container.exe:

	10a855a0()	
 	ntdll.dll!_RtlProcessFlsData@4()  + 0xea bytes	
 	ffffffff()	



Expected results:

No pending crash report should have generated.
(Reporter)

Comment 1

6 years ago
stack in plugin-container.exe (not attached to firefox.exe):

        ntdll.dll!_ZwRaiseException@12()  + 0x12 bytes	
 	ntdll.dll!_ZwRaiseException@12()  + 0x12 bytes	
 	ntdll.dll!_RtlDispatchException@8()  + 0x52 bytes	
 	ntdll.dll!_KiUserExceptionDispatcher@8()  + 0xf bytes	
 	102ba569()	
 	kernel32.dll!@BaseThreadInitThunk@12()  + 0x12 bytes	
 	ntdll.dll!___RtlUserThreadStart@8()  + 0x27 bytes	
 	ntdll.dll!__RtlUserThreadStart@8()  + 0x1b bytes
Component: Untriaged → Plug-ins
Product: Firefox → Core
QA Contact: untriaged → plugins

Comment 2

6 years ago
I have been a bunch of dumps in the pending folder since June 9, but no dump files appear after applying your STR in 13.0.

Comment 3

6 years ago
Jeromie Clark says in bug 763237 comment 39 that the patch of bug 747683 fixes the problem. Can you confirm using Firefox 13.0.1 (ftp://ftp.mozilla.org/pub/firefox/nightly/13.0.1-candidates/build1/)?

Comment 4

6 years ago
Does the issue still happen?

Comment 5

6 years ago
I'm not seeing it in FF 13.0.1.  I haven't tried it on newer versions, though.

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 747683
You need to log in before you can comment on or make changes to this bug.