Last Comment Bug 747683 - [adbe 3172259] Crash Report [@ LdrShutdownProcess ] with Flash 11.3 "Protected Mode for Firefox"
: [adbe 3172259] Crash Report [@ LdrShutdownProcess ] with Flash 11.3 "Protecte...
Status: VERIFIED FIXED
: crash
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: x86 Windows 7
: -- critical with 6 votes (vote)
: mozilla16
Assigned To: Benjamin Smedberg [:bsmedberg]
: Paul Silaghi, QA [:pauly]
Mentors:
https://crash-stats.mozilla.com/repor...
: 763142 763276 764494 765176 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-21 15:59 PDT by MrX1980
Modified: 2014-05-12 10:05 PDT (History)
35 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified
verified
verified
14+
verified


Attachments
Don't unload plugin libraries, rev. 1 (924 bytes, patch)
2012-06-13 15:04 PDT, Benjamin Smedberg [:bsmedberg]
jaas: review+
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta+
akeybl: approval‑mozilla‑release+
lukasblakk+bugs: approval‑mozilla‑esr10+
Details | Diff | Review

Description MrX1980 2012-04-21 15:59:09 PDT
If Flash Player 11.3.x plugin was loaded (website with Flash content) in Firefox (11.0 - 14.0a1) and I close Firefox I'm getting "Crash Report [@ LdrShutdownProcess ]".

It seems that because of the new Flash Player function "Protected Mode for Firefox" Firefox cannot terminate the Flash Player plugin right.

https://crash-stats.mozilla.com/report/index/4d2d5179-b494-4302-8916-b699d2120421

Is it more a Firefox/Core or Flash Player problem?
Comment 1 MrX1980 2012-04-28 10:27:28 PDT
With Flash Player 11.3.300.241 (internal build) too, but I have fewer crashes against beta2.

Last Crash:
https://crash-stats.mozilla.com/report/index/bp-16f6f40a-49e9-4bbb-9a87-060162120428
http://www.wdr.de/mediathek/html/regional/2012/04/27/koelner-treff.xml

reproducible: very rarely now
Comment 2 Anonymous 2012-06-09 08:51:12 PDT
With Firefox 14.0b1 and Flash 11.3.300.257 I'm seeing this regularly.
Comment 3 Alice Wyman 2012-06-09 19:07:37 PDT
I installed Flash 11.3.300.257 and, although it appeared to be working properly, I am having the same "silent crash" issue after closing Firefox 13 that was reported here:

http://forums.adobe.com/thread/1020038 
https://bugbase.adobe.com/index.cfm?event=bug&id=3209832
Flash Player 11.3.300.257 causes Exception Access Violation in Firefox 13 

I noticed it after looking in my %APPDATA%\Mozilla\Firefox\Crash Reports\Pending folder and finding two sets of .dmp and .extra files from today. I then went to about:crashes and submitted one of the two crash reports and got this report:

https://crash-stats.mozilla.com/report/index/a21db6b6-3bee-4d24-8fd2-8170b2120610
Comment 4 MrX1980 2012-06-10 00:37:52 PDT
[Platform_Windows] Firefox - Crash Report [@ LdrShutdownProcess ]
https://bugbase.adobe.com/index.cfm?event=bug&id=3172259

Adobe: "We have an internal bug for tracking this problem."
(12:28:47 AM PDT May 17, 2012)
Comment 5 MrX1980 2012-06-10 12:24:28 PDT
"workaround"
How do I disable Flash Player's protected mode for Firefox?
http://forums.adobe.com/thread/1018071?tstart=0
Comment 6 candaules 2012-06-10 15:30:19 PDT
here my issue (the same)
https://bugzilla.mozilla.org/show_bug.cgi?id=763276

workaround: in the flash folder edit the file mms.cfg:

ProtectedMode=0

the plugincontainer does NOT crash after closing firefox. I warmly hope that this critical issue will be fixed soon. thanks.
Comment 7 Scoobidiver (away) 2012-06-10 22:52:26 PDT
*** Bug 763276 has been marked as a duplicate of this bug. ***
Comment 8 candaules 2012-06-11 02:26:32 PDT
bad news guys!
https://bugbase.adobe.com/index.cfm?event=bug&id=3210025

despite my crash reports adobe was unable torepruduce this very critical bug. 
good luck to us and everyone.
Comment 9 candaules 2012-06-11 03:31:28 PDT
	Priority 4-Very High
Frequency All users will encounter 
https://bugbase.adobe.com/index.cfm?event=bug&id=3209832

https://bugbase.adobe.com/index.cfm?event=bug&id=3172259
Comment 10 candaules 2012-06-11 03:33:38 PDT
...this looks as a "less silent" crash ;)
Nome evento problema:	BEX
  Nome applicazione:	plugin-container.exe
  Versione applicazione:	13.0.0.4535
  Timestamp applicazione:	4fc8de63
  Nome modulo con errori:	NPSWF32_11_3_300_257.dll_unloaded
  Versione modulo con errori:	0.0.0.0
  Timestamp modulo con errori:	4fc821fc
  Offset eccezione:	64f99903
  Codice eccezione:	c0000005
  Dati eccezione:	00000008
  Versione SO:	6.0.6002.2.2.0.768.3
  ID impostazioni locali:	1040
  Informazioni aggiuntive 1:	27dd
  Ulteriori informazioni 2:	b76caa7c2627bab0b68e16f682ad848f
  Ulteriori informazioni 3:	ff08
  Ulteriori informazioni 4:	4fae96fb14b9fa70f5513f6819ad1b00


==>>> very important:
disabling protection mode in flash 11.3, all is ok!!!

no crash (because > no additional processes in task manager _flashplugin_-- that conflict with container ,)
Comment 11 candaules 2012-06-11 08:31:59 PDT
to mozilla dev:
https://bugbase.adobe.com/index.cfm?event=bug&id=3210091
Comment 12 candaules 2012-06-11 14:03:36 PDT
vista32.
Comment 13 cehona_hal9100 2012-06-12 02:09:59 PDT
Windows 7 x86 FF 13 Crash with Flash 11.3.300.257 :-(
Comment 14 smadayag 2012-06-12 10:28:17 PDT
is this also reated to realplayer?  can someone who is experiencing this particular crash signature give it a try?  thanks...
http://helpx.adobe.com/flash-player/kb/crash-leaving-browser-page-flash.html
Comment 15 candaules 2012-06-12 10:58:35 PDT
NO realplayer here ;)
Comment 16 Underpass 2012-06-12 12:21:36 PDT
Plugin systematically crashing, Windows 7 with Service Pack 1, RealPlayer never installed.
Comment 17 Alice Wyman 2012-06-12 14:41:10 PDT
(In reply to smadayag from comment #14)
> is this also reated to realplayer?  can someone who is experiencing this
> particular crash signature give it a try?  thanks...
> http://helpx.adobe.com/flash-player/kb/crash-leaving-browser-page-flash.html

Never installed RealPlayer either.
Comment 18 Sue 2012-06-12 15:18:28 PDT
Not too good with computers but I managed to find my mms.cfg file and it will allow me to open it and type in protected mode=0, but then it says that access to this file is denied.  Please can someone take me through step by step how to edit this file
Comment 19 smadayag 2012-06-12 15:24:54 PDT
copy the file over to somewhere writable (eg Desktop).  make the edits and copy it back, overwriting the existing mms.cfg.
Comment 20 candaules 2012-06-12 15:26:59 PDT
doing so, so problem here. 
I guess that the sandbox may "damage" the container.exe
Comment 21 Sue 2012-06-12 15:43:08 PDT
Sorry, but I've copied and pasted the file to my desktop, added the line....how do I overwrite the existing mms.cfg file?
Comment 22 smadayag 2012-06-12 16:20:05 PDT
(In reply to Sue from comment #21)
> Sorry, but I've copied and pasted the file to my desktop, added the
> line....how do I overwrite the existing mms.cfg file?

drag it back to its original location and accept an overwrite.  or delete the original and drag the edited version to that location.
Comment 23 Sue 2012-06-13 00:47:45 PDT
@ smadayag   Thank you so much for your help.  All done and hopefully I'll be able to do some work today, thanks again!!
Comment 24 Benjamin Smedberg [:bsmedberg] 2012-06-13 15:04:00 PDT
Created attachment 632900 [details] [diff] [review]
Don't unload plugin libraries, rev. 1

After discussion, it seems possible or even likely that Flash started using an atexit handler, which since we're unloading the Flash library is then crashing.
Comment 25 candaules 2012-06-13 15:12:18 PDT
maybe. thank you.

that is right as described in the crash report from Vista32:
Nome applicazione:	plugin-container.exe
  Versione applicazione:	13.0.0.4535
  Timestamp applicazione:	4fc8de63
  Nome modulo con errori:	NPSWF32_11_3_300_257.dll_unloaded
Comment 26 Benjamin Smedberg [:bsmedberg] 2012-06-13 15:19:32 PDT
Comment on attachment 632900 [details] [diff] [review]
Don't unload plugin libraries, rev. 1

[Approval Request Comment]
Regression caused by (bug #): Flash 10.3 release
If this is not a sec:{high,crit} bug, please state case for ESR consideration: this works around an issue in Flash 10.3 which causes user-visible crash dialogs
User impact if declined: user-visible crash dialogs
Fix Landed on Version:
Risk to taking this patch (and alternatives if risky): pretty small, the plugin process exits almost immediately after this code runs
String or UUID changes made by this patch: None
Comment 27 Benjamin Smedberg [:bsmedberg] 2012-06-13 15:21:41 PDT
https://hg.mozilla.org/mozilla-central/rev/8cf5423b0213
Comment 28 Alex Keybl [:akeybl] 2012-06-13 17:40:40 PDT
Comment on attachment 632900 [details] [diff] [review]
Don't unload plugin libraries, rev. 1

[Triage Comment]
Approving for Aurora and Beta since we're considering this for a 13.0.1 release.
Comment 30 Tetsuro Kato (tete) 2012-06-14 07:32:37 PDT
*** Bug 763142 has been marked as a duplicate of this bug. ***
Comment 31 Bob Clary [:bc:] 2012-06-14 07:38:27 PDT
This appears to have fixed the explosive crashes on shutdown for Beta, Aurora and Nightly in crash automation.
Comment 32 Alex Keybl [:akeybl] 2012-06-14 09:08:29 PDT
Comment on attachment 632900 [details] [diff] [review]
Don't unload plugin libraries, rev. 1

[Triage Comment]
Approving for landing on mozilla-release, as this causes crashes on shutdown with Adobe's latest release. We believe it's very low risk, and would only cause regressions around shutdown.

QA - please test having plugins loaded on the page and closing the browser as part of sign-offs.
Comment 33 Benjamin Smedberg [:bsmedberg] 2012-06-14 09:17:06 PDT
https://hg.mozilla.org/releases/mozilla-release/rev/5bd841d76b3a for 13.0.1
Comment 34 Lukas Blakk [:lsblakk] use ?needinfo 2012-06-14 15:03:48 PDT
Tracking for the next ESR since we won't chemspill for this, but we'll want it in.
Comment 35 Lukas Blakk [:lsblakk] use ?needinfo 2012-06-14 15:05:46 PDT
Comment on attachment 632900 [details] [diff] [review]
Don't unload plugin libraries, rev. 1

[Triage Comment]
As Alex said for aurora/beta: it's very low risk, and would only cause regressions around shutdown - seems like a good fix to take on ESR for better user experience with less crashes on shutdown.
Comment 36 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-06-14 15:39:25 PDT
@MrX1980, we now have 13.0.1 candidate builds:
ftp://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/13.0.1-candidates/build1/

Can you please test it to see if this is fixed for you?
Comment 37 MrX1980 2012-06-14 17:20:29 PDT
After a quick test on two devices I don't have the crash anymore with Firefox 13.0.1 and Flash Player 11.3.300.257
Thanks to all.
Comment 38 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-06-15 09:52:06 PDT
Thanks a lot MrX1980. If you have a chance, can you please also test this with Firefox 14.0b7 and 15.0a2? These builds should also be fixed.
Comment 39 MrX1980 2012-06-15 09:56:37 PDT
All Firefox 2012-06-14 builds (release -> nightly) are ok for me.
Comment 40 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-06-15 10:00:49 PDT
Thanks again, MrX1980!
Comment 41 candaules 2012-06-15 11:00:28 PDT
verified for vista32 too? thanks.
Comment 42 Matthias Versen [:Matti] 2012-06-15 16:01:44 PDT
*** Bug 765176 has been marked as a duplicate of this bug. ***
Comment 43 teodolo 2012-06-16 02:06:43 PDT
Protected mode disabled. Is now working. Thanks
Comment 44 Scoobidiver (away) 2012-06-16 02:11:28 PDT
teodolo, you should re-enable Protected Mode for Firefox in Flash because Firefox 13.0.1 fixes the issue.
Comment 45 programings 2012-06-16 05:11:09 PDT
Hello!

My problems with Flash 11.3.300.257 and Mozilla Firefox 13.0.1 continues after update!

Flash plugin work slowly only under Firefox on my system ! Sometimes i see white screens too and when i move my cursor on white screen, i see the flash content on the parts!

Under Opera and Internet Explorer i don`t have this problem !
Comment 46 candaules 2012-06-16 05:14:07 PDT
Hi.
I still have the issue where when I visit a page with Flash content the first time, it causes the browser to loose focus. That doesn't happen with Protected Mode off.
Comment 47 programings 2012-06-16 05:21:17 PDT
My problem is here with and without protected mode !

I think here have another bug !
Comment 48 Scoobidiver (away) 2012-06-16 05:41:24 PDT
This bug is not a tracking bug for issues with Flash 11.3. The crash on shutdown is fixed.

(In reply to programings from comment #45)
> Flash plugin work slowly only under Firefox on my system ! Sometimes i see
> white screens too and when i move my cursor on white screen, i see the flash
> content on the parts!
It's likely bug 763459. For workarounds, see: https://support.mozilla.org/kb/flash-113-doesnt-load-video-firefox

(In reply to candaules from comment #46)
> I still have the issue where when I visit a page with Flash content the
> first time, it causes the browser to loose focus. That doesn't happen with
> Protected Mode off.
File a new bug.
Comment 49 candaules 2012-06-16 05:46:24 PDT
no more time to file a new bug for firefox-adobe. I remain with this issue. thanks.
Comment 50 Underpass 2012-06-17 04:18:20 PDT
Are you sure this bug is fixed?
Is Firefox 14 beta 7 supposed not to have the problem? 


At work, last friday I installed the last beta of Firefox 14 and the "silent crashes" were not solved. I disabled the Flash protected mode again.
Comment 51 Kohei Yoshino [:kohei] 2012-06-17 04:36:22 PDT
(In reply to Simone Lando from comment #50)
> At work, last friday I installed the last beta of Firefox 14 and the "silent
> crashes" were not solved. I disabled the Flash protected mode again.

This bug fixed a crash on quit. Your issue might be Bug 763237 where Adobe has been working on.
Comment 52 Alice Wyman 2012-06-17 04:43:35 PDT
For me, the shutdown bug appears to be fixed in Firefox 13.0.1 but when I tried Flash in Firefox 14 Beta 7 (which I installed this morning) I found another "silent crash" had occurred at shutdown:

https://crash-stats.mozilla.com/report/index/bp-f047da2d-ee7b-49f1-8d33-309452120617
Comment 53 MrX1980 2012-06-17 04:54:09 PDT
14.0b7 build 1 is from 2012-06-12
There should be a build 2 from 2012-06-14
Has someone forget to compile build 2 ?

On my quick test I don't have the crash but now I got it again:
Firefox 14.0 Crash Report [@ LdrShutdownProcess ] 
https://crash-stats.mozilla.com/report/index/bp-df81dea0-50b7-4a0f-b31c-56d6b2120617
Comment 54 Scoobidiver (away) 2012-06-17 05:24:38 PDT
The patch will land in Beta 8. See http://hg.mozilla.org/releases/mozilla-beta/graph
Comment 55 Scoobidiver (away) 2012-06-18 01:22:44 PDT
*** Bug 763276 has been marked as a duplicate of this bug. ***
Comment 56 dennis.lundberg 2012-06-20 04:54:59 PDT
I just wanted write and confirm that the workaround described in Comment 6 (adding "ProtectedMode=0" to the file mms.cfg) works for Firefox 3.6.27 on Windows 7 Enterprise 64-bit.
Comment 57 Bob Hill 2012-06-27 04:20:26 PDT
(In reply to candaules from comment #46)
> Hi.
> I still have the issue where when I visit a page with Flash content the
> first time, it causes the browser to loose focus. That doesn't happen with
> Protected Mode off.

Hello candaules,

Regarding the focus issue, you and any other users experiencing the
focus issue might like to add votes to Adobe bug number 3223393:
https://bugbase.adobe.com/index.cfm?event=bug&id=3223393
The more votes, the higher priority Adobe should assign to the bug.

Kind regards, Bob Hill   (just another user, not Adobe employee)
Comment 58 john senchak 2012-07-01 08:06:15 PDT
I  am  still seeing major issues with running  Adobe Flash   and Firefox  version 12   , 13, and 13.01   with  Zynga's   Cityville.   I  noticed  that problems occur in both  Flash version's   10.3.183.7 and   11.3.300.262

Problems  occur with computer using Windows Vista and 2 GB  of memory

1) Flashes crashes   taken down other  flash programs running in other sites  that are in separate  tabs

2) Memory leakage issues,  where all the memory used by Cityville is not returned  to Windows Vista after exiting  to Facebook.

3) Start up issues with Flash during the start routine  of  running Cityville

4)  Heavy  usage of Cityville causes memory to max out slowing down the function of the browser.  This usual  cause the Windows to  utilize  the swap file slowing down the  whole computer to a crawl.

5) Excessive defrag of the hard drive.   When  Cityville is not used under Firefox  then this issue is not seen

6)Degrades  the  performance of Windows Vista usual  during exiting into and out of sleep mode.  Again  if Cityville   is not used with Firefox  then the problem doesn't happen.

7) Degrades the performance  of Firefox over time with heavy usage of playing  Cityville.   This happened when the browser  is not shut down on a regular  basis and left running for weeks.  Note here that   I am real impressed that  Firefox  12+  can sustain   heavy usage over   a period of weeks  without a restart. Cityville  causes memory  leakage issues  that cause you to either restart or even reboot the computer. If I didn't run Cityville, I could probably   go over a month without a restart of the broswer

8) Upgraded   browser to  version  13.1  and  Adobe Flash to the latest  version (11.3.300.262) last night  and still see the same issues with Cityville
Comment 59 candaules 2012-07-01 10:00:32 PDT
2) Memory leakage issues,  where all the memory used by Cityville is not
returned  to Windows Vista after exiting  to Facebook.


I confirm this.
the new layout of facebook fatiguates firefox, 8 tabs facebook albums = 50 tabs concerning the ram. fullscreen mode = 1Gb ram firefox.
as you are watching a 15MP foto ;)
this not due to flash player, but is an issue in firefox since november.
Comment 60 Matthias Versen [:Matti] 2012-07-01 11:06:21 PDT
>this not due to flash player, but is an issue in firefox since november.
and why are you posting this to this bug ?
This bug is limited to a Mozilla crash during the flash shutdown and this crash is fixed. This bug is _not_ about other issues like high memory usage, memory leaks, flash crashes or other flash or browser issues.
Comment 61 candaules 2012-07-01 12:50:17 PDT
In reply to the previous post! ;)
Comment 62 candaules 2012-07-01 12:50:50 PDT
tell it to john senchak please, not to me ;)
Comment 64 Scoobidiver (away) 2012-07-02 22:30:18 PDT
*** Bug 764494 has been marked as a duplicate of this bug. ***
Comment 65 Lukas Blakk [:lsblakk] use ?needinfo 2012-07-03 12:34:26 PDT
This still needs to get landed to the ESR branch, please let release-management know if there's any change otherwise go ahead and land asap.
Comment 66 Benjamin Smedberg [:bsmedberg] 2012-07-03 12:54:48 PDT
I don't really know anything about ESR procedures, what tree/branch would this land to for ESR?
Comment 67 ammar.m.alshaikh 2012-07-05 19:22:54 PDT
My browsing life have become a living hell because of this :s
Comment 68 Scoobidiver (away) 2012-07-05 23:26:36 PDT
(In reply to ammar.m.alshaikh from comment #67)
> My browsing life have become a living hell because of this :s
Using Firefox 13.0.1 will make your life a paradise as this specific issue of Flash crashes during shutdown is fixed in this version.
If you have other issues with Flash 11.3, please file a new bug after checking your problem is not already reported.
Comment 69 Lukas Blakk [:lsblakk] use ?needinfo 2012-07-06 00:47:20 PDT
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #66)
> I don't really know anything about ESR procedures, what tree/branch would
> this land to for ESR?

The info in https://wiki.mozilla.org/Release_Management/ESR_Landing_Process should help here.  We don't have try for mozilla-esr10 branch, so please keep an eye on your push after you land to make sure there isn't unexpected fallout.
Comment 70 candaules 2012-07-06 04:26:14 PDT
the one and only bug that should be filed is the loosing of the focus in ff when the container process is not running after watching flash video.
I hope that someone in the world may want to file this bug report.
Comment 71 Scoobidiver (away) 2012-07-06 05:44:44 PDT
(In reply to candaules from comment #70)
> the one and only bug that should be filed is the loosing of the focus in ff
It's bug 766009.
Comment 72 Benjamin Smedberg [:bsmedberg] 2012-07-11 10:55:37 PDT
https://hg.mozilla.org/releases/mozilla-esr10/rev/a2c73a272160
Comment 73 Paul Silaghi, QA [:pauly] 2012-07-17 07:41:24 PDT
Everything looks ok on FF 10.0.6 ESR, but I also couldn't reproduce the issue on FF 11, 10.0.5 ESR with Flash 11.3.300.257, 11.3.300.265.
Comment 74 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-09-13 15:22:02 PDT
Paul, at this point we'll just have to trust this verified for ESR based on comment 73. Unless you can find a way to reproduce this.
Comment 75 banakon 2014-05-11 08:24:42 PDT
its sure that it has been fixed?
https://crash-stats.mozilla.com/report/index/929df07d-08e2-4b5e-9b2c-881d62140510
Comment 76 Georg Fritzsche [:gfritzsche] [away Jun 24 - Jul 3] 2014-05-12 03:43:57 PDT
(In reply to banakon from comment #75)
> its sure that it has been fixed?
> https://crash-stats.mozilla.com/report/index/929df07d-08e2-4b5e-9b2c-
> 881d62140510

This doesn't look related to the bug here. If you have reliable steps to reproduce the hang you experience, please file a new bug.
Comment 77 banakon 2014-05-12 06:11:30 PDT
I filed it, on the 11th may with the link to youtoube and the task (watching only, not problems; by refreshing or by moving the pointer to jump fowrad I become hang).

Note You need to log in before you can comment on or make changes to this bug.