Closed Bug 764573 Opened 8 years ago Closed 4 years ago

Remove MAX_SCHEMA_RETRY define now that we have SQLite 3.7.13

Categories

(Toolkit :: Storage, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla52
Tracking Status
firefox52 --- fixed

People

(Reporter: bent.mozilla, Assigned: mak)

References

Details

Attachments

(1 file)

IndexedDB needed a larger MAX_SCHEMA_RETRY in order to work before SQLite 3.7.13, but now it shouldn't be needed.
I don't think it's worth it.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 877657
oops, we can indeed remove it cause 3.7.17 set the default to 50 and we use 25.
Status: RESOLVED → REOPENED
Priority: -- → P3
Resolution: WONTFIX → ---
Assignee: nobody → mak77
Comment on attachment 8807879 [details]
Bug 764573 - Remove MAX_SCHEMA_RETRY since now the default value is larger.

https://reviewboard.mozilla.org/r/90866/#review90594
Attachment #8807879 - Flags: review?(bugmail) → review+
Pushed by mak77@bonardo.net:
https://hg.mozilla.org/integration/autoland/rev/d7f727af4b9f
Remove MAX_SCHEMA_RETRY since now the default value is larger. r=asuth
https://hg.mozilla.org/mozilla-central/rev/d7f727af4b9f
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
You need to log in before you can comment on or make changes to this bug.