The default bug view has changed. See this FAQ.

Screen orientation isn't unlocked when the document is left without explicitly exiting fullscreen

VERIFIED FIXED in Firefox 15

Status

()

Core
DOM
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Martijn Wargers (dead), Assigned: mounir)

Tracking

({mobile, testcase})

Trunk
mozilla15
mobile, testcase
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox13 unaffected, firefox14 wontfix, firefox15+ verified, firefox16 verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 633083 [details]
testcase

See testcase, when tapping on the portrait or landscape button, you have locked Fennec to landscape/portrait mode, which should not be possible.
(Reporter)

Comment 1

5 years ago
I guess bug 757791 is related.
(Assignee)

Comment 2

5 years ago
(In reply to Martijn Wargers [:mw22] (QA - IRC nick: mw22) from comment #1)
> I guess bug 757791 is related.

No. I think the issue here is that reload() should unlock the screen but doesn't do that. I will try to have a look when I will find time to solve my link issue on Android.
(Assignee)

Updated

5 years ago
Blocks: 740190
(Assignee)

Updated

5 years ago
Blocks: 740188
No longer blocks: 740190
(Assignee)

Updated

5 years ago
Component: General → DOM
OS: Android → All
Product: Fennec Native → Core
QA Contact: general → general
Hardware: ARM → All
Summary: Can lock screen in portrait/landscape mode in this case using mozRequestFullScreen() → Screen orientation isn't unlocked when the document is left without explicitly exiting fullscreen
(Assignee)

Comment 3

5 years ago
Created attachment 635238 [details] [diff] [review]
Patch v1

This should fix it.
I have a patch that will make sure that unlock() is a no-op if the screen isn't currently locked (in Android backend).
Assignee: nobody → mounir
Status: NEW → ASSIGNED
Attachment #635238 - Flags: review?(bugs)
(Assignee)

Updated

5 years ago
status-firefox14: --- → wontfix
status-firefox15: --- → affected
status-firefox16: --- → affected
tracking-firefox15: --- → ?
(Assignee)

Updated

5 years ago
Blocks: 766903

Updated

5 years ago
Attachment #635238 - Flags: review?(bugs) → review+
(Assignee)

Updated

5 years ago
Target Milestone: --- → mozilla16
(Assignee)

Updated

5 years ago
Attachment #635238 - Flags: checkin+
(Assignee)

Comment 4

5 years ago
Comment on attachment 635238 [details] [diff] [review]
Patch v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 740188
User impact if declined: when navigating to a page using screen lock, Firefox might be stuck to the same orientation with the only salvation being restarting Firefox
Risk to taking this patch (and alternatives if risky): only regressions in screen lock features, unlikely worse than keeping this bug
String or UUID changes made by this patch: none
Attachment #635238 - Flags: approval-mozilla-aurora?
(Reporter)

Updated

5 years ago
Keywords: mobile
https://hg.mozilla.org/mozilla-central/rev/054217b5399b
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
status-firefox16: affected → ---

Updated

5 years ago
tracking-firefox15: ? → +

Comment 6

5 years ago
Comment on attachment 635238 [details] [diff] [review]
Patch v1

[Triage Comment]
Early enough in the cycle that I expect to find regressions prior to release. Approving for Aurora 15.
Attachment #635238 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Updated

5 years ago
status-firefox13: --- → unaffected
status-firefox15: affected → fixed
status-firefox16: --- → fixed
Target Milestone: mozilla16 → mozilla15
(Assignee)

Comment 7

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/46c0c328a78c

Comment 8

5 years ago
Verified/fixed on:
Nightly Fennec 16.0a1 (2012-07-08)
Aurora Fennec 15.0a2 (2012-07-08)
Using:
HTC Desire Z (2.3.3)

The issue in the bug is not reproducible and the test case in the bug works correctly.
Status: RESOLVED → VERIFIED
status-firefox15: fixed → verified
status-firefox16: fixed → verified
You need to log in before you can comment on or make changes to this bug.