Closed Bug 764787 Opened 9 years ago Closed 9 years ago

notification panel sizing requires providers to specify fixed size content

Categories

(Firefox Graveyard :: SocialAPI, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 797716

People

(Reporter: markh, Unassigned)

References

Details

The sizing of the notification panels only works correctly if the provider content defines a "notif" element with a fixed width and height.  We adjust the panel to whatever fixed size they specify.

Ideally we should control the size of the popup and allow the providers to implement a more flexible layout scheme - ie, we have a better idea of that the "best" size for the popup should be and the layout of the provider content should adjust accordingly.  They can still implement a fixed size if they choose, but they may end up with scroll-bars.  Or they can be even more flexible and avoid scrollbars while still not dictating the popup size.
I would prefer we use document.body.firstChild rather than a named element, but in any case, this needs documentation in the api doc.

Is there any other todo for ms1 here?
Duplicate of this bug: 774176
Using something like bug 476039 might be a workable alternative.
Is this something we're trying to tackle for 17?
panel resizing landed in bug 797716
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 797716
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.