Last Comment Bug 764867 - Android Sync branding should match installed Fennec branding
: Android Sync branding should match installed Fennec branding
Status: VERIFIED FIXED
[qa+]
:
Product: Android Background Services
Classification: Client Software
Component: Android Sync (show other bugs)
: unspecified
: All Android
: P1 normal
: mozilla17
Assigned To: Nick Alexander :nalexander
:
Mentors:
Depends on: 742478
Blocks: 761206 772645
  Show dependency treegraph
 
Reported: 2012-06-14 09:24 PDT by Nick Alexander :nalexander
Modified: 2013-04-04 13:48 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
affected
fixed
verified
+


Attachments
Nightly <-> Firefox mashup (Screenshot) (67.94 KB, image/png)
2012-06-14 11:00 PDT, Aaron Train [:aaronmt]
no flags Details
Nightly (07/03) - Screenshot (124.75 KB, image/png)
2012-07-03 16:22 PDT, Aaron Train [:aaronmt]
no flags Details
Icons for Nightly, Aurora, Firefox (109.90 KB, application/x-zip-compressed)
2012-07-16 11:32 PDT, Ian Barlow (:ibarlow)
no flags Details
Proposed patch for Aurora. v1 (63.97 KB, patch)
2012-07-31 09:00 PDT, Richard Newman [:rnewman]
rnewman: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Nick Alexander :nalexander 2012-06-14 09:24:06 PDT
From IRC:

09:12 AaronMT: [08:20:18] Just noticed Sync setup is hard-coded with Fx branding; that expected?
09:18 nalexander: AaronMT: elaborate?  I'm looking into multiple Fennecs and Sync right now and might be able to look into it.
09:20 AaronMT: nalexander: Dont have the phone on me atm; was in Nightly, saw Firefox logo/string branding

We should be careful to use the Fx logos and strings where appropriate.
Comment 1 Aaron Train [:aaronmt] 2012-06-14 11:00:36 PDT
Created attachment 633190 [details]
Nightly <-> Firefox mashup (Screenshot)
Comment 2 Richard Newman [:rnewman] 2012-06-14 23:01:10 PDT
The only string references I see to Firefox are in the noun phrase "Firefox Sync" (which should not match the product name) and references to "your desktop Firefox".

Iconography probably isn't adapted correctly, though. Sometimes that's fine (Ian recently provided a Firefox logo to use for Send Tab).
Comment 3 Aaron Train [:aaronmt] 2012-07-03 16:22:54 PDT
Created attachment 638909 [details]
Nightly (07/03) - Screenshot

Device tab page

(Honestly, I only own one Galaxy Nexus!)
Comment 4 Nick Alexander :nalexander 2012-07-03 16:24:52 PDT
Comment on attachment 638909 [details]
Nightly (07/03) - Screenshot

Yeah, this is a known issue (with no ticket, AFAIK).  You've set up this account on your Galaxy Nexus several times; each time, we choose a random client GUID to identify the device, and they're never purged.  We could address this in a bunch of different ways.
Comment 5 Richard Newman [:rnewman] 2012-07-03 21:34:33 PDT
(In reply to Nick Alexander :nalexander from comment #4)

> Yeah, this is a known issue (with no ticket, AFAIK).

Filed Bug 770785. Let's keep this bug on-topic.
Comment 6 Richard Newman [:rnewman] 2012-07-03 21:41:00 PDT
Note that this was the 'constant' icon that Ian provided in Bug 742478. I jus' do what I'm told, UI-wise :)
Comment 7 Ian Barlow (:ibarlow) 2012-07-16 11:32:59 PDT
Created attachment 642660 [details]
Icons for Nightly, Aurora, Firefox

Attached are channel-specific icons that can be used in these menus.
Comment 8 Richard Newman [:rnewman] 2012-07-16 18:47:37 PDT
Thanks, Ian!
Comment 9 Nick Alexander :nalexander 2012-07-24 12:12:30 PDT
rnewman: can you explain why you added icons to 

$(TOPDIR)/res/drawable-*/

in

https://hg.mozilla.org/integration/mozilla-inbound/rev/4297a8802cd5
Comment 10 Richard Newman [:rnewman] 2012-07-24 16:08:06 PDT
(In reply to Nick Alexander :nalexander from comment #9)
> rnewman: can you explain why you added icons to 
> 
> $(TOPDIR)/res/drawable-*/

Accidental during commit. Kill them, r=me.
Comment 11 Richard Newman [:rnewman] 2012-07-24 20:28:17 PDT
> Accidental during commit. Kill them, r=me.

Killed them in https://hg.mozilla.org/integration/mozilla-inbound/rev/78dce09ed250.
Comment 12 Nick Alexander :nalexander 2012-07-26 09:11:58 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/2e71d9e5e868
Comment 13 Nick Alexander :nalexander 2012-07-26 09:20:23 PDT
Steps to verify:

All Firefox Sync logos used to be "official" Firefox logo, and should now use whatever the installed Firefox logo is (probably Nightly).  To check 3 places that use the logo in different ways:

1. go to Android > Settings > Accounts & sync > Add Account.
2. verify that "Firefox Sync" has Firefox branded logo (probably Nightly's logo).
3. select "Firefox Sync".
4. verify that "Add a Firefox Sync Account" page has Firefox branded logo (again, probably Nightly's logo).
5. pair device to existing Sync account.
6. from within Fennec, share a page.
7. verify that "Firefox Sync" Send Tab activity has Firefox branded logo.
Comment 14 Nick Alexander :nalexander 2012-07-26 09:42:31 PDT
Question: should the "Set up Firefox Sync" button still use the "Gray Rotating Arrows" icon?  We've moved Sync away from the arrows (to the Firefox channel logo) in order to support multiple Apps, so these arrows don't appear elsewhere on the device.  They do appear on all desktops.
Comment 15 Richard Newman [:rnewman] 2012-07-26 10:51:22 PDT
(In reply to Nick Alexander :nalexander from comment #14)
> Question: should the "Set up Firefox Sync" button still use the "Gray
> Rotating Arrows" icon?  We've moved Sync away from the arrows (to the
> Firefox channel logo) in order to support multiple Apps, so these arrows
> don't appear elsewhere on the device.  They do appear on all desktops.

I believe so: desktop parity, in-product branding versus out-of-product.
Comment 16 Matt Brubeck (:mbrubeck) 2012-07-26 14:07:32 PDT
https://hg.mozilla.org/mozilla-central/rev/2e71d9e5e868
Comment 17 Aaron Train [:aaronmt] 2012-07-31 07:16:04 PDT
Beta/Aurora uplift?
Comment 18 Richard Newman [:rnewman] 2012-07-31 07:46:10 PDT
Makefile changes, so I'm inclined to uplift to as few places as possible. Aurora is probably quite feasible.
Comment 19 Richard Newman [:rnewman] 2012-07-31 09:00:55 PDT
Created attachment 647551 [details] [diff] [review]
Proposed patch for Aurora. v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
  History!

User impact if declined: 
  Confused branding between channels. Usability impact when multiple Fennec Sync support lands.

Testing completed (on m-c, etc.): 
  Verified on m-c.

Risk to taking this patch (and alternatives if risky): 
  Minimal: any problems should be immediately and blindingly obvious.

String or UUID changes made by this patch: 
  None.
Comment 20 Nick Alexander :nalexander 2012-07-31 09:19:57 PDT
(In reply to Richard Newman [:rnewman] from comment #19)
> Created attachment 647551 [details] [diff] [review]
> Proposed patch for Aurora. v1

Flyby: looks good to me.
Comment 21 Richard Newman [:rnewman] 2012-07-31 09:44:33 PDT
(In reply to Nick Alexander :nalexander from comment #20)

> Flyby: looks good to me.

I sure hope so; it's the code you landed :)
Comment 22 Nick Alexander :nalexander 2012-07-31 10:01:51 PDT
(In reply to Richard Newman [:rnewman] from comment #21)
> (In reply to Nick Alexander :nalexander from comment #20)
> 
> > Flyby: looks good to me.
> 
> I sure hope so; it's the code you landed :)

Ah, but I wanted to be sure we didn't drop the Sync icon deletions, and that we maintained the Makefile changes.  Of coures, the original patch might apply cleanly :)
Comment 23 Lukas Blakk [:lsblakk] use ?needinfo 2012-07-31 15:04:15 PDT
Comment on attachment 647551 [details] [diff] [review]
Proposed patch for Aurora. v1

Since changes will be blindingly obvious, approved for Aurora.
Comment 24 Richard Newman [:rnewman] 2012-07-31 18:49:41 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/3186b5d413c9

Note You need to log in before you can comment on or make changes to this bug.