Closed Bug 765632 Opened 7 years ago Closed 7 years ago

Kuma: Need a way to set translation parent

Categories

(developer.mozilla.org :: Localization, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: lorchard, Assigned: groovecoder)

References

(Blocks 1 open bug)

Details

(Whiteboard: u=user c=wiki p=3 s=2012-08-22 s=2012-08-29)

Migration was unable to establish translation parents for some pages. For example:

    https://developer-new.mozilla.org/en-US/docs/HTML/Element/button

That page has translations in es and fr:

    {{ languages( { "es": "es/HTML/Elemento/button" ,  "fr": "fr/HTML/Element/Button" } ) }}

But, the translation parents were not migrated. So, we need the ability to manually choose a new translation parent for pages to fix this situation.
Where would this appear?  The "edit" page?  Somewhere in "admin"?
I'd say Edit page, ideally. There should be a way for general wiki editors to correct translation relationships. Otherwise, we're limited to the handful of admins that exist to do the work.
Whiteboard: u=user c=wiki s=2012-07-03 p=
Whiteboard: u=user c=wiki s=2012-07-03 p= → u=user c=wiki s=2012-07-03 p=2
Les:

How can we tell if a translation doesn't have a parent?  Simply no parent_id?  How can I tell if something is a translation?

We should only show that new field if the translation doesn't have a parent, right?
My proposal for this ticket is: If no "parent_id" is present, show this field as an autocompleter, much like the link editor
Sounds good to me.
Depends on: 765647
Friendly all aboard ping. We scheduled this one to be completed before the next sprint. How's it looking?
Whiteboard: u=user c=wiki s=2012-07-03 p=2 → u=user c=wiki s=2012-07-13 p=2
Whiteboard: u=user c=wiki s=2012-07-13 p=2 → u=user c=wiki s=2012-07-18 p=2
I current have the front end completed on this branch:

    https://github.com/darkwing/kuma/tree/set-trans-parent-765632

I attempted to complete the server side with these lines:

    https://github.com/darkwing/kuma/commit/fe4454f08e3634a85b14aafae17b10395d12c504

But upon submission, I receive the following error:

    [A revision must be based on a revision of the English document. Revision ID 891 does not fit those criteria.]

Updating ticket as progress.
Blocks: 773292
No longer blocks: 756263
This is complicated by the fact that kitsune wants non-english revisions to be based_on corresponding documents' en-US revisions. MDN has always had some pages that were never based on en_US pages.

We can break it by removing the constraint, but that will also break kitsune's feature that notifies localizers when an English document changes. (See bug 671717)

So, we're deferring this feature to post-launch.
Blocks: 756266
No longer blocks: 773292
Blocks: 773292
No longer blocks: 756266
Blocks: 756266
No longer blocks: 773292
Priority: -- → P1
Whiteboard: u=user c=wiki s=2012-07-18 p=2 → u=user c=wiki p=2
Blocks: 776486
Moving out of the release as per our discussions last week.
No longer blocks: 756266
Component: Docs Platform → Localization
Blocks: 782493
No longer blocks: 782493
Duplicate of this bug: 782493
Whiteboard: u=user c=wiki p=2 → u=user c=wiki p=2 s=2012-08-22
Whiteboard: u=user c=wiki p=2 s=2012-08-22 → u=user c=wiki p=3 s=2012-08-22
Blocks: 782493
Whiteboard: u=user c=wiki p=3 s=2012-08-22 → u=user c=wiki p=3 s=2012-08-22 s=2012-08-29
Assignee: nobody → lcrouch
Commits pushed to master at https://github.com/mozilla/kuma

https://github.com/mozilla/kuma/commit/3b8495434bc67a50a23841b92a50aa222c915dca
fix bug 765632 - Adding parent-settings capabilities for translations

Adding show block logic

Progress

Updating to front-end progress

Progress

https://github.com/mozilla/kuma/commit/6879b3f8bb8e2ec4631538a09efb20737e62d80c
Merge pull request #575 from groovecoder/set-trans-parent-765632-squashed

fix bug 765632 - Adding parent-settings capabilities for translations
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Version: Kuma → unspecified
You need to log in before you can comment on or make changes to this bug.