Manually set translation parent of pages that lost parent during migration

REOPENED
Unassigned

Status

Mozilla Developer Network
Localization
REOPENED
5 years ago
3 years ago

People

(Reporter: dynamis (Tomoya ASAI), Unassigned)

Tracking

Details

(Whiteboard: [triaged])

(Reporter)

Description

5 years ago
Some translation pages don't have their translation parent.
We should set parent of them.

https://developer.mozilla.org/en-US/docs/JavaScript/A_re-introduction_to_JavaScript
https://developer.mozilla.org/ja/docs/JavaScript/A_re-introduction_to_JavaScript

I'll ad comment when I find more.
(Reporter)

Updated

5 years ago
Depends on: 765632
That's a duplicate. But continue to add a comment here with the one you find, not to clutter the other bug.

Once fixed, we will go through the links.

Note: there are a lot of them!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
No longer depends on: 765632
Resolution: --- → DUPLICATE
Duplicate of bug: 765632

Comment 2

5 years ago
https://developer.mozilla.org/en-US/docs/JavaScript/Guide/Closures
https://developer.mozilla.org/ja/docs/JavaScript/Guide/Working_with_Closures

https://developer.mozilla.org/ja/docs/JavaScript/Reference/Global_Objects/Number

https://developer.mozilla.org/en-US/docs/JavaScript/Reference/Operators/Comma_Operator
https://developer.mozilla.org/ja/docs/JavaScript/Reference/Operators/Comma_Operator

https://developer.mozilla.org/en-US/docs/Project:Disambiguation
https://developer.mozilla.org/ja/docs/Project:Disambiguation

https://developer.mozilla.org/en-US/docs/Project:MDC_editor_guide
https://developer.mozilla.org/ja/docs/Project:MDC_editor_guide

Comment 3

5 years ago
Please :-)


https://developer.mozilla.org/ja/docs/HTML/Element/var
https://developer.mozilla.org/en-US/docs/HTML/Element/var

https://developer.mozilla.org/ja/docs/HTML/Element/html
https://developer.mozilla.org/en-US/docs/HTML/Element/html

https://developer.mozilla.org/ja/docs/HTML/Element/title
https://developer.mozilla.org/en-US/docs/HTML/Element/title

https://developer.mozilla.org/ja/docs/HTML/Element/code
https://developer.mozilla.org/en-US/docs/HTML/Element/code

https://developer.mozilla.org/ja/docs/HTML/Element/samp
https://developer.mozilla.org/en-US/docs/HTML/Element/samp

https://developer.mozilla.org/ja/docs/HTML/Element/ins
https://developer.mozilla.org/en-US/docs/HTML/Element/ins

https://developer.mozilla.org/ja/docs/HTML/Element/i
https://developer.mozilla.org/en-US/docs/HTML/Element/i

https://developer.mozilla.org/ja/docs/HTML/Element/br
https://developer.mozilla.org/en-US/docs/HTML/Element/br

https://developer.mozilla.org/ja/docs/HTML/Element/div
https://developer.mozilla.org/en-US/docs/HTML/Element/div

https://developer.mozilla.org/ja/docs/HTML/Element/blockquote
https://developer.mozilla.org/en-US/docs/HTML/Element/blockquote

https://developer.mozilla.org/ja/docs/HTML/Element/ul
https://developer.mozilla.org/en-US/docs/HTML/Element/ul

https://developer.mozilla.org/ja/docs/HTML/Element/legend
https://developer.mozilla.org/en-US/docs/HTML/Element/legend

https://developer.mozilla.org/ja/docs/HTML/Element/details
https://developer.mozilla.org/en-US/docs/HTML/Element/details

https://developer.mozilla.org/ja/docs/HTML/Element/summary
https://developer.mozilla.org/en-US/docs/HTML/Element/summary

https://developer.mozilla.org/ja/docs/HTML/Element/bdi
https://developer.mozilla.org/en-US/docs/HTML/Element/bdi

https://developer.mozilla.org/ja/docs/HTML/Element/button
https://developer.mozilla.org/en-US/docs/HTML/Element/object

Comment 4

5 years ago
https://developer.mozilla.org/en-US/docs/HTML/Element/button
https://developer.mozilla.org/ja/docs/HTML/Element/object

Comment 5

5 years ago
https://developer.mozilla.org/ja/docs/HTML/Element/footer
https://developer.mozilla.org/ja/docs/HTML/Element/h1
https://developer.mozilla.org/ja/docs/HTML/Element/h2
https://developer.mozilla.org/ja/docs/HTML/Element/h3
https://developer.mozilla.org/ja/docs/HTML/Element/h4
https://developer.mozilla.org/ja/docs/HTML/Element/h5
https://developer.mozilla.org/ja/docs/HTML/Element/h6
https://developer.mozilla.org/ja/docs/HTML/Element/big
https://developer.mozilla.org/ja/docs/HTML/Element/plaintext

https://developer.mozilla.org/en-US/docs/HTML/Element/footer
https://developer.mozilla.org/en-US/docs/HTML/Element/h1
https://developer.mozilla.org/en-US/docs/HTML/Element/h2
https://developer.mozilla.org/en-US/docs/HTML/Element/h3
https://developer.mozilla.org/en-US/docs/HTML/Element/h4
https://developer.mozilla.org/en-US/docs/HTML/Element/h5
https://developer.mozilla.org/en-US/docs/HTML/Element/h6
https://developer.mozilla.org/en-US/docs/HTML/Element/big
https://developer.mozilla.org/en-US/docs/HTML/Element/plaintext

Comment 6

5 years ago
Pleeeease :-)


https://developer.mozilla.org/ja/docs/CSS/background-repeat
https://developer.mozilla.org/ja/docs/CSS/list-style
https://developer.mozilla.org/ja/docs/Mozilla_CSS_support_chart
https://developer.mozilla.org/ja/docs/CSS/normal
https://developer.mozilla.org/ja/docs/CSS/resize
https://developer.mozilla.org/ja/docs/CSS/font-weight
https://developer.mozilla.org/ja/docs/JavaScript/Reference/Operators/Comparison_Operators
https://developer.mozilla.org/ja/docs/JavaScript/Reference/Operators/typeof
https://developer.mozilla.org/ja/docs/JavaScript/Other_JavaScript_tools
https://developer.mozilla.org/ja/docs/JavaScript/Reference/Global_Objects/Function/length
https://developer.mozilla.org/ja/docs/JavaScript/Reference/Global_Objects/parseFloat
https://developer.mozilla.org/ja/docs/JavaScript/Reference/Global_Objects/Array/indexOf
https://developer.mozilla.org/ja/docs/JavaScript/Reference/Global_Objects/Array/lastIndexOf
https://developer.mozilla.org/ja/docs/JavaScript/Reference/Global_Objects/Array/filter
https://developer.mozilla.org/ja/docs/JavaScript/Reference/Global_Objects/Array/every
https://developer.mozilla.org/ja/docs/JavaScript/Reference/Global_Objects/Array/map
https://developer.mozilla.org/ja/docs/JavaScript/Reference/Global_Objects/Array/reduce
https://developer.mozilla.org/ja/docs/JavaScript/Reference/Global_Objects/Array/reduceRight
https://developer.mozilla.org/ja/docs/JavaScript/Reference/Global_Objects/Date/now
https://developer.mozilla.org/ja/docs/JavaScript/Reference/Global_Objects/Date/getMonth
https://developer.mozilla.org/ja/docs/JavaScript/Reference/Global_Objects/Date/getMinutes
https://developer.mozilla.org/ja/docs/DOM/HTMLHeadElement
https://developer.mozilla.org/ja/docs/DOM/HTMLParagraphElement
https://developer.mozilla.org/ja/docs/DOM/HTMLHRElement
https://developer.mozilla.org/ja/docs/DOM/HTMLBRElement
https://developer.mozilla.org/ja/docs/DOM/HTMLModElement


https://developer.mozilla.org/en-US/docs/CSS/background-repeat
https://developer.mozilla.org/en-US/docs/CSS/list-style
https://developer.mozilla.org/en-US/docs/Mozilla_CSS_support_chart
https://developer.mozilla.org/en-US/docs/CSS/normal
https://developer.mozilla.org/en-US/docs/CSS/resize
https://developer.mozilla.org/en-US/docs/CSS/font-weight
https://developer.mozilla.org/en-US/docs/JavaScript/Reference/Operators/Comparison_Operators
https://developer.mozilla.org/en-US/docs/JavaScript/Reference/Operators/typeof
https://developer.mozilla.org/en-US/docs/JavaScript/Other_JavaScript_tools
https://developer.mozilla.org/en-US/docs/JavaScript/Reference/Global_Objects/Function/length
https://developer.mozilla.org/en-US/docs/JavaScript/Reference/Global_Objects/parseFloat
https://developer.mozilla.org/en-US/docs/JavaScript/Reference/Global_Objects/Array/indexOf
https://developer.mozilla.org/en-US/docs/JavaScript/Reference/Global_Objects/Array/lastIndexOf
https://developer.mozilla.org/en-US/docs/JavaScript/Reference/Global_Objects/Array/filter
https://developer.mozilla.org/en-US/docs/JavaScript/Reference/Global_Objects/Array/every
https://developer.mozilla.org/en-US/docs/JavaScript/Reference/Global_Objects/Array/map
https://developer.mozilla.org/en-US/docs/JavaScript/Reference/Global_Objects/Array/reduce
https://developer.mozilla.org/en-US/docs/JavaScript/Reference/Global_Objects/Array/reduceRight
https://developer.mozilla.org/en-US/docs/JavaScript/Reference/Global_Objects/Date/now
https://developer.mozilla.org/en-US/docs/JavaScript/Reference/Global_Objects/Date/getMonth
https://developer.mozilla.org/en-US/docs/JavaScript/Reference/Global_Objects/Date/getMinutes
https://developer.mozilla.org/en-US/docs/DOM/HTMLHeadElement
https://developer.mozilla.org/en-US/docs/DOM/HTMLParagraphElement
https://developer.mozilla.org/en-US/docs/DOM/HTMLHRElement
https://developer.mozilla.org/en-US/docs/DOM/HTMLBRElement
https://developer.mozilla.org/en-US/docs/DOM/HTMLModElement

Comment 7

5 years ago
https://developer.mozilla.org/ja/docs/DOM/Document.querySelector
https://developer.mozilla.org/en-US/docs/DOM/Document.querySelector
Thanks for aggregating a list of broken pages everyone!

I have updated this bug to be about manually correcting these pages. This will be possible after bug 765632 is fixed.
Status: RESOLVED → REOPENED
Depends on: 765632
Resolution: DUPLICATE → ---
Summary: Need to set translation parent → Manually set translation parent of pages that lost parent during migration
Duplicate of this bug: 782110
Some more from Irvin.

https://bugzilla.mozilla.org/show_bug.cgi?id=782110#c0
Duplicate of this bug: 782564
English page:
https://developer.mozilla.org/en-US/docs/HTML/Element/head

Two translations that are not listed on the English page (de + ja):
https://developer.mozilla.org/de/docs/HTML/Element/head  and
https://developer.mozilla.org/ja/docs/HTML/Element/head

In addition, the two above link to this page when they should link to the one at the very top of this comment.
https://developer.mozilla.org/en-US/docs/DOM/HTMLHeadElement

Comment 13

5 years ago
https://developer.mozilla.org/ja/docs/DOM
https://developer.mozilla.org/en-US/docs/DOM

Comment 14

5 years ago
https://developer.mozilla.org/ja/docs/CSS/inherit
https://developer.mozilla.org/en-US/docs/CSS/inherit

Comment 15

5 years ago
https://developer.mozilla.org/ja/docs/JavaScript/Reference/Operators/void
https://developer.mozilla.org/en-US/docs/JavaScript/Reference/Operators/void

Comment 16

5 years ago
https://developer.mozilla.org/ja/docs/DOM/HTMLSourceElement
https://developer.mozilla.org/en-US/docs/DOM/HTMLSourceElement

Comment 17

5 years ago
https://developer.mozilla.org/ja/docs/JavaScript/Guide/Working_with_Objects
https://developer.mozilla.org/en-US/docs/JavaScript/Guide/Working_with_Objects

Comment 18

5 years ago
https://developer.mozilla.org/ja/docs/DOM/HTMLFormControlsCollection
https://developer.mozilla.org/en-US/docs/DOM/HTMLFormControlsCollection

Comment 19

5 years ago
https://developer.mozilla.org/ja/docs/DOM/HTMLQuoteElement
https://developer.mozilla.org/en-US/docs/DOM/HTMLQuoteElement

Comment 20

5 years ago
https://developer.mozilla.org/ja/docs/JavaScript/New_in_JavaScript/1.5
https://developer.mozilla.org/ja/docs/JavaScript/New_in_JavaScript/1.6
https://developer.mozilla.org/ja/docs/JavaScript/New_in_JavaScript/1.7
https://developer.mozilla.org/ja/docs/JavaScript/New_in_JavaScript/1.8
https://developer.mozilla.org/ja/docs/JavaScript/New_in_JavaScript/1.8.1

https://developer.mozilla.org/ja/docs/SpiderMonkey/Introduction_to_the_JavaScript_shell
https://developer.mozilla.org/ja/docs/SpiderMonkey/Internals/Thread_Safety

Comment 21

5 years ago
https://developer.mozilla.org/es/docs/Detectar_la_orientaci%C3%B3n_del_dispositivo

Comment 22

5 years ago
https://developer.mozilla.org/es/docs/Usando_archivos_desde_aplicaciones_web

Comment 23

5 years ago
https://developer.mozilla.org/es/docs/Usar_la_Geolocalizaci%C3%B3n

Comment 24

5 years ago
https://developer.mozilla.org/es/docs/M%C3%B3vil

Comment 25

5 years ago
https://developer.mozilla.org/es/docs/Usando_audio_y_video_en_Firefox

Comment 26

5 years ago
https://developer.mozilla.org/es/docs/WebSockets

Comment 27

5 years ago
https://developer.mozilla.org/es/docs/Usar_web_workers

Comment 28

5 years ago
https://developer.mozilla.org/es/docs/XMLHttpRequest/Usar_XMLHttpRequest

Comment 29

5 years ago
https://developer.mozilla.org/es/docs/DOM/Eventos_t%C3%A1ctiles

Comment 30

5 years ago
https://developer.mozilla.org/fr/docs/Utilisation_de_la_g%C3%A9olocalisation

Comment 31

5 years ago
https://developer.mozilla.org/fr/docs/HTML/Element
https://developer.mozilla.org/en-US/docs/HTML/Element

Comment 32

5 years ago
https://developer.mozilla.org/ja/docs/JavaScript/Guide
https://developer.mozilla.org/en-US/docs/JavaScript/Guide

Comment 33

5 years ago
https://developer.mozilla.org/zh-CN/docs/SVG

Comment 34

5 years ago
https://developer.mozilla.org/ja/docs/Jetpack
https://developer.mozilla.org/ja/docs/Jetpack/Basics
https://developer.mozilla.org/ja/docs/Jetpack/System
https://developer.mozilla.org/ja/docs/Jetpack/Multimedia
https://developer.mozilla.org/ja/docs/Jetpack/Storage
https://developer.mozilla.org/ja/docs/Jetpack/Extenders
https://developer.mozilla.org/ja/docs/Jetpack/Meta
https://developer.mozilla.org/ja/docs/Jetpack/UI
https://developer.mozilla.org/ja/docs/Jetpack/UI/Slidebar
https://developer.mozilla.org/ja/docs/Jetpack/UI/Tabs
https://developer.mozilla.org/ja/docs/Jetpack/UI/Selection
https://developer.mozilla.org/ja/docs/Jetpack/Content
https://developer.mozilla.org/ja/docs/Jetpack/Libraries/Twitter

Comment 35

5 years ago
https://developer.mozilla.org/ja/docs/HTML/Using_the_application_cache
https://developer.mozilla.org/ja/docs/HTML/Element/video
https://developer.mozilla.org/ja/docs/CSS/color_value
https://developer.mozilla.org/ja/docs/CSS/Shorthand_properties
https://developer.mozilla.org/ja/docs/CSS/length
https://developer.mozilla.org/ja/docs/JavaScript_technologies_overview
https://developer.mozilla.org/ja/docs/JavaScript/Guide/Regular_Expressions
https://developer.mozilla.org/ja/docs/JavaScript/Guide/LiveConnect_Overview
https://developer.mozilla.org/ja/docs/JavaScript/Reference/Global_Objects/isNaN
https://developer.mozilla.org/ja/docs/JavaScript/Reference/Global_Objects/parseInt
https://developer.mozilla.org/ja/docs/JavaScript/Reference/Functions_and_function_scope/arguments/callee
https://developer.mozilla.org/ja/docs/E4X/Processing_XML_with_E4X
https://developer.mozilla.org/ja/docs/DOM/Touch_events
https://developer.mozilla.org/ja/docs/Using_HTML5_audio_and_video
https://developer.mozilla.org/ja/docs/HTML/Element/Audio
https://developer.mozilla.org/ja/docs/MathML/Element/math
https://developer.mozilla.org/ja/docs/HTML/Element/basefont
https://developer.mozilla.org/ja/docs/CSS/CSS_Reference/Mozilla_Extensions

Comment 36

5 years ago
https://developer.mozilla.org/ja/docs/Project:How_to_Help

Comment 37

5 years ago
https://developer.mozilla.org/ja/docs/Project:Custom_Templates

Comment 38

5 years ago
https://developer.mozilla.org/ja/docs/CSS/Media_queries

Comment 39

5 years ago
https://developer.mozilla.org/ja/docs/XUL/Attribute/align
(Assignee)

Updated

5 years ago
Version: Kuma → unspecified

Comment 40

5 years ago
https://developer.mozilla.org/zh-TW/docs/JavaScript/About_JavaScript
https://developer.mozilla.org/zh-TW/docs/JavaScript/Guide/JavaScript_Overview
https://developer.mozilla.org/zh-TW/docs/JavaScript_technologies_overview
Just find 3 more article, please.
Sheppy, Luke: Does this require development work or can an editor do it?
(In reply to John Karahalis [:openjck] from comment #41)
> Sheppy, Luke: Does this require development work or can an editor do it?

I believe the devs have to do this; I don't think it requires "development" work but I don't think there's UI for us to do it. But I'm not sure.

Comment 43

4 years ago
https://developer.mozilla.org/fr/docs/JavaScript/Référence_JavaScript/ 
The link is currently pointing to a sandbox page instead of the correct one (https://developer.mozilla.org/en-US/docs/Web/JavaScript/Reference ) 

Thanks :)
Whiteboard: [triaged]
fwiw, you can set the translation parent through the editor now.

Also, there is no need to collect pages without parent in this bug anymore, because there is a new maintenance page "without-parent" for each locale now:

https://developer.mozilla.org/fr/docs/without-parent
https://developer.mozilla.org/es/docs/without-parent
https://developer.mozilla.org/ja/docs/without-parent
https://developer.mozilla.org/de/docs/without-parent
https://developer.mozilla.org/zh-TW/docs/without-parent
...
You need to log in before you can comment on or make changes to this bug.