Note: There are a few cases of duplicates in user autocompletion which are being worked on.

increase system NSPR requirement from 4.9.1 to 4.9.2

RESOLVED FIXED in Firefox 16

Status

()

Core
JavaScript Engine
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Hussam Al-Tayeb, Assigned: Callek)

Tracking

Trunk
mozilla18
x86
Linux
Points:
---

Firefox Tracking Flags

(firefox16 fixed, firefox17 fixed)

Details

(Whiteboard: [js:waitingforinfo])

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120616064646

Steps to reproduce:

firefox 13.0.1 compiled fine with clang but trunk won't,


Actual results:

clang++ -o jsgc.o -c  -I./../../dist/system_wrappers_js -include /home/hussam/packages/firefox/js/src/config/gcc_hidden.h -DMOZ_GLUE_IN_PROGRAM -DEXPORT_JS_API -DJS_HAS_CTYPES -DDLL_PREFIX=\"lib\" -DDLL_SUFFIX=\".so\" -DNO_NSPR_10_SUPPORT -I/usr/lib/libffi-3.0.11/include   -I.  -I/home/hussam/packages/firefox/js/src/../../mfbt/double-conversion -I/home/hussam/packages/firefox/js/src -I. -I./../../dist/include  -I/usr/include/nspr  -I/home/hussam/packages/firefox/js/src -I/home/hussam/packages/firefox/js/src/assembler -I/home/hussam/packages/firefox/js/src/yarr  -fPIC -Qunused-arguments  -pedantic -Qunused-arguments -Wall -Wpointer-arith -Woverloaded-virtual -Werror=return-type -Wtype-limits -Wempty-body -Wno-ctor-dtor-privacy -Wno-overlength-strings -Wno-invalid-offsetof -Wno-variadic-macros -Wno-c++0x-extensions -Wno-extended-offsetof -Wno-unknown-warning-option -Wno-return-type-c-linkage -Wno-long-long -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -pthread -pipe  -DNDEBUG -DTRIMMED -g -O3 -freorder-blocks  -fomit-frame-pointer -DUSE_SYSTEM_MALLOC=1 -DENABLE_ASSEMBLER=1 -DENABLE_JIT=1  -Qunused-arguments  -DMOZILLA_CLIENT -include ./js-confdefs.h -MD -MF .deps/jsgc.pp /home/hussam/packages/firefox/js/src/jsgc.cpp
/home/hussam/packages/firefox/js/src/jsgc.cpp:2736:5: error: use of undeclared
      identifier 'PR_SetCurrentThreadName'
    PR_SetCurrentThreadName("JS GC Helper");
    ^
1 error generated.
make[5]: *** [jsgc.o] Error 1
make[5]: Leaving directory `/home/hussam/packages/firefox/obj-i686-pc-linux-gnu/js/src'
make[4]: *** [libs_tier_js] Error 2
make[4]: Leaving directory `/home/hussam/packages/firefox/obj-i686-pc-linux-gnu'
make[3]: *** [tier_js] Error 2
make[3]: Leaving directory `/home/hussam/packages/firefox/obj-i686-pc-linux-gnu'
make[2]: *** [default] Error 2
make[2]: Leaving directory `/home/hussam/packages/firefox/obj-i686-pc-linux-gnu'
make[1]: *** [realbuild] Error 2
make[1]: Leaving directory `/home/hussam/packages/firefox'
make: *** [build] Error 2



Expected results:

firefox should compile correctly.
Note: This worked in firefox 13.0.1 so it is a regression.

Updated

5 years ago
Assignee: nobody → general
Component: Untriaged → JavaScript Engine
Product: Firefox → Core
QA Contact: untriaged → general
Do you have a regression range for the breakage?
Whiteboard: [js:waitingforinfo]
(Reporter)

Comment 2

5 years ago
No, sorry. all I know is that it worked when I compiled firefox 13.0.1 then didn't when I felt like playing with a trunk build.
(Reporter)

Comment 3

5 years ago
ok, it works with internal nspr but not with system nspr 4.9.1

Comment 4

5 years ago
Honza: mozilla/configure.in can require a particular version of system nspr:
http://mxr.mozilla.org/mozilla-central/source/configure.in#3890

3890 dnl ========================================================
3891 dnl = If NSPR was not detected in the system,
3892 dnl = use the one in the source tree (mozilla/nsprpub)
3893 dnl ========================================================
3894 MOZ_ARG_WITH_BOOL(system-nspr,
3895 [  --with-system-nspr      Use system installed NSPR],
3896     _USE_SYSTEM_NSPR=1 )
3897 
3898 if test -n "$_USE_SYSTEM_NSPR"; then
3899     AM_PATH_NSPR(4.9.0, [MOZ_NATIVE_NSPR=1], [AC_MSG_ERROR([your don't have NSPR installed or your version is too old])])
3900 fi

I don't know what happens if the system nspr is too old.

We should change 4.9.0 to 4.9.2.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Is anybody working on this?  It's assigned, but there is nobody reasonable in the assignee field.
(Reporter)

Updated

5 years ago
Summary: compile failure with clang → increase system NSPR requirement from 4.9.1 to 4.9.2
Created attachment 642671 [details] [diff] [review]
v0

We don't actually need to touch the browser's requirement, just the SpiderMonkey one.
Assignee: general → terrence
Attachment #642671 - Flags: review?(dmandelin)
Comment on attachment 642671 [details] [diff] [review]
v0

Main configure needs this too.
Attachment #642671 - Flags: review?(dmandelin) → review-

Comment 8

5 years ago
Comment on attachment 642671 [details] [diff] [review]
v0

required on aurora 16 branch if bug 778845 lands there
Attachment #642671 - Flags: approval-mozilla-aurora?
Comment on attachment 642671 [details] [diff] [review]
v0

This hasn't even landed on mozilla-central.
Attachment #642671 - Flags: approval-mozilla-aurora?
(In reply to Terrence Cole [:terrence] from comment #6)
> Created attachment 642671 [details] [diff] [review]
> v0
> 
> We don't actually need to touch the browser's requirement, just the
> SpiderMonkey one.

We do. Because of bug 720778.
Duplicate of this bug: 787774
Note that it's also needed on mozilla-beta. 16.0b1 doesnt build with system nspr 4.9.0.
(Assignee)

Comment 13

5 years ago
Created attachment 657646 [details] [diff] [review]
fix it both places

Stealing bug since no new patch in over 1 month, And this is bound to give Linux Distro's a headache with build errors if we let it languish as an issue in beta for long.
Assignee: terrence → bugspam.Callek
Attachment #642671 - Attachment is obsolete: true
Attachment #657646 - Flags: review?(mh+mozilla)
(Assignee)

Comment 14

5 years ago
Created attachment 657647 [details] [diff] [review]
fix it both places v1.5

This time after qref'ing
Attachment #657646 - Attachment is obsolete: true
Attachment #657646 - Flags: review?(mh+mozilla)
Attachment #657647 - Flags: review?(mh+mozilla)
Attachment #657647 - Flags: review?(mh+mozilla) → review+
(Assignee)

Comment 15

5 years ago
Comment on attachment 657647 [details] [diff] [review]
fix it both places v1.5

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: None, but has Linux Distro problems if decline
Testing completed (on m-c, etc.): Landing on m-i now.
Risk to taking this patch (and alternatives if risky): NPOTB (our builds don't use --with-system-nspr)
String or UUID changes made by this patch: None

Without this patch, we risk linux distro's wasting time trying to compile Firefox 16 against an older [system] NSPR and getting confused, by taking this change we are able to error out early and let them know they need to update the dependancy in both their build tools and the rpm/yum/whatever repo they store it in.
Attachment #657647 - Flags: approval-mozilla-beta?
Attachment #657647 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 16

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/09b4f8b937cb
https://hg.mozilla.org/mozilla-central/rev/09b4f8b937cb
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla18
Comment on attachment 657647 [details] [diff] [review]
fix it both places v1.5

[Triage Comment]
NPOTB, good fix for Linux maintainers.
Attachment #657647 - Flags: approval-mozilla-beta?
Attachment #657647 - Flags: approval-mozilla-beta+
Attachment #657647 - Flags: approval-mozilla-aurora?
Attachment #657647 - Flags: approval-mozilla-aurora+
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
https://hg.mozilla.org/releases/mozilla-beta/rev/6522f25bc0c6
https://hg.mozilla.org/releases/mozilla-aurora/rev/001ea9e38a99
status-firefox16: --- → fixed
status-firefox17: --- → fixed
Keywords: checkin-needed
You need to log in before you can comment on or make changes to this bug.