Closed Bug 766520 Opened 9 years ago Closed 9 years ago

Signature placed above quote in plain text, entire message body is considered signature, variant 1

Categories

(Thunderbird :: Message Compose Window, defect)

13 Branch
x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 765673

People

(Reporter: john.mozilla, Unassigned)

Details

This bug is a variant on bug 762413, which was new in TB 13 and fixed in TB 13.0.1. Although that bug is now fixed, I have seen a variant of it still present in TB 13.0.1 on Windows at least which I describe below. I'm pretty sure this bug was new in TB 13 so is likely closely related to bug 762413 which was also new in TB 13, although I don't have an easy way to test. I also haven't tested in Seamonkey, so I don't know whether this should really be place in Mailnews Component.

Steps to reproduce, in TB 13.0.1 for Windows, starting from a brand new TB profile:

1, Click "Skip this and use my existing email" and setup access to email (in my case, IMAP to a MS Exchange server, but I don't think this matters)
2, Tools, Account Settings
3, Important: Leave the signature box blank
4, Composition & Addressing:
	a, Untick "Compose messages in HTML format"
	b, Tick "Automatically quote the original message when replying"
	c, Choose "start my reply above the quote"
	d, and place my signature "below my reply (above the quote)"
5, Click OK, then go into Tools, Account Settings again (important to do this rather than just clicking on the account name in the top-left, as you want the identity that you're just about to setup to have the same composition settings as the main account)
6, Click Manage Identities, then Add
7, Fill in a new name and email address (doesn't really matter what, but presumably must be different to the other email address)
8, Fill in "test" in the signature
9, OK, Close
10, Click Write
11, Change the From address to the one that you made in the additional identity
12, Tab into the message body and observe that there are no blanks lines above the signature, and that message body text placed above the signature is grey

The important thing about the above, and what is different from bug 762413, is that the problem only shows up if the main account has a blank signature, and an additional identity has a non-blank signature. (Incidentally, you will also notice while doing step 12 the appearance of bug 118050 - "Caret (cursor) is positioned after the signature if you change the identity (From: address)").
Dupe of Bug 765673 maybe?
(In reply to Loic from comment #1)
> Dupe of Bug 765673 maybe?

yes
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 765673
You need to log in before you can comment on or make changes to this bug.