Last Comment Bug 766793 - layout/media not always relinking when things change
: layout/media not always relinking when things change
Status: RESOLVED FIXED
[capacity]
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: x86 Windows 7
: -- blocker (vote)
: mozilla17
Assigned To: Kyle Huey [:khuey] (khuey@mozilla.com)
:
Mentors:
Depends on:
Blocks: 757339
  Show dependency treegraph
 
Reported: 2012-06-20 17:10 PDT by Bas Schouten (:bas.schouten)
Modified: 2012-08-24 16:03 PDT (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
unaffected
-
fixed


Attachments
Patch (2.69 KB, patch)
2012-08-23 12:17 PDT, Kyle Huey [:khuey] (khuey@mozilla.com)
ted: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Bas Schouten (:bas.schouten) 2012-06-20 17:10:04 PDT
Both me and Nick Cameron have noticed layout/media is not always relinking gkmedias.dll when stuff that is linked in there changes. (Like Azure for example)

This can cause unexpected (old) code to be run and linked in, causing all kinds of mysterious bugs. It can also cause newly added symbols not to be found when xul is linking to gkmedias. It's a big problem.
Comment 1 Ed Morley [:emorley] 2012-07-28 09:05:45 PDT
This was one of the (3-4) causes of bustage today that caused myself and RyanVM to spend about 6 hours of a weekend messing about with retriggers.

The changesets in question that landed were:
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=22eea4925efc

Examples of the crashes at:
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=a04448be734a

Please can someone take a look at this, since it's only going to bite us again (and you can bet during peak coalescing hours :-/).

:-)
Comment 2 Ed Morley [:emorley] 2012-07-28 09:06:40 PDT
CCing sheriffs who might be affected by this in the future.
Comment 3 Bas Schouten (:bas.schouten) 2012-08-21 09:12:25 PDT
Just as a reminder.. this bug is -still- there. This will continue to cause build bustages.
Comment 4 Ed Morley [:emorley] 2012-08-23 03:38:53 PDT
This bit us again on inbound last night. I have way too little build-system knowledge to know where to start with this, or I'd try and take a look myself :-(

Please may someone take a look?
Comment 5 Ed Morley [:emorley] 2012-08-23 05:14:19 PDT
And again this morning after https://hg.mozilla.org/integration/mozilla-inbound/rev/6229a3b222e4
Comment 6 Ed Morley [:emorley] 2012-08-23 11:29:40 PDT
And a few more times this afternoon/evening.

Every time I have to clobber on all platforms - this is really hurting our infra load at the moment.
Comment 7 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-08-23 12:17:31 PDT
Created attachment 654731 [details] [diff] [review]
Patch
Comment 8 Ted Mielczarek [:ted.mielczarek] 2012-08-23 12:19:08 PDT
Comment on attachment 654731 [details] [diff] [review]
Patch

Ugh.
Comment 9 Mike Hommey [:glandium] 2012-08-23 13:06:01 PDT
(In reply to Ted Mielczarek [:ted] from comment #8)
> Comment on attachment 654731 [details] [diff] [review]
> Patch
> 
> Ugh.

Amazing that it worked at all. And that has been there for, like, ever.
Comment 10 Mike Hommey [:glandium] 2012-08-23 15:14:56 PDT
(In reply to Mike Hommey [:glandium] from comment #9)
> Amazing that it worked at all. And that has been there for, like, ever.

Ah, I'm realizing this was triggered by bug 757339, which means this affects aurora but not beta.
Comment 11 Phil Ringnalda (:philor, back in August) 2012-08-23 15:21:15 PDT
Yeah, aurora showed the effects by hitting bug 777755 until I clobbered it.
Comment 12 Ryan VanderMeulen [:RyanVM] 2012-08-23 19:16:53 PDT
https://hg.mozilla.org/mozilla-central/rev/ecd18a2ed3ef
Comment 13 Lukas Blakk [:lsblakk] use ?needinfo 2012-08-24 10:58:59 PDT
Comment on attachment 654731 [details] [diff] [review]
Patch

[Triage Comment]
land away to Aurora.
Comment 14 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-08-24 11:01:41 PDT
https://hg.mozilla.org/releases/mozilla-aurora/rev/4e68f2c7176b

Note You need to log in before you can comment on or make changes to this bug.