Closed Bug 766808 Opened 9 years ago Closed 9 years ago

Cannot launch apps with icons using a relative url

Categories

(Firefox for Android Graveyard :: Web Apps (PWAs), defect, P1)

ARM
Android
defect

Tracking

(blocking-kilimanjaro:?, firefox16 verified)

VERIFIED FIXED
Firefox 16
blocking-kilimanjaro ?
Tracking Status
firefox16 --- verified

People

(Reporter: jsmith, Assigned: wesj)

References

Details

(Whiteboard: [blocking-webrtandroid1+])

Attachments

(1 file)

Steps:

1. Go to testmanifest.com
2. Modify the manifest to have icons point to non-existent locations
3. Save it
4. Install the web app
5. Go to about:apps and try to launch it

Expected:

The app should start in a chromeless window.

Actual:

Nothing happens.
Summary: Cannot launch apps with icons pointing to a 404 from about:apps → Cannot launch apps with icons pointing to a non-existent location from about:apps
With the fix to have default icons for apps without icons, I'm wondering if that will fix this problem by caveat. Re-test this to ensure.
Keywords: qawanted
I've just experienced this with an app that doesn't specify an icon (so has the default icon on Desktop), rather than an icon that doesn't exist.
(In reply to Andrew Williamson [:eviljeff] from comment #2)
> I've just experienced this with an app that doesn't specify an icon (so has
> the default icon on Desktop), rather than an icon that doesn't exist.

Ah, good point. Just saw that happen, although the build today for me does not show the default icon yet when you don't specify an icon.
Summary: Cannot launch apps with icons pointing to a non-existent location from about:apps → Cannot launch apps with no icons specified or icons pointing to a non-existent location from about:apps
Keywords: qawanted
(In reply to Jason Smith [:jsmith] from comment #3)
> (In reply to Andrew Williamson [:eviljeff] from comment #2)
> > I've just experienced this with an app that doesn't specify an icon (so has
> > the default icon on Desktop), rather than an icon that doesn't exist.
> 
> Ah, good point. Just saw that happen, although the build today for me does
> not show the default icon yet when you don't specify an icon.

Yeah, I don't get a default icon either on Android.

Actually I suppose my issue was more bug 749618 than this one.
I figure this is the same thing I'm seeing when installing 'Galactians 2' [1]. No shortcut is created, and in about:apps; I see no icon but mere text that is still un-launchable.

[1] https://marketplace.mozilla.org/en-US/app/galactians2/

--
Nightly (06/29)
Samsung Galaxy Nexus (Android 4.0.4)
blocking-kilimanjaro: --- → ?
Galactians 2 has an icon specified and desktop Firefox manages to find it just fine. I think there's a different problem there.
The issue about being unable to launch apps that have invalid icons will likely be resolved by bug 766260. I can launch apps now that do not have icons, although launching in general from the notification appears to be broken (that's a separate issue).
Attached patch PatchSplinter Review
Resolve relative urls using the app origin.
Assignee: nobody → wjohnston
Attachment #637989 - Flags: review?(mark.finkle)
No longer blocks: Blocking-FFA-WebRT1+
Summary: Cannot launch apps with no icons specified or icons pointing to a non-existent location from about:apps → Cannot launch apps with icons using a relative url
Comment on attachment 637989 [details] [diff] [review]
Patch

This keeps getting more and more complicated
Attachment #637989 - Flags: review?(mark.finkle) → review+
Duplicate of this bug: 769712
tracking-fennec: --- → ?
QA Contact: aaron.train
Priority: -- → P1
Whiteboard: [qa+]
https://hg.mozilla.org/mozilla-central/rev/422dcbefb833
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 16
V-F via Nightly (07/12), Samsung Galaxy Nexus (Android 4.1.1)
Status: RESOLVED → VERIFIED
Whiteboard: [qa+]
Whiteboard: [blocking-webrtandroid1+]
tracking-fennec: ? → ---
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.