Last Comment Bug 766917 - error: TEST FAILED: test-widget.testPanelWidget1 (timed out)
: error: TEST FAILED: test-widget.testPanelWidget1 (timed out)
Status: RESOLVED FIXED
:
Product: Add-on SDK
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All All
: P1 normal (vote)
: 1.9
Assigned To: Alexandre Poirot [:ochameau]
:
Mentors:
: 768584 (view as bug list)
Depends on:
Blocks: 768584 774088
  Show dependency treegraph
 
Reported: 2012-06-21 05:12 PDT by Alexandre Poirot [:ochameau]
Modified: 2012-07-25 10:23 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Pull request 471 (165 bytes, text/html)
2012-06-21 05:36 PDT, Alexandre Poirot [:ochameau]
rFobic: review+
Details

Description Alexandre Poirot [:ochameau] 2012-06-21 05:12:37 PDT
We are facing permanent failure on:
https://tbpl.mozilla.org/php/getParsedLog.php?id=12855856&tree=Firefox#error0
info: executing 'test-widget.testPanelWidget1'
error: An exception occurred.
Traceback (most recent call last):
  File "resource://1b658e06-2ace-4746-8c3a-96cb6a2540a4-at-jetpack/addon-kit/lib/panel.js", line 290, in _onShow
    let textColor = win.getComputedStyle(node).getPropertyValue("color");
[Exception... "Operation is not supported"  code: "9" nsresult: "0x80530009 (NotSupportedError)"  location: "resource://1b658e06-2ace-4746-8c3a-96cb6a2540a4-at-jetpack/api-utils/lib/loader.js -> resource://1b658e06-2ace-4746-8c3a-96cb6a2540a4-at-jetpack/addon-kit/lib/panel.js Line: 290"]
error: TEST FAILED: test-widget.testPanelWidget1 (timed out)

This exception is due to bug 764755, which changes panel anonymous XBL content.
So that the code that try to grab text color of panel fails.
Comment 1 Alexandre Poirot [:ochameau] 2012-06-21 05:36:44 PDT
Created attachment 635268 [details]
Pull request 471

This patch modify our code based on platform modification:
  http://hg.mozilla.org/mozilla-central/diff/e983572af03f/toolkit/content/widgets/popup.xml
And avoid breaking panel completely in case of issue during this action.
Comment 2 [github robot] 2012-06-21 15:25:32 PDT
Commits pushed to master at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/24b8ab3fb6b6067074d0577df1ca67fe75212e2c
Bug 766917: Fix application of panel style to its document.

https://github.com/mozilla/addon-sdk/commit/cd13decd45fe6c6c409f8408281e192d76b28bba
Merge pull request #471 from ochameau/bug/766917-fix-widget-test

Bug 766917: Fix application of panel style to its document. r=@gozala
Comment 3 Alexandre Poirot [:ochameau] 2012-07-07 14:57:10 PDT
*** Bug 768584 has been marked as a duplicate of this bug. ***
Comment 4 Eric Shepherd [:sheppy] 2012-07-07 17:46:51 PDT
Does this require rebuilding add-ons that were built against older SDKs?
Comment 5 Alexandre Poirot [:ochameau] 2012-07-07 18:08:31 PDT
Yes. Note that we are working on repackaging AMO addons.
I already built a repacker script which is working quite well:
  https://github.com/ochameau/jetpack-repacker
(Still missing some features)
But now, we mostly need to setup a plan to reach addons authors.
Comment 6 Alexandre Poirot [:ochameau] 2012-07-18 05:29:15 PDT
Hum this appear to be missing in 1.9b2.
Why isn't it in stabilization branch as it landed before the merge from master to stab? Landed on 06/21 altought merge should have been done on 06/26.
Am I misunderstanding our branches workflow, is there something wrong in 
  https://wiki.mozilla.org/Jetpack/SDK_2012_Release_Schedule
?

This change should definitely be pulled in next 1.9 version!
Comment 7 Wes Kocher (:KWierso) 2012-07-18 11:49:10 PDT
(In reply to Alexandre Poirot (:ochameau) from comment #6)
> Hum this appear to be missing in 1.9b2.
> Why isn't it in stabilization branch as it landed before the merge from
> master to stab? Landed on 06/21 altought merge should have been done on
> 06/26.
> Am I misunderstanding our branches workflow, is there something wrong in 
>   https://wiki.mozilla.org/Jetpack/SDK_2012_Release_Schedule
> ?
> 
> This change should definitely be pulled in next 1.9 version!

Is this not what's on stabilization right now? https://github.com/mozilla/addon-sdk/blob/stabilization/packages/addon-kit/lib/panel.js#L274
Comment 8 Alexandre Poirot [:ochameau] 2012-07-18 12:27:58 PDT
Oh right nevermind I was completely misreading panel.js ... everything is fine!
This change is already part of 1.9b1.
Comment 9 [github robot] 2012-07-25 10:23:12 PDT
Commit pushed to release at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/c64ad82e81db8933cef4246b366f5926d7a8e764
Merge pull request #471 from ochameau/bug/766917-fix-widget-test

Bug 766917: Fix application of panel style to its document. r=@gozala(cherry picked from commit cd13decd45fe6c6c409f8408281e192d76b28bba)
Comment 10 [github robot] 2012-07-25 10:23:15 PDT
Commit pushed to stabilization at https://github.com/mozilla/addon-sdk

https://github.com/mozilla/addon-sdk/commit/c64ad82e81db8933cef4246b366f5926d7a8e764
Merge pull request #471 from ochameau/bug/766917-fix-widget-test

Note You need to log in before you can comment on or make changes to this bug.