cnn.com returns desktop not mobile site to Fennec

RESOLVED FIXED

Status

Tech Evangelism
Mobile
RESOLVED FIXED
6 years ago
3 years ago

People

(Reporter: lmandel, Assigned: karlcow)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [sitewait] [country-all] [serversniff] , URL)

CNN returns the desktop version of their site, not the mobile version to Fennec due to UA sniffing. 

Spoofing the iPhone UA in Fennec results in the CNN mobile site being returned, which appears to be mostly functional. (See bug 766949.)

Updated

5 years ago
Component: Evangelism → Mobile
Product: Firefox for Android → Tech Evangelism

Updated

5 years ago
Duplicate of this bug: 875898

Comment 2

5 years ago
Is there any update to this.
I would have thought it's a popular site affecting many users.
Although we log issues in Bugzilla just because an issue is logged doesn't mean that anyone is actively working on it. As the reporter, I have no update for this issue at this time but did confirm that the issue is still valid. 

If you have time to help contact CNN please do!
CNN also sends the FirefoxOS UA a low-fi mobile site, rather than the more hi-fi one the iPhone get. (FxOS is redirected to "cnnmobile.com").
Assignee: nobody → hsteen
Status: NEW → ASSIGNED
Contacted on Twitter and through web form
Whiteboard: [sitewait]
Karl, you seem to have some Turner media power or plain luck - mind taking on this one too? ;-)
Assignee: hsteen → kdubost
(Assignee)

Comment 7

4 years ago
The issue is multiple.

* Firefox OS gets the low-fi mobile site now.
  It is a revert of the progress we had previously.
  https://bugzilla.mozilla.org/show_bug.cgi?id=878635
* Firefox Android gets a desktop site
* Opera Mobile gets a nice mobile site.
* Iphone seems to receive a different mobile site (at least looking at the markup)



# FIREFOX OS

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: www.cnn.com
User-Agent: Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

HTTP/1.1 302 Moved Temporarily
Cache-Control: private, no-cache
Connection: keep-alive
Content-Length: 154
Content-Type: text/html
Date: Wed, 13 Nov 2013 16:47:31 GMT
Location: http://m.cnn.com
Server: nginx
Set-Cookie: CG=CA:ON:Toronto; path=/
Vary: *



# Firefox Android

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: www.cnn.com
User-Agent: Mozilla/5.0 (Android; Mobile; rv:18.0) Gecko/18.0 Firefox/18.0

HTTP/1.1 200 OK
Cache-Control: max-age=60, private
Connection: keep-alive
Content-Encoding: gzip
Content-Type: text/html
Date: Wed, 13 Nov 2013 16:47:44 GMT
Expires: Wed, 13 Nov 2013 16:48:40 GMT
Last-Modified: Wed, 13 Nov 2013 16:47:22 GMT
Server: nginx
Set-Cookie: CG=CA:ON:Toronto; path=/
Transfer-Encoding: chunked
Vary: Accept-Encoding


# Iphone

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: www.cnn.com
User-Agent: Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.48.3

HTTP/1.1 200 OK
Cache-Control: max-age=60, private
Connection: keep-alive
Content-Encoding: gzip
Content-Type: text/html
Date: Wed, 13 Nov 2013 16:48:35 GMT
Expires: Wed, 13 Nov 2013 16:49:34 GMT
Last-Modified: Wed, 13 Nov 2013 16:48:25 GMT
Server: nginx
Set-Cookie: CG=CA:ON:Toronto; path=/
Transfer-Encoding: chunked
Vary: Accept-Encoding


# Opera Mobile

GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate, compress
Host: www.cnn.com
User-Agent: Opera/12.02 (Android 4.1; Linux; Opera Mobi/ADR-1111101157; U; en-US) Presto/2.9.201 Version/12.02

HTTP/1.1 200 OK
Cache-Control: max-age=60, private
Connection: keep-alive
Content-Encoding: gzip
Content-Type: text/html
Date: Wed, 13 Nov 2013 16:49:06 GMT
Expires: Wed, 13 Nov 2013 16:50:02 GMT
Last-Modified: Wed, 13 Nov 2013 16:48:15 GMT
Server: nginx
Set-Cookie: CG=CA:ON:Toronto; path=/
Transfer-Encoding: chunked
Vary: Accept-Encoding
Whiteboard: [sitewait] → [sitewait] [country-all] [serversniff]
(Assignee)

Comment 8

4 years ago
OK contacted CNN.
(Assignee)

Updated

4 years ago

Updated

4 years ago
Duplicate of this bug: 961730
Can we at least use a UA override on this for now?
(Assignee)

Comment 11

4 years ago
(In reply to Ryan VanderMeulen [:RyanVM UTC-4] from comment #10)
> Can we at least use a UA override on this for now?

It will hurt more to use UA override.

* Firefox OS receives the *lowfi* mobile version. So not the best, but usable.
* Firefox Android receives the desktop version BUT has no UA override mechanism.

I have tried to reach out (again) my contact there. 

btw, now and for me in Japan

cnn.com -> http://edition.cnn.com/ (for desktop)
cnn.com -> http://cnnmobile.com/ (for simple mobile)
(Assignee)

Updated

4 years ago
Duplicate of this bug: 603818
Duplicate of this bug: 1003135
(Assignee)

Updated

4 years ago
See Also: → bug 1019179
(Assignee)

Comment 14

3 years ago
Contacted someone from CNN today about it.
Responsive design site rolled out over New Years. Works in Firefox for Android.
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.