cnn.com doesn't recognize Fennec or B2G UA as mobile

RESOLVED FIXED

Status

Tech Evangelism
Mobile
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: lmandel, Assigned: karlcow, NeedInfo)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [uaoverride] [country-all] [serversniff] [sitewait], URL)

cnn.com serves a desktop site to B2G. Bug 823364 added an UA override for this domain. The override should be removed once the domain serves mobile content to B2G. This bug tracks the evangelism for the site to recognize the B2G UA and the removal of the override at that time.
Blocks: 766947
URL: cnn.com
Whiteboard: [uaoverride]
cnn.com also doesn't recognize Fennec as mobile.
OS: Gonk (Firefox OS) → All
Summary: cnn.com doesn't recognize B2G UA as mobile → cnn.com doesn't recognize Fennec or B2G UA as mobile
(Assignee)

Comment 2

5 years ago
ok that is quite interesting, and opposite to the usual thing. the Mobile is working but not the Android Mobile.

→ http HEAD http://www.cnn.com/  User-Agent:'Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0' 

HTTP/1.1 302 Moved Temporarily
Location: http://m.cnn.com


→ http HEAD http://www.cnn.com/  User-Agent:'Mozilla/5.0 (Android; Mobile; rv:18.0) Gecko/18.0 Firefox/18.0' 

HTTP/1.1 200 OK


I have tested on ZTE device after removing the cnn.com and confirmed it is working. I haven't tested on Android (my device is not with me now.).
I get desktop content in Firefox for Android with a banner ad to install their Android app.
(Fennec issue is tracked in bug 766951 - do you want to track them both in this and mark that as dup, or track them separately?)
(Assignee)

Comment 5

5 years ago
Usually I prefer to track them separately specifically because the UA override is not the same and that's two different lists.
(Assignee)

Comment 6

5 years ago
So it's a bit messy.

Opera Mobile + Android -> Mobile (graphics)
Firefox OS   + ZTE     -> Mobile (text)
Opera Mini   + Android -> Desktop
Firefox      + Android -> Desktop

Opera Mobile, Firefox for Android and Firefox OS should receive the graphical mobile version
Opera Mini should receive the mobile text version.
Assignee: nobody → kdubost
Whiteboard: [uaoverride] → [uaoverride] [country-all] [serversniff]
(Assignee)

Comment 7

5 years ago
Hi Daniel,
Could you help us on this one?
Thanks.
Flags: needinfo?(daniel.wester)
Whiteboard: [uaoverride] [country-all] [serversniff] → [uaoverride] [country-all] [serversniff] [sitewait]
(Assignee)

Comment 8

5 years ago
Contact with CNN started.
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 9

5 years ago
And this is fixed!
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

5 years ago
Blocks: 911260
(Assignee)

Comment 10

5 years ago
We need to open a new bug on this one. They went to a low text version.
Or to follow up on https://bugzilla.mozilla.org/show_bug.cgi?id=766951
I want to keep this one closed at it was about the UA override.
You need to log in before you can comment on or make changes to this bug.