NOSCRIPT content not displayed if JavaScript is turned off

VERIFIED FIXED in M18

Status

()

P1
normal
VERIFIED FIXED
20 years ago
19 years ago

People

(Reporter: bam, Assigned: harishd)

Tracking

({html4})

Trunk
PowerPC
Mac System 8.6
html4
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+][fixinhand], URL)

Attachments

(2 attachments)

(Reporter)

Description

20 years ago
I'm not sure what my expectation with respect to Javascript working or not
should be in Macintosh M6, but this is at least an HTML rendering bug, and
perhaps also a Javascript bug if it is supposed to work.

Apple's developer website, http://www.apple.com/developer/ has three HTML
select controls in the upper left corner. When you pick them, it is supposed to
take you to the appropriate developer area via javascript, if you have it
enabled, or via a "go" button next to each select control, embedded in <
noscript>
tags so you should see them if you have javascript disabled.

Regardless of the setting in edit->prefs->advanced for javascript, the "go"
buttons inside the <noscript> tags are not rendered. Also, the javascript does
not appear to do anything if javascript is enabled in mozilla, so the page
is not navigable.

Updated

20 years ago
QA Contact: leger → desale

Comment 1

20 years ago
desale, can you reproduce and give comments?  Thanks!

Updated

20 years ago
Assignee: don → rickg
Component: Apprunner → Layout

Comment 2

20 years ago
Rick,

Any idea who should get this?  You or maybe vidur?  I'm not sure ...

Updated

20 years ago
Status: NEW → ASSIGNED

Comment 3

20 years ago
This is a legit bug. We assume (now) that javascript is always on. If we offer a
pref where it can be turned off, then <noscript> needs to be dealt with.

Comment 4

20 years ago
I tried to reproduce the bug.
On Mac OS:
Javascript seems not working, and even if we try to disable javascript the image
inside <NOSCRIPT> tags does not appear. When we pick any select control, it is
supposed to take you to appropriate page, but it seems its not working. I tried
to desable javascript also, in order to see the go button inside <NOSCRIPT>
tags, but I can't see that also.
I found some different behaviour on Win-95.
Win-95:
Javscript seems working on windows-95 even if javascript disabled as well as
enabled.
Javascript works but you have to click select menu twice.
Means, you select option from select menu then leave it. [Now it is supposed to
take you to another appropriate page, but nothing happens]. Now again you click
select menu to select option once more [Now you'll see, as soon as you click
select, it'll take you to the page you selected previously.]
(Assignee)

Updated

20 years ago
Assignee: rickg → harishd
Status: ASSIGNED → NEW
(Assignee)

Updated

20 years ago
Target Milestone: M14
(Assignee)

Comment 5

20 years ago
Assigning bug to myself.  I don't think this is a beta stopper..so moving it to
M14.
(Assignee)

Updated

20 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

20 years ago
Target Milestone: M14 → M12

Updated

20 years ago
Target Milestone: M12 → M13

Comment 6

19 years ago
*** Bug 22172 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

19 years ago
Target Milestone: M13 → M14
(Assignee)

Comment 7

19 years ago
Need to fix bug 21008 inorder to fix this one.  Moving to M14.
(Assignee)

Comment 8

19 years ago
I think I've the fix for 21008.  But this bug would get fixed only after hooking 
up prefs. ( to set/unset JS ), which I don't think is going to happen for M14.

So moving this one to M15.
Target Milestone: M14 → M15
(Assignee)

Comment 9

19 years ago
Moved to M16.
Target Milestone: M15 → M16
(Assignee)

Updated

19 years ago
Priority: P3 → P1
(Assignee)

Comment 10

19 years ago
*** Bug 35090 has been marked as a duplicate of this bug. ***

Comment 11

19 years ago
Just giving this bug a nice summary.
Summary: Javascript or HTML rendering error → NOSCRIPT content not displayed if JavaScript is turned off
(Assignee)

Comment 12

19 years ago
The prefs. [ To enable NOSCRIPT ] will not be land until post beta2. Marking M17
Target Milestone: M16 → M17
Nominating nsbeta3 as reminder. Strictly speaking, this *is* an html40 handling 
correctness issue (although NOSCRIPT isn't widely used and most people run with 
JS on, this is still important for accessibility & high-security environment 
customers who run with JS off). Recommend [nsbeta3+].
Keywords: html4, nsbeta3
Blocks: 7954
(Assignee)

Updated

19 years ago
Target Milestone: M17 → M18
(Assignee)

Comment 14

19 years ago
Created attachment 11365 [details] [diff] [review]
Proposed patch - version 1.1
(Assignee)

Updated

19 years ago
Whiteboard: Fix in hand

Comment 15

19 years ago
Marking nsbeta3+. 
Whiteboard: Fix in hand → [nsbeta3+][Fix in hand]

Updated

19 years ago
Blocks: 21008
(Assignee)

Comment 16

19 years ago
Removed [Fix in hand] from the summary beacause my fix is not complete.
Whiteboard: [nsbeta3+][Fix in hand] → [nsbeta3+]
I suggest you remove <NOSCRIPT> from
    http://www.mozilla.org/quality/help/bug-form.html
until this is fixed; that particular page should not be blank:-)
(Assignee)

Comment 18

19 years ago
*** Bug 9059 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 19

19 years ago
Note: Before closing this bug make sure that bug 9059 is also fixed.
(Assignee)

Comment 20

19 years ago
*** Bug 49459 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 21

19 years ago
Note: Before closing this bug make sure that bug 49459 is also fixed.

Comment 22

19 years ago
Harish has the fix in hand.  Will check it in over today or tomorrow.
Whiteboard: [nsbeta3+] → [nsbeta3+][fixinhand]

Comment 23

19 years ago
*** Bug 50860 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 24

19 years ago
Fix is in. Disable JS and see NOSCRIPT content getting displayed. I don't think 
the URL is still the same. Anyway to test NOSCRIPT use the testcases in bug 9059 
and bug 45959.

Marking FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 25

19 years ago
Bug 9059 is not fully fixed by this patch.  If the contents of the NOSCRIPT tag 
also contain a BODY tag (ie: to set the background color), the contents of the 
NOSCRIPT tag is always shown, regardless of whether or not JavaScript is 
enabled.

Should this bug be reopened?

Build: 2000090808 on Win2000 SP1

Comment 26

19 years ago
Created attachment 14321 [details]
Modified test case from bug 9059 w/ BODY tag inside NOSCRIPT tag
(Assignee)

Comment 27

19 years ago
Frank, please open up a separate bug. Thanx

Comment 28

19 years ago
Opened bug 52136 to track this issue.

Comment 29

19 years ago
Verified with 2000-091309. Marking verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.