frameset doesn't load when noscript element appears between it and head element

VERIFIED DUPLICATE of bug 7670

Status

()

Core
HTML: Parser
P2
normal
VERIFIED DUPLICATE of bug 7670
19 years ago
6 years ago

People

(Reporter: Chad House, Assigned: harishd)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE], URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Overview:

   A frameset will not load if a noscript element (empty or otherwise)
   appears between the HEAD element and the FRAMESET.

Steps to Reproduce:

   1. Load attached testcase

Actual Results:

   A blank page is displayed.

Expected Results:

   The frameset is loaded. The top frame loads www.gnu.org, while the
   bottom frame loads www.linux.org.

Build Date & Platform:

   M7 viewer and apprunner on x86 Linux 2.0.36 (Build ID: 1999062115)

Additional Information:

   See attached testcase.
(Reporter)

Comment 1

19 years ago
Created attachment 625 [details]
testcase
(Reporter)

Updated

19 years ago
Summary: [TESTCASE] frameset doesn't load when noscript element appears between it and head element → frameset doesn't load when noscript element appears between it and head element
Whiteboard: [TESTCASE]

Updated

19 years ago
Assignee: karnaze → pollmann

Comment 2

19 years ago
Reassigning to Eric.

Comment 3

19 years ago
Addtion Platform I tested.

OS / Build : Win98 / Build ID 1999070614 < Mislabeld 8-16-1999-14 >

Result : Blank Page / Document: done 2.3sec.

Comment 4

19 years ago
bug 11407 is a possible dup - problems with NOSCRIPT tags and document.write,
which is blocking some sidebar features, in which case M15 is much too late.

Updated

19 years ago
Assignee: pollmann → harishd

Comment 5

19 years ago
There's a good chance these are related.  This looks like it may (?) be a parser
or content sink issue?

I'm forwarding this to Harish because the content model is not getting formed
correctly:

<html>

<head>
<title>Bug 3943</title>
</head>

<noscript>
Doesn't matter what goes here - it can even be empty.
</noscript>

<!-- This frameset won't load thanks to the noscript element above -->

<frameset rows="30%,*">
   <frame src="http://www.gnu.org">
   <frame src="http://www.linux.org">
</frameset>

</html>

Gives this when I dump the content model in Viewer:

webshell=0x80f01c8
html refcount=3<
  head refcount=2<
    title refcount=2<
      Text refcount=2<Bug 3943>
    >
  >
  body refcount=3<
    Text refcount=3<\n\n>
    Comment refcount=2<<!-- This frameset won't load thanks to the noscript
element above -->>
    Text refcount=3<\n\n\n   \n   \n\n\n>
  >
>

It seems that <NOSCRIPT> is opening up and body element.  When I remove the
<NOSCRIPT> (http://blueviper/frames/noscript.html) I get this, which looks a lot
better:

webshell=0x80f01c8
html refcount=3<
  head refcount=2<
    title refcount=2<
      Text refcount=2<Bug 3943>
    >
    Comment refcount=2<<!-- This frameset won't load thanks to the noscript
element above -->>
  >
  frameset rows=30%,* refcount=4<
    frame src=http://www.gnu.org refcount=4<>
    frame src=http://www.linux.org refcount=4<>
  >
>

Updated

19 years ago
Component: HTMLFrames → Parser
OS: Linux → All
Hardware: PC → All
Target Milestone: M15
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

19 years ago
Checked in a fix.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 7

19 years ago
using the 19990830 build on win95, mac, and linux -- the attached test case
renders correctly. Marking verified.

Updated

18 years ago
Status: VERIFIED → REOPENED

Comment 8

18 years ago
This bug re-appears in Win32 build 1999123008 on Windows 98.  (Try also
http://www.firstauction.com/)  See bug #22827

Comment 9

18 years ago
*** Bug 22827 has been marked as a duplicate of this bug. ***

Comment 10

18 years ago
*** Bug 22827 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
Target Milestone: M13
(Assignee)

Updated

18 years ago
Priority: P3 → P2
(Assignee)

Updated

18 years ago
Status: REOPENED → ASSIGNED
(Assignee)

Updated

18 years ago
Resolution: FIXED → ---
(Assignee)

Comment 11

18 years ago
*** Bug 22002 has been marked as a duplicate of this bug. ***

Comment 12

18 years ago
*** Bug 21851 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 13

18 years ago
*** Bug 21590 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Assignee: harishd → rickg
Status: ASSIGNED → NEW

Comment 14

18 years ago
This is fixed in my tree awaiting a chance to land.

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → FIXED

Comment 15

18 years ago
Fixed by improvements to heuristics used to deal with badly formed framesets.

Comment 16

18 years ago
All of the bugs I found about not being able to customise my.netscape.com panels 
point to this bug as the culprit.  customizing bookmarks, or weather or any 
panel in mynetscape loads a blank page with my trunk win32 M18 build today 
072808.  If it is not this bug (the testcase here seems to work) then I'll file 
a new one.

Comment 17

18 years ago
Asa, should this bug be reopened and assigned to Harish or me?  Is the original
test case failing?

Comment 18

18 years ago
The testcase passes but bug 22002 bug 21851 and bug 21590 (all marked dupe of
this bug) fail.  I'm not sure if we should reopen those bugs or reopen this bug.  

Comment 19

18 years ago
Harish, looks like this is still failing for some set of test cases.  I'm
reopening it and CC'ing you.  Do you know what Rick did to fix this one
originally?

Comment 20

18 years ago
reopen...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 21

18 years ago
Off to harish, who has been working on noscript issues.
Assignee: rickg → harishd
Status: REOPENED → NEW
(Assignee)

Comment 22

18 years ago
This will get resolved when NOSCRIPT is enabled ( Ref. Bug 7670 ). Marking this 
a dup ( not exactly! ) of 7670.   

*** This bug has been marked as a duplicate of 7670 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 23

17 years ago
Dupe is now fixed and this testcase now works. Verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.