java.lang.NullPointerException: at org.mozilla.gecko.GeckoApp.onPrepareOptionsMenu(GeckoApp.java) at org.mozilla.gecko.GeckoApp.invalidateOptionsMenu(GeckoApp.java)

RESOLVED DUPLICATE of bug 773089

Status

()

defect
--
critical
RESOLVED DUPLICATE of bug 773089
7 years ago
7 years ago

People

(Reporter: scoobidiver, Unassigned)

Tracking

({crash, topcrash})

14 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox14 affected, firefox15 unaffected, firefox16 unaffected, blocking-fennec1.0 -, fennec+)

Details

(Whiteboard: [native-crash][startupcrash], crash signature)

This bug tracks crashes not fixed by bug 760267.

It's #3 top crasher in 14.0b8.

java.lang.NullPointerException
	at org.mozilla.gecko.GeckoApp.onPrepareOptionsMenu(GeckoApp.java:436)
	at org.mozilla.gecko.GeckoApp.invalidateOptionsMenu(GeckoApp.java:386)
	at org.mozilla.gecko.Tabs$2.run(Tabs.java:141)
	at android.os.Handler.handleCallback(Handler.java:605)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:137)
	at android.app.ActivityThread.main(ActivityThread.java:4424)
	at java.lang.reflect.Method.invokeNative(Native Method)
	at java.lang.reflect.Method.invoke(Method.java:511)
	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:784)
	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:551)
	at dalvik.system.NativeStart.main(Native Method)

More reports at:
https://crash-stats.mozilla.com/report/list?product=FennecAndroid&version=FennecAndroid%3A14.0b8&signature=java.lang.NullPointerException%3A%20at%20org.mozilla.gecko.GeckoApp.onPrepareOptionsMenu%28GeckoApp.java%29
I found out that the patches in bug 760267 were not landed for the beta. If we see these crashes on nightly or aurora, please reopen. But since the fix is not in 14.0b8, I will dupe this.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 760267
(In reply to Mark Finkle (:mfinkle) from comment #1)
> If we see these crashes on nightly or aurora, please reopen.
Bug 760357 that has the same signature but a different stack is still applicable on Aurora.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
It's fixed in the trunk by an unknown patch different from the one in bug 760267. Indeed there are no crashes after 16.0a1/20120619.
It's not even fixed in the trunk. See bug 760267 comment 41.
Sriram, this NPE from GeckoApp.onPrepareOptionsMenu() is our #2 topcrash for Firefox 14.0.
Assignee: nobody → sriram
(In reply to Chris Peterson (:cpeterson) from comment #5)
> Sriram, this NPE from GeckoApp.onPrepareOptionsMenu() is our #2 topcrash for
> Firefox 14.0.

We didn't uplift the patch for 14.0, hence the crashes are expected to happen. However, in next beta/release, this wouldn't be seen.
Assignee: sriram → nobody
tracking-fennec: --- → +
blocking-fennec1.0: ? → -
(In reply to Sriram Ramasubramanian [:sriram] from comment #6)
> We didn't uplift the patch for 14.0, hence the crashes are expected to
> happen. However, in next beta/release, this wouldn't be seen.
I am surprised that a patch that hasn't fixed crashes in Aurora (see bug 760357) will fix crashes in Beta.
Fixing bug 766861 in the trunk will probably fix this crash after uplift to Beta.
(In reply to Sriram Ramasubramanian [:sriram] from comment #6)
> However, in next beta/release, this wouldn't be seen.
First 14.0b10 crash stats confirm that the #1 top crasher is not fixed: https://crash-stats.mozilla.com/report/list?version=FennecAndroid%3A14.0b10&signature=java.lang.NullPointerException%3A%20at%20org.mozilla.gecko.GeckoApp.onPrepareOptionsMenu%28GeckoApp.java%29
blocking-fennec1.0: - → ?
Let's focus on fixing this on trunk and see what we can uplift
blocking-fennec1.0: ? → -
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 773089
You need to log in before you can comment on or make changes to this bug.