Firefox 13.0.1 does not correctly load certain pages that are correctly loaded by Chrome 19.0.1084.56 m and Opera 12.00 build 1467.

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: Patrick Sedgwick, Unassigned)

Tracking

13 Branch
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0.1
Build ID: 20120614114901

Steps to reproduce:

Visited certain pages, e.g.
(a) http://www.bbc.co.uk/iplayer/diagnostics (and clicked the "Start Test" button)
(b) http://wdc.com/en/products/products.aspx?id=280#%23ffffff
(c) http://www.bbc.co.uk/news/science-environment-18540381


Actual results:

For (a): an error message resulted, "Configuration load failed. The configuration for the Speed Test couldn't be loaded..."

For (b): underneath the heading "My Book Live" and menu-bar "Highlights / Features ... ...  / Accessories / Support", a large blank white space appeared where images and text should be loaded.

For (c): in the embedded video frame, a rotating "please wait" indicator was displayed.. unendingly.


Expected results:

For (a): A speed test should have been executed. It is, in Chrome and Opera.

For (b): Images and text should be loaded. They are, in Chrome and Opera.

For (c): A video should play. It does, in Chrome and Opera.
All 3 pages are using flash and they work for me with Seamonkey trunk and Firefox13.0.2 with the Flash plugin NPSWF32_11_3_300_262

Please try a new profile
http://support.mozilla.org/kb/Managing%20profiles

And if that doesn't work try to disable the protected mode in flash
http://forums.adobe.com/thread/1018071?tstart=0 (under last resort)

Report this bug to Adobe if disabling the Proteced mode fixes your issue.
(Reporter)

Comment 2

6 years ago
2012-06-26 10:43 UK time:

Renewing the profile did not help.

But the following  steps from the Adobe thread cited above did fix the problem, WITHOUT having to disable Flash Protected Mode:
* Problem: Flash content does not appear, YouTube display errors such as "An error occurred.  Please try again later.", or Flash video will not function properly.
 
* Solution: If RealPlayer is installed on your system, please disable the RealPlayer Browser Record plug-in.
 
> Launch RealPlayer
> Click the RealPlayer icon [button] in the upper left corner of the window and choose Preferences.
> Choose Download & Recording from the left hand panel
> Uncheck "Enable Web Download & Recording for these installed browsers" [Note: Firefox was not listed as one of the installed browsers -- but I still unchecked the box].
> Click OK and close RealPlayer
> Restart Firefox
You had the realplayer addon installed ?
This addon should have been blocked !
Do you manually enabled the blocked addon or do you disabled the blocklist download ?

Please post the version string from the addon and the realplayer plugin.
Extension: Tools/add-ons/extensions
Plugins: Tools/add-ons/Plugins
(Reporter)

Comment 4

6 years ago
No, I didn't manually enable or disable, or manually block or unblock, anything.

I don't remember updating RealPlayer and its elements recently, but it looks (from the list below) as if RealPlayer updated itself on 27 May 2012.

Or perhaps I may have answered an "update?" prompt; if software tells me it needs to update itself, and I know the software was previously installed by me, I usually allow it to update itself.

Here are the results of inspecting my Firefox add-ons.

[Firefox orange button at top left] > Extensions > :
    no RealPlayer extension is listed.

[Firefox orange button at top left] > Plugins > :
    RealJukebox NS Plugin 15.0.4.53
    RelNetworks(tm) Chrome Background Extension Plugin 15.0.4.53 
    RealPlayer Download Plugin 15.0.4.53
    RealPlayer(tm) G2 LiveConnect-Enabled Plug-In (32-bit) 15.0.4.53
    RealPlayer(tm) HTML5VideoShim Plug-In (32-bit) 15.0.4.53

    All the above declare themselves to have been last updated 27 May 2012.
Patrick: 
You disabled the "RealPlayer Download Plugin 15.0.4.53" and it worked ?


jorge/juanb: only the extension is blocked but not the plugin, right ?
Should we extend to block to the plugin ?
Blocks: 764210
(Reporter)

Comment 6

6 years ago
Created attachment 636685 [details]
RealPlayer preferences showing what is now unchecked
(Reporter)

Comment 7

6 years ago
Created attachment 636686 [details]
B - Firefox extensions screen
(Reporter)

Comment 8

6 years ago
Created attachment 636687 [details]
C - Firefox Plugins screen
(Reporter)

Comment 9

6 years ago
Matti:

I have not -- at least, not yet -- disabled the RealPlayer Download plugin in Firefox.

I have "disabled" (unchecked a preference-setting) in RealPlayer (see first attachment).

That seems to have allowed the 3 pages which did not work before, to work now. That is consistent with the advice on the Adobe web-page you kindly pointed me to, and the procedural steps on that which I followed and reproduced in Comment 2.

My Firefox extensions and plug-ins are illustrated in attachments B and C.

Updated

6 years ago
Component: Untriaged → Plug-ins
Product: Firefox → Core
QA Contact: untriaged → plugins
Matthias, Patrick, when you uncheck the preference in the RealPlayer dialog, it disables the "RealPlayer Browser Record Plugin" extension, but it leaves the plugin installed. During our testing, doing this proved the most reliable way to make Flash work again, at the expense of disabling the recording feature.

Disabling the extension also worked in all of my testing, but some users said this did not work for them.
(Reporter)

Comment 11

6 years ago
Juan, and others including Matti, thank you.

I will, then, just leave that RealPlayer setting unchecked. That seems to have fixed the problem for me.

What a pity that RealPlayer and Adobe, so it would seem, can't make their software work properly with each other and/or with Firefox.

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Juan, I'm seeing this in SUMO as well. We are still getting a lot of reports of the same symptoms caused by this issue. There are definitely some users who openly admit that they turned the thing back on, but I don't think that is the case for all of them.

Updated

6 years ago
Blocks: 771802
You need to log in before you can comment on or make changes to this bug.