Last Comment Bug 771802 - More Blocklist RealPlayer Download Plugin add-ons
: More Blocklist RealPlayer Download Plugin add-ons
Status: RESOLVED FIXED
: qawanted
Product: Toolkit
Classification: Components
Component: Blocklisting (show other bugs)
: unspecified
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: Marcia Knous [:marcia - use ni]
Mentors:
Depends on: 764210 768234
Blocks: 763459
  Show dependency treegraph
 
Reported: 2012-07-07 09:42 PDT by Alex Keybl [:akeybl]
Modified: 2016-03-07 15:30 PST (History)
30 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Alex Keybl [:akeybl] 2012-07-07 09:42:16 PDT
Please block the add-ons in https://bugzilla.mozilla.org/show_bug.cgi?id=764210#c35 for the versions Marcia provides shortly.

+++ This bug was initially created as a clone of Bug #764210 +++

Plugin name: RealPlayer Download Plugin
Plugin versions to block: <=15.0.4.53
Applications, versions, and platforms affected: Windows
Block severity: hard

How does this plugin appear in about:plugins?
     File: nprpplugin.dll
     Version: 15.0.4.53
     Description: RealPlayer Download Plugin

Reasons: bug 763459 – RealPlayer Browser record plugin breaks Youtube since Fx13
Comment 1 Marcia Knous [:marcia - use ni] 2012-07-07 10:13:26 PDT
Plugin name: RealPlayer Download Plugin
Plugin versions to block: <=15.0.5.109
Applications, versions, and platforms affected: Windows
Block severity: hard

How does this plugin appear in about:plugins?
    File: nprpplugin.dll
    Version: 15.0.5.109
    RealPlayer Download Plugin
Comment 2 Jorge Villalobos [:jorgev] 2012-07-07 12:23:37 PDT
Marcia, I need the version number for the extension, not the plugin, unless you think we need to block the plugin instead of the add-on.
Comment 3 Jorge Villalobos [:jorgev] 2012-07-07 12:24:00 PDT
(In reply to Jorge Villalobos [:jorgev] from comment #2)
> instead of the add-on.

instead of the extension.
Comment 4 Marcia Knous [:marcia - use ni] 2012-07-07 18:59:36 PDT
I just did a quick test in my VM and confirmed that disabling the addon does restore the ability to play videos, so it doesn't appear that we have to do anything about the plugin. Oddly the extension has "plugin" in its name so it is a bit confusing: 

Here is the info you need regarding the addon:

RealPlayer Browser Record Plugin 15.0.5
{C3949AC2-4B17-43ee-B4F1-D26B9D42404D}
Comment 5 Jorge Villalobos [:jorgev] 2012-07-07 23:56:53 PDT
The blocks have been updated on staging:
https://addons-dev.allizom.org/en-US/firefox/blocked/i92
https://addons-dev.allizom.org/en-US/firefox/blocked/i95

Alex, let me know if I should just go ahead and update the blocks on prod without waiting for QA confirmation. I don't expect any problems given that they're the same blocks with just a version bump.
Comment 6 Alex Keybl [:akeybl] 2012-07-08 09:27:33 PDT
(In reply to Jorge Villalobos [:jorgev] from comment #5)
> The blocks have been updated on staging:
> https://addons-dev.allizom.org/en-US/firefox/blocked/i92
> https://addons-dev.allizom.org/en-US/firefox/blocked/i95
> 
> Alex, let me know if I should just go ahead and update the blocks on prod
> without waiting for QA confirmation. I don't expect any problems given that
> they're the same blocks with just a version bump.

Agreed, let's just go for it.
Comment 7 Jorge Villalobos [:jorgev] 2012-07-08 10:35:26 PDT
Done.
https://addons.mozilla.org/en-US/firefox/blocked/i106
https://addons.mozilla.org/en-US/firefox/blocked/i107

QA, please verify.
Comment 8 Paul Silaghi, QA [:pauly] 2012-07-09 04:43:51 PDT
Still enabled on Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0.1
Comment 9 Jorge Villalobos [:jorgev] 2012-07-09 08:27:31 PDT
Paul, which version of the RealPlayer extension do you have installed? Did you try forcing a blocklist ping? https://wiki.mozilla.org/Blocklisting/Testing
Comment 10 juan becerra [:juanb] 2012-07-09 13:07:39 PDT
Jorge, whether I use the instructions in comment #9 or the "Timer Fire" extension nothing happens. The RealPlayer 15.0.5 remeains enabled. The entries in the blocklist.xml file are there, but it isn't blocked. 

I've also tried restarting Firefox, the VM, resetting the timers, but no luck.
Comment 11 Marcia Knous [:marcia - use ni] 2012-07-09 14:03:43 PDT
I see the same thing in my Win 7 VM as Juan does, but I am going to try on real hardware next.
Comment 12 Jorge Villalobos [:jorgev] 2012-07-09 14:53:05 PDT
What is the extension's ID?
Comment 13 Marcia Knous [:marcia - use ni] 2012-07-09 15:29:34 PDT
Jorge: Here is what I see in blocklist.xml:

-<emItem id="{ABDE892B-13A8-4d1b-88E6-365A6E755758}" blockID="i107" os="WINNT"> <versionRange maxVersion="15.0.5" minVersion="0" severity="1"> </versionRange> </emItem>

-<emItem id="{97E22097-9A2F-45b1-8DAF-36AD648C7EF4}" blockID="i106" os="WINNT"> <versionRange maxVersion="15.0.5" minVersion="0" severity="1"> </versionRange> </emItem>

about:support shows {C3949AC2-4B17-43ee-B4F1-D26B9D42404D} as the Extension ID for RealPlayer Browser Record Plugin 15.0.5.
Comment 14 Jorge Villalobos [:jorgev] 2012-07-09 15:32:39 PDT
Hrm, they're changing their ID with every update.
Comment 15 Jorge Villalobos [:jorgev] 2012-07-09 15:37:26 PDT
Since this is a new block, let's do this right. I've set up a block with the new ID on staging now: https://addons-dev.allizom.org/en-US/firefox/blocked/i97

Please restest.
Comment 16 Marcia Knous [:marcia - use ni] 2012-07-09 16:52:11 PDT
Confirming that the staged block works in my Windows 7 VM - the addon is hard blocked.

(In reply to Jorge Villalobos [:jorgev] from comment #15)
> Since this is a new block, let's do this right. I've set up a block with the
> new ID on staging now:
> https://addons-dev.allizom.org/en-US/firefox/blocked/i97
> 
> Please restest.
Comment 17 Jorge Villalobos [:jorgev] 2012-07-09 17:14:54 PDT
(In reply to Marcia Knous [:marcia] from comment #16)
> the addon is hard blocked.

Hard blocked? Does this mean you can't enable it again? Do you see the severity set to 1 in blocklist.xml?
Comment 18 Marcia Knous [:marcia - use ni] 2012-07-09 18:00:27 PDT
Jorge: Yes, it appears the severity is set to 1 and I cannot renable the addon:

- <emItem blockID="i97" os="WINNT" id="{C3949AC2-4B17-43ee-B4F1-D26B9D42404D}">
  <versionRange minVersion="0" maxVersion="15.0.5" severity="1" /> 
  </emItem>
Comment 19 Dave Herrera 2012-07-09 18:25:20 PDT
Hi Jorge, what is the justification for not allowing users to re-enable? Does Mozilla see that this new bug in 15.0.5 is affecting a larger percentage of Firefox users than the original issue in 15.0.4?
Comment 20 Jorge Villalobos [:jorgev] 2012-07-09 19:01:58 PDT
(In reply to Dave Herrera from comment #19)
> Hi Jorge, what is the justification for not allowing users to re-enable?
> Does Mozilla see that this new bug in 15.0.5 is affecting a larger
> percentage of Firefox users than the original issue in 15.0.4?

We *want* users to be able to re-enable the add-on after the block, which is why I asked in comment #17 and I am puzzled by comment #18. Note that this is only in staging and we haven't pushed the new block to production yet.
Comment 21 Jorge Villalobos [:jorgev] 2012-07-10 10:59:46 PDT
Marcia: I asked Andrew and Kris to test the block and they're both seeing a soft block. Can you give it another look?
Comment 22 Marcia Knous [:marcia - use ni] 2012-07-10 14:33:20 PDT
The staged block works for me and it is a soft block.

(In reply to Jorge Villalobos [:jorgev] from comment #21)
> Marcia: I asked Andrew and Kris to test the block and they're both seeing a
> soft block. Can you give it another look?
Comment 23 Jorge Villalobos [:jorgev] 2012-07-10 15:28:42 PDT
Blocked: https://addons.mozilla.org/en-US/firefox/blocked/i111
Comment 24 John Hesling [:John99] 2012-07-11 05:32:56 PDT
When I view https://addons.mozilla.org/en-US/firefox/blocked/i111

It is worded as a soft block
"The RealPlayer Browser Record extension is causing significant problems on Flash video sites like YouTube. This block automatically disables the add-on, but users can re-enable it from the Add-ons Manager if necessary. "
Comment 25 Marcelo Pontarelli 2012-07-17 08:25:06 PDT
I'm using Firefox 13.0.1 ( now 14.0.1 ) with RP 15.0.5.109 and AFlashP 11.3.300.265 in WindowsXP.
I override blocking permissions on AdobeFlashPlayer an it works perfectly without any problem on any YouTube video I've tested.
It's seems more an 'I don't want to fix it as commanded by Adobe' than a real problem.

Note You need to log in before you can comment on or make changes to this bug.