Kuma: Admins need to be able to edit custom site-wide CSS

RESOLVED FIXED

Status

Mozilla Developer Network
Wiki pages
P1
normal
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: sheppy, Unassigned)

Tracking

Details

(Whiteboard: u=user c=wiki s=2012-07-03 p=1 t=2012-07-09)

(Reporter)

Description

6 years ago
MindTouch has a "Custom CSS" editor that lets admins write CSS that gets injected into all pages. We use this *extensively* and need it ASAP.

So sorry we didn't catch this sooner. :(

Here's where it is on MindTouch:

https://developer.mozilla.org/deki/cp/custom_css.php
Duplicate of this bug: 671790
Blocks: 768370
Depends on: 768498
(Reporter)

Comment 2

6 years ago
lorchard suggests this could be done using a template that gets linked to by the site template, at least as a stopgap measure until we have a real solution. That seems doable. The list of people that can edit templates is small.
(Reporter)

Comment 3

6 years ago
More accurately, by using a page in the Template: namespace as a CSS stylesheet, rather than as an actual template. That would put it under the access permissions of the templates, which is a small enough, trusted set of people to get by until we have this feature implemented properly.

I think this is a great solution until we can do it right.

Comment 4

6 years ago
Commits pushed to master at https://github.com/mozilla/kuma

https://github.com/mozilla/kuma/commit/45e3c2d37ad33a156cbd08f84781f03c46c2e5ed
Bug 768492: Quick hack to enable a wiki doc to be treated as wiki CSS

https://github.com/mozilla/kuma/commit/e5d1d765a0d43dad390393266d754f2912e33119
Merge pull request #327 from lmorchard/admin-custom-css-768492

Bug 768492: Quick hack to enable a wiki doc to be treated as wiki CSS
Not sure we want to call this one fixed, in lieu of a cleaner solution. But, I just pushed to developer-new, and have this working:

https://developer-new.mozilla.org/en-US/docs/Template:CustomCSS

I was able to add an `h1 { color: red }` and saw it take effect. I also copied over the contents of the MindTouch custom CSS, so hopefully that helps.
Depends on: 770195
Blocks: 770195
No longer depends on: 770195
Actually, I am going to call this fixed for now, and file a follow-up bug to refine the feature.
Whiteboard: u=user c=wiki s=2012-07-03 p=1
No longer depends on: 768498
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: u=user c=wiki s=2012-07-03 p=1 → u=user c=wiki s=2012-07-03 p=1 t=2012-07-09
Opened bug 774912 about refining this.
(In reply to John Karahalis [:openjck] from comment #7)
> Opened bug 774912 about refining this.

That's a dupe of the one I already filed :) bug 770195
That's what I get for ignoring Bugzilla's dupe detector. Thanks, Les.
(Assignee)

Updated

5 years ago
Version: Kuma → unspecified
(Assignee)

Updated

5 years ago
Component: Website → Landing pages
Product: Mozilla Developer Network → Mozilla Developer Network
You need to log in before you can comment on or make changes to this bug.