Last Comment Bug 769352 - DOM/content implementation for <input type=date>
: DOM/content implementation for <input type=date>
Status: RESOLVED FIXED
: doc-bug-filed, meta
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: Trunk
: All All
: -- normal with 5 votes (vote)
: mozilla20
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 866440 769355 769357 769359 769370 769379 769385 825009 828472
Blocks: datetime 446510 825294
  Show dependency treegraph
 
Reported: 2012-06-28 10:41 PDT by Raphael Catolino (:raphc)
Modified: 2016-02-22 23:13 PST (History)
15 users (show)
mounir: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Raphael Catolino (:raphc) 2012-06-28 10:41:31 PDT
Implement the content part of the <input type=date> as described in http://www.whatwg.org/specs/web-apps/current-work/multipage/states-of-the-type-attribute.html#date-state-%28type=date%29

I'm going to break this bug into separate smaller bugs and to use this one to reference them.
Comment 1 Boris Zbarsky [:bz] (still a bit busy) 2012-06-28 10:59:50 PDT
Isn't the hard part here the UI, not the DOM bits?
Comment 2 Mounir Lamouri (:mounir) 2012-06-28 15:13:05 PDT
(In reply to Boris Zbarsky (:bz) from comment #1)
> Isn't the hard part here the UI, not the DOM bits?

Yes. The plan is to have the DOM bits done and use the native widgets on Android and do a UI on B2G. We will disable it on desktop as long as we don't have a UI there.
Comment 3 Mark Finkle (:mfinkle) (use needinfo?) 2012-12-04 21:40:12 PST
Raphael / Mounir: How close are we to landing the dependent patches? Many seem to have r+ and some are r?
Comment 4 Mounir Lamouri (:mounir) 2012-12-05 04:07:02 PST
(In reply to Mark Finkle (:mfinkle) from comment #3)
> Raphael / Mounir: How close are we to landing the dependent patches? Many
> seem to have r+ and some are r?

We found some issues that need to be think of but as-is, the patches might be ready to land. However, I never did the last review because if I land those patches, I will have to dedicate some time to maintain the feature (fix any issue that might pop-up) and I do not have right now the bandwidth to get familiar with the code. I was hoping to do that this month but other stuff came :(
Comment 5 Mounir Lamouri (:mounir) 2012-12-28 11:53:52 PST
DOM implementation is now complete and lives behind a pref: "dom.experimental_forms". Given that the implementation comes with no UI, it is only available on Mobile.

Note You need to log in before you can comment on or make changes to this bug.