Last Comment Bug 769537 - Actually use QuotaExceededError for database creation
: Actually use QuotaExceededError for database creation
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM: IndexedDB (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla16
Assigned To: Kyle Huey [:khuey] (khuey@mozilla.com)
:
Mentors:
: 711928 (view as bug list)
Depends on: 748630 767999
Blocks: 726378
  Show dependency treegraph
 
Reported: 2012-06-28 21:46 PDT by Kyle Huey [:khuey] (khuey@mozilla.com)
Modified: 2015-01-02 06:15 PST (History)
4 users (show)
khuey: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (1.81 KB, patch)
2012-06-28 21:48 PDT, Kyle Huey [:khuey] (khuey@mozilla.com)
jonas: review+
Details | Diff | Review

Description Kyle Huey [:khuey] (khuey@mozilla.com) 2012-06-28 21:46:56 PDT
Maxime pointed out that if the quota is exceeded during database creation, an UnknownError is returned.
Comment 1 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-06-28 21:48:02 PDT
Created attachment 637780 [details] [diff] [review]
Patch
Comment 2 Jonas Sicking (:sicking) 2012-06-29 00:42:27 PDT
Comment on attachment 637780 [details] [diff] [review]
Patch

Review of attachment 637780 [details] [diff] [review]:
-----------------------------------------------------------------

Ben says r=bent, but we should figure out a way to test this some day, not now.
Comment 3 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-06-29 11:54:26 PDT
https://hg.mozilla.org/mozilla-central/rev/5424f28013c6
Comment 4 Kyle Huey [:khuey] (khuey@mozilla.com) 2015-01-02 06:15:13 PST
*** Bug 711928 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.