Last Comment Bug 770419 - Rename "Send Image...", "Send Video...", and "Send Audio..." to "Email Image...", etc
: Rename "Send Image...", "Send Video...", and "Send Audio..." to "Email Image....
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Menus (show other bugs)
: Trunk
: All All
: -- normal with 2 votes (vote)
: Firefox 16
Assigned To: Jared Wein [:jaws] (please needinfo? me)
:
Mentors:
Depends on: 239307 776293
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-02 23:25 PDT by Jared Wein [:jaws] (please needinfo? me)
Modified: 2013-11-13 03:07 PST (History)
6 users (show)
jaws: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (7.58 KB, patch)
2012-07-03 01:03 PDT, Jared Wein [:jaws] (please needinfo? me)
dao+bmo: review-
Details | Diff | Review
Patch v2 (7.62 KB, patch)
2012-07-03 18:55 PDT, Jared Wein [:jaws] (please needinfo? me)
fryn: review+
Details | Diff | Review

Description Jared Wein [:jaws] (please needinfo? me) 2012-07-02 23:25:41 PDT
I talked with shorlander and we think that we should keep the context menuitems for sending media but rename them to be simpler and more obvious as to their outcomes.

In the case of these items, the user doesn't get to choose *how* the message is sent, so the word "As" in "Send Image As..." doesn't really apply here.

We can make this more intuitive by changing these to:
"Email Image...", "Email Video...", and "Email Audio..."

The behavior of these menuitems will remain the same.
Comment 1 Jared Wein [:jaws] (please needinfo? me) 2012-07-03 01:03:47 PDT
Created attachment 638614 [details] [diff] [review]
Patch

This patch is dependent on the patch for bug 239307, that's why I didn't update the sendPageCmd in browser-context.inc since the send page command is removed from the context menu in the patch for bug 239307.

This patch renames Send Image, Send Video, Send Audio, and Send Page to Email *.

This MXR search shows that these are the only "Send *" strings that will lead to a user sending an email <https://mxr.mozilla.org/mozilla-central/search?string=send+&find=\.dtd&findi=\.x.l&filter=^[^\0]*%24&hitlimit=&tree=mozilla-central>.
Comment 2 Dão Gottwald [:dao] 2012-07-03 03:51:45 PDT
Comment on attachment 638614 [details] [diff] [review]
Patch

>Bug 770419 - Rename 'Send Image...' et al to 'Email Image...'.

This bug has a more complete summary, please use that (at least).

>-<!ENTITY sendPageCmd.label            "Send Link…">
>-<!ENTITY sendPageCmd.accesskey        "e">
>+<!ENTITY sendPageCmd2.label           "Email Link…">
>+<!ENTITY sendPageCmd2.accesskey       "E">

emailFooCmd rather than sendFooCmd2.

The original spelling of the verb is "e-mail". Not sure which is better or used more commonly...
Comment 3 Frank Yan (:fryn) 2012-07-03 12:11:28 PDT
Comment on attachment 638614 [details] [diff] [review]
Patch

(In reply to Dão Gottwald [:dao] from comment #2)
> The original spelling of the verb is "e-mail". Not sure which is better or
> used more commonly...

"email" is used more commonly (see Google results, etc.) and is also what we use (including in 'Copy Email Address'):
https://mxr.mozilla.org/mozilla-central/search?string=email&find=\.dtd%24&findi=\.dtd%24&filter=^[^\0]*%24&hitlimit=&tree=mozilla-central
although pippki is the odd exception:
https://mxr.mozilla.org/mozilla-central/search?string=e-mail&find=\.dtd%24&findi=\.dtd%24&filter=^[^\0]*%24&hitlimit=&tree=mozilla-central
Comment 4 Jared Wein [:jaws] (please needinfo? me) 2012-07-03 18:55:51 PDT
Created attachment 638940 [details] [diff] [review]
Patch v2

I renamed the entities to be email*Cmd, but I didn't update the commands or other related items because I don't think the tradeoff of hg history churn is worth it.

test_contextmenu.html passes green locally.

On the question of email vs e-mail, the brand toolkit [0] says to refer to the AP Styleguide [1] which recommends 'email'.

[0] http://www.mozilla.org/en-US/firefox/brand/copy/rules/
[1] http://mashable.com/2011/03/18/ap-stylebook-email/
Comment 5 Frank Yan (:fryn) 2012-07-03 21:07:57 PDT
Comment on attachment 638940 [details] [diff] [review]
Patch v2

I think Dão was asking you to change the commit message:

(In reply to Dão Gottwald [:dao] from comment #2)
> Comment on attachment 638614 [details] [diff] [review]
> Patch
> 
> >Bug 770419 - Rename 'Send Image...' et al to 'Email Image...'.
> 
> This bug has a more complete summary, please use that (at least).
Comment 6 Frank Yan (:fryn) 2012-07-03 21:14:23 PDT
Comment on attachment 638940 [details] [diff] [review]
Patch v2

Never mind. I misunderstood.
Comment 7 Jared Wein [:jaws] (please needinfo? me) 2012-07-03 21:21:00 PDT
Pushed to mozilla-inbound:
https://hg.mozilla.org/integration/mozilla-inbound/rev/2ed02bff1f4d
Comment 8 Ryan VanderMeulen [:RyanVM] 2012-07-04 06:37:19 PDT
https://hg.mozilla.org/mozilla-central/rev/2ed02bff1f4d
Comment 9 Justin Dolske [:Dolske] 2012-07-05 14:24:58 PDT
Do we want a followup bug to consider entirely removing these?
Comment 10 Jared Wein [:jaws] (please needinfo? me) 2012-07-05 14:44:33 PDT
(In reply to Justin Dolske [:Dolske] from comment #9)
> Do we want a followup bug to consider entirely removing these?

I'm not sure, but I'm leaning towards not removing these (hence the filing of this bug).

Our current data shows that ~3% of context menu clicks are for send-image. As mentioned in https://bugzilla.mozilla.org/show_bug.cgi?id=252277#c10, the URLs for these items are generally hidden vs. the generally visibile page URLs. This distinction makes the benefit of keeping these menuitems greater than the 'Send Page...' one.

Note You need to log in before you can comment on or make changes to this bug.