The default bug view has changed. See this FAQ.

[b2g] semi-transparent scroll bars should not occupy content-flow space

RESOLVED FIXED in mozilla17

Status

()

Core
General
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: timdream, Assigned: vingtetun)

Tracking

Trunk
mozilla17
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-basecamp:+)

Details

Attachments

(2 attachments)

+++ This bug was initially created as a clone of Bug #711986 +++
See https://github.com/mozilla-b2g/gaia/pull/2136 for tests

The scroll bar currently occupies 8px of the spaces, causing the 10th small boxes to flow to the second row and a 12px blank beside the scroll bar.

I tried to hack the CSS but so far without much success. Will keep trying.
Whiteboard: [inbound]
It is likely that bug 636564 will resolve that.
(In reply to Vivien Nicolas (:vingtetun) from comment #2)
> It is likely that bug 636564 will resolve that.

That is really unfortunate ...
Depends on: 636564
Let's add Roc to this bug. He can have good suggestions for us.
I believe cjones and Doug have some ideas about rendering scroll indicators in the compositor. Is that the best plan for dealing with this bug?
Yes, but async sub-frame scrolling is looking risky for b2g v1, so we'll likely need to ship with the current sync fallback hack.  This bug is less important for the scrollable subframes though, I guess.
If we want to proceed with fixing synchronously drawn scrollbar indicators in this bug, I think the best way forward would be to revive the subset of patches in bug 636564 that are needed here.
Created attachment 645358 [details] [diff] [review]
Part 1, v1: handle scrollbar margins

Roc, this patch came from bug 636564 and you have already r+ it. It seems to resolve the issue.
Assignee: nobody → 21
Status: NEW → ASSIGNED
Attachment #645358 - Flags: review?(roc)
Attachment #645358 - Flags: review?(roc) → review+
Vivien do you want to land this? The scrollbar is pretty annoying ;-)
https://hg.mozilla.org/integration/mozilla-inbound/rev/9ed259005de2
Target Milestone: --- → mozilla17
Backed out for Android XUL R3 failures in scrollbars-0{1,2}.svg:
https://tbpl.mozilla.org/php/getParsedLog.php?id=13935054&tree=Mozilla-Inbound

https://hg.mozilla.org/integration/mozilla-inbound/rev/d4b106f2136c
Target Milestone: mozilla17 → ---
Duplicate of this bug: 776232
blocking-basecamp: --- → +
Created attachment 648044 [details] [diff] [review]
mobile/xul patch

mobile/xul/themes/content/content.css change the size of scrollbars for SVG content making a reftest to fail when the margin is taken into account for calculating the size of the scrollable area. This patch should not change any fennec behavior and ensure that we don't fail the reftest.
Attachment #648044 - Flags: review?(mark.finkle)
Attachment #648044 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/b5e444664a6c
https://hg.mozilla.org/integration/mozilla-inbound/rev/a99a135fc810
Target Milestone: --- → mozilla17
Depends on: 780373
https://hg.mozilla.org/mozilla-central/rev/b5e444664a6c
https://hg.mozilla.org/mozilla-central/rev/a99a135fc810
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Depends on: 781086
You need to log in before you can comment on or make changes to this bug.