Closed Bug 772436 Opened 10 years ago Closed 10 years ago

Tab is closed too easy when swiped to the right

Categories

(Firefox for Android Graveyard :: General, defect)

15 Branch
ARM
Android
defect
Not set
normal

Tracking

(firefox15 verified)

VERIFIED FIXED
Firefox 16
Tracking Status
firefox15 --- verified

People

(Reporter: andreea.pod, Assigned: wesj)

References

Details

Attachments

(1 file)

Build: Firefox 16.0a1 (2012-07-10)
Device: LG Optimus 2X (Android 2.2.2)

Steps to reproduce:
1. Open the tab menu
2. make sure you have few tabs opened
3. tap on one of the tabs on the left side and swipe to the right but not more than the close ("X") button width 

Expected results: 
- the tab should jump back as it does when you swipe from right to left

Actual result: 
- the tab closes, please see video: http://www.youtube.com/watch?v=gXjRV-slHhA&feature=youtu.be

Note: 
- also I saw that if you tap on the left side of the tab and swipe to the left that tab closes in the right side.
Blocks: 764812
Duplicate of this bug: 772493
Attached patch PatchSplinter Review
Uh, you warned me about this rounding and I thought I paid attention, but apparently not. (3/4) is being rounded to zero before the multiplication.
Assignee: nobody → wjohnston
Attachment #640689 - Flags: review?(mark.finkle)
Comment on attachment 640689 [details] [diff] [review]
Patch

\o/ I am not useless... just ignored :)
Attachment #640689 - Flags: review?(mark.finkle) → review+
Comment on attachment 640689 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 764812
User impact if declined: Sliding from the left will always close the tab.
Testing completed (on m-c, etc.): Just landed.
Risk to taking this patch (and alternatives if risky): Very low. Fixes a regression. At worst, this should have the exact same behavior as before.
String or UUID changes made by this patch: None.
Attachment #640689 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/465da27bb61b
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 16
Attachment #640689 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified fixed on:
- build: Firefox Beta 15.0 (2012-07-17)
- device: ASUS EEE Transformer (Android 4.0.3), LG Optimus 2X (Android 2.2.2)
Status: RESOLVED → VERIFIED
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.