Last Comment Bug 772682 - make Mac OS X 10.6 the minimum system version
: make Mac OS X 10.6 the minimum system version
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: Firefox 17
Assigned To: Josh Aas
:
Mentors:
Depends on:
Blocks: 772735 774509 775744 776467 778664 778969 783554
  Show dependency treegraph
 
Reported: 2012-07-10 16:06 PDT by Josh Aas
Modified: 2013-12-27 14:36 PST (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix v1.0 (788 bytes, patch)
2012-07-10 16:09 PDT, Josh Aas
gavin.sharp: review+
Details | Diff | Splinter Review

Description Josh Aas 2012-07-10 16:06:44 PDT

    
Comment 1 Josh Aas 2012-07-10 16:08:05 PDT
The current plan is to do this for Firefox 17.
Comment 2 Josh Aas 2012-07-10 16:09:14 PDT
Created attachment 640844 [details] [diff] [review]
fix v1.0
Comment 3 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-07-11 17:18:01 PDT
Comment on attachment 640844 [details] [diff] [review]
fix v1.0

I imagine we'll need to disable the 10.5 build/test machines before landing this? Is there a bug tracking that?
Comment 4 Josh Aas 2012-07-11 18:29:01 PDT
(In reply to :Gavin Sharp (use gavin@gavinsharp.com for email) from comment #3)

> I imagine we'll need to disable the 10.5 build/test machines before landing
> this? Is there a bug tracking that?

I was planning to file one, will do it now.
Comment 5 Ed Morley [:emorley] 2012-07-18 01:45:06 PDT
(In reply to Josh Aas (Mozilla Corporation) from comment #4)
> I was planning to file one, will do it now.

Bug 773120, for those following along. (This bug only loosely depends on that one, since armen/myself have hidden OS X 10.5 on tbpl, so the tree won't appear busted; we'll just be wasting cycles/machines)
Comment 6 Scoobidiver (away) 2012-07-18 02:00:52 PDT
Firefox 17 is the next major ESR version, so this won't give an extra one-year delay for organizations to migrate their old Macs. Do you have feedback from ESR users about that?
Comment 7 Josh Aas 2012-07-18 06:46:14 PDT
(In reply to Scoobidiver from comment #6)
> Firefox 17 is the next major ESR version, so this won't give an extra
> one-year delay for organizations to migrate their old Macs. Do you have
> feedback from ESR users about that?

This has been considered, we're not planning any sort of 10.5 support for the next esr, nor are we recommending esr for 10.5 users. Asa know more about this if you want more info.
Comment 8 Josh Aas 2012-07-18 06:50:58 PDT
pushed to mozilla-inbound

https://hg.mozilla.org/integration/mozilla-inbound/rev/0df827058bf5
Comment 9 Ed Morley [:emorley] 2012-07-19 07:36:26 PDT
https://hg.mozilla.org/mozilla-central/rev/0df827058bf5
Comment 10 Jason Smith [:jsmith] 2012-07-20 09:04:38 PDT
Does this patch also make the Webapp Runtime in Firefox have a minimum OS version for Mac at OS X 10.6?
Comment 11 Josh Aas 2012-07-20 11:33:12 PDT
(In reply to Jason Smith [:jsmith] from comment #10)
> Does this patch also make the Webapp Runtime in Firefox have a minimum OS
> version for Mac at OS X 10.6?

I don't know anything about how the webapp runtime works, so I don't know. This patch marks the Firefox app bundle as requiring Mac OS X 10.6.

Note You need to log in before you can comment on or make changes to this bug.