Last Comment Bug 783554 - Make Mac OS X 10.6 the minimum system version
: Make Mac OS X 10.6 the minimum system version
Status: RESOLVED FIXED
:
Product: SeaMonkey
Classification: Client Software
Component: Build Config (show other bugs)
: Trunk
: x86 Mac OS X
: -- minor (vote)
: seamonkey2.14
Assigned To: Stefan [:stefanh]
:
Mentors:
Depends on: 772682
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-17 07:34 PDT by Stefan [:stefanh]
Modified: 2012-08-27 10:04 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Proposed patch (889 bytes, patch)
2012-08-17 07:34 PDT, Stefan [:stefanh]
bugspam.Callek: review+
Details | Diff | Splinter Review

Description Stefan [:stefanh] 2012-08-17 07:34:51 PDT
Created attachment 652763 [details] [diff] [review]
Proposed patch

+++ This bug was initially created as a clone of Bug #772682 +++

We should change the minimum Mac OS version to 10.5 in our .plist file. 10.5 users will then get a warning when they try to launch 2.14.

Both Firefox and Thunderbird have kept the LSMinimumSystemVersionByArchitecture key, but as https://bugzilla.mozilla.org/show_bug.cgi?id=778664#c2 points out, there's no need to keep that key.

Patch is untested since I don't have any 10.5 machine. I could possibly verify it later on a 10.4 machine (probably not that useful...).
Comment 1 Justin Wood (:Callek) 2012-08-26 22:31:28 PDT
Comment on attachment 652763 [details] [diff] [review]
Proposed patch

Review of attachment 652763 [details] [diff] [review]:
-----------------------------------------------------------------

I'm tempted to suggest we patch Firefox's as well to remove LSMinimumSystemVersionByArchitecture
Comment 2 Stefan [:stefanh] 2012-08-27 10:04:37 PDT
http://hg.mozilla.org/comm-central/rev/d16a703b8818

Yeah, we should fix Firefox too.

Note You need to log in before you can comment on or make changes to this bug.