Last Comment Bug 773431 - Wikipedia mobile sliding reference div unclickable
: Wikipedia mobile sliding reference div unclickable
Status: VERIFIED FIXED
: regression
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: Trunk
: ARM Android
: -- normal (vote)
: Firefox 17
Assigned To: Kartikaya Gupta (email:kats@mozilla.com)
:
Mentors:
: 778193 (view as bug list)
Depends on: 777706
Blocks: 744518 clicksdontwork wikipedia.org
  Show dependency treegraph
 
Reported: 2012-07-12 14:01 PDT by Michael Comella (:mcomella) [PTO til 6/27]
Modified: 2012-09-27 04:44 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
affected
verified
verified
verified


Attachments
Listen for touchstart in capture mode (1.30 KB, patch)
2012-07-24 09:36 PDT, Kartikaya Gupta (email:kats@mozilla.com)
wjohnston2000: review+
lukasblakk+bugs: approval‑mozilla‑aurora+
lukasblakk+bugs: approval‑mozilla‑beta+
Details | Diff | Review

Description Michael Comella (:mcomella) [PTO til 6/27] 2012-07-12 14:01:23 PDT
1) Open Firefox, preferably versions 14 - 15 (standard - aurora) due to Bug 773427.
2) Click the URL bar and navigate to http://en.m.wikipedia.org/wiki/Real+
3) Scroll down until the first reference (displayed as "[1]", colored in blue as a clickable link) and tap it so that the div slides into place.
4) Click the link on the expanded div.

Expected: Firefox navigates to page the reference points to.
Actual: Nothing.

Note that the "X", the close button, is also unclickable.

If your reference div contains a link and you long press the link, you will be given the long press dialog that allows you to open the link in a new tab and such. Therefore, the problem seems to extend to short taps only.

Tested on Galaxy Nexus, Android 4.0.4.
Comment 1 Michael Comella (:mcomella) [PTO til 6/27] 2012-07-12 14:02:04 PDT
Added see also for Bug 773427 as they are both bugs with the Wikipedia mobile reference links.
Comment 2 Michael Comella (:mcomella) [PTO til 6/27] 2012-07-12 14:19:36 PDT
Added another "See Also" link to another Wikipedia mobile reference div bug.
Comment 3 Michael Comella (:mcomella) [PTO til 6/27] 2012-07-12 14:20:40 PDT
(In reply to Michael Comella (:mcomella) from comment #0)
> 2) Click the URL bar and navigate to http://en.m.wikipedia.org/wiki/Real+

Note on the link above, the "+" is not added automatically by Bugzilla – you have to add it by hand.
Comment 4 Kartikaya Gupta (email:kats@mozilla.com) 2012-07-24 09:36:21 PDT
Created attachment 645347 [details] [diff] [review]
Listen for touchstart in capture mode

The page is stopping propagation of the touchstart event, so we end up never receiving it in browser.js. This ensures we get it first so we can do our handling even if the page stops it. This behaviour is consistent with Chrome - I have a simple test page at http://people.mozilla.org/~kgupta/bug/773431.html to repro/verify this.
Comment 5 Kartikaya Gupta (email:kats@mozilla.com) 2012-07-24 09:37:29 PDT
This is a regression from bug 744518.
Comment 6 Kartikaya Gupta (email:kats@mozilla.com) 2012-07-24 09:54:36 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/3ff93386d03f
Comment 7 Ed Morley [:emorley] 2012-07-25 08:12:22 PDT
https://hg.mozilla.org/mozilla-central/rev/3ff93386d03f
Comment 8 Aaron Train [:aaronmt] 2012-07-26 10:11:53 PDT
This broke Twitter (bug 777706).
Comment 9 Kartikaya Gupta (email:kats@mozilla.com) 2012-07-27 10:40:31 PDT
*** Bug 778193 has been marked as a duplicate of this bug. ***
Comment 10 Kartikaya Gupta (email:kats@mozilla.com) 2012-08-07 10:55:46 PDT
Comment on attachment 645347 [details] [diff] [review]
Listen for touchstart in capture mode

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 744518
User impact if declined: sometimes clicking on things doesn't work
Testing completed (on m-c, etc.): on m-c
Risk to taking this patch (and alternatives if risky): this patch exposed bug 777706 which has now been fixed and uplifted. there don't seem to be any other regressions and it has been baking on m-c for a while now. affects mobile only
String or UUID changes made by this patch: none
Comment 12 Adrian Tamas (:AdrianT) 2012-09-27 04:44:44 PDT
I am able to open the link and to close the reference pop-up by tapping the "x" button on:

Firefox Mobile 16.0b5 / Firefox Mobile 15
Samsung Galaxy R (Android 2.3.4)

Marking as verified on Firefox Mobile 16 and 15

Note You need to log in before you can comment on or make changes to this bug.