mozGetUserMedia({audio:true}...) fails on the second attempt

VERIFIED FIXED

Status

()

Core
WebRTC
--
major
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: jesup, Unassigned)

Tracking

Trunk
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [getUserMedia], [blocking-gum+], URL)

(Reporter)

Description

5 years ago
mozGetUserMedia({audio:true}...) fails on the second attempt, requiring a browser restart.

Not sure if it's OS-related (Fedora 15 x64 here)
Duplicate of this bug: 773832
Also reproduces on OS X 10.6.
OS: Linux → All
Hardware: x86_64 → All

Updated

5 years ago
Whiteboard: [getUserMedia], [blocking-gum+]

Updated

5 years ago
Duplicate of this bug: 781705

Updated

5 years ago
QA Contact: jsmith

Comment 4

5 years ago
I also have the same problem using a Mac OSX 10.6.8, the audio only works one time. I have to restart the browser and cycle the Picture capture one time before I can make the Audio work once. The error message is "NO_DEVICES_FOUND".

Updated

5 years ago
Flags: in-testsuite?
There is no need to restart the browser. Simply reload the page. I'm fairly sure this is because of bug 798037.
Depends on: 798037
(In reply to Henrik Skupin (:whimboo) from comment #5)
> There is no need to restart the browser. Simply reload the page. I'm fairly
> sure this is because of bug 798037.

Nope! That bug has to do with being able to release the camera using the stop function of LocalMediaStream. On top of that - This works for me on the 10/19 build. Something must have fixed this...
Status: NEW → RESOLVED
Last Resolved: 5 years ago
No longer depends on: 798037
Resolution: --- → WORKSFORME
Bug 802411 solves this and a few other bugs.
Switching to fixed to say "Fixed by bug 802411"
Resolution: WORKSFORME → FIXED

Updated

5 years ago
Keywords: verifyme
Verified on the 10/19 build. And this needs a test.
Status: RESOLVED → VERIFIED
Keywords: verifyme
Added automation coverage for this in bug 822109's patch.
Flags: in-testsuite? → in-testsuite+
You need to log in before you can comment on or make changes to this bug.