Mozilla.org SVN update not showing on production

RESOLVED FIXED

Status

Infrastructure & Operations
WebOps: Other
P1
normal
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: pascalc, Assigned: jakem)

Tracking

Details

(URL)

(Reporter)

Description

6 years ago
+++ This bug was initially created as a clone of Bug #774814 +++

Same problem as yesterday, the production server is not showing the updated translation for the page

http://www.mozilla.org/b/ru/firefox/14.0.1/whatsnew/

shouls be like:
http://www-dev.allizom.org/b/ru/firefox/14.0.1/whatsnew/

Jakem solved this yesterday this way:
"These are fixed. I don't know what was wrong, but I restarted Apache on all of the prod nodes and now that block is gone. I suspect (but can not confirm) that Django's caching layer may have had old/bad data in it. www-dev gets restarted regularly, so it wouldn't be quite so affected by this kind of thing."

Rik is looking at the webdev side of things to fix our platform so as that updates don't get badly cached, we will file a bedrock bug for that.
(Assignee)

Comment 1

6 years ago
Should be fixed now. Looks better to me, anyway. :)

[root@bedrockadm.private.phx1 ~]# issue-multi-command bedrock service httpd graceful
[2012-07-18 09:38:05] [bedrock1.webapp.scl3.mozilla.com] running: service httpd graceful
[2012-07-18 09:38:05] [bedrock2.webapp.scl3.mozilla.com] running: service httpd graceful
[2012-07-18 09:38:05] [bedrock3.webapp.scl3.mozilla.com] running: service httpd graceful
[2012-07-18 09:38:05] [bedrock4.webapp.scl3.mozilla.com] running: service httpd graceful
[2012-07-18 09:38:05] [bedrock5.webapp.scl3.mozilla.com] running: service httpd graceful
[2012-07-18 09:38:05] [bedrock1.webapp.phx1.mozilla.com] running: service httpd graceful
[2012-07-18 09:38:06] [bedrock2.webapp.phx1.mozilla.com] running: service httpd graceful
[2012-07-18 09:38:06] [bedrock3.webapp.phx1.mozilla.com] running: service httpd graceful
[2012-07-18 09:38:06] [bedrock1.webapp.phx1.mozilla.com] finished: service httpd graceful (0.494s)
[2012-07-18 09:38:06] [bedrock2.webapp.scl3.mozilla.com] finished: service httpd graceful (0.834s)
[2012-07-18 09:38:06] [bedrock3.webapp.scl3.mozilla.com] finished: service httpd graceful (0.848s)
[2012-07-18 09:38:06] [bedrock5.webapp.scl3.mozilla.com] finished: service httpd graceful (0.865s)
[2012-07-18 09:38:06] [bedrock4.webapp.scl3.mozilla.com] finished: service httpd graceful (0.872s)
[2012-07-18 09:38:06] [bedrock3.webapp.phx1.mozilla.com] finished: service httpd graceful (0.906s)
[2012-07-18 09:38:06] [bedrock1.webapp.scl3.mozilla.com] finished: service httpd graceful (0.943s)
[2012-07-18 09:38:06] [bedrock2.webapp.phx1.mozilla.com] finished: service httpd graceful (0.984s)
Assignee: server-ops-webops → nmaul
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

6 years ago
\o/ thanks Jake :)
Component: Server Operations: Web Operations → WebOps: Other
Product: mozilla.org → Infrastructure & Operations
You need to log in before you can comment on or make changes to this bug.