Open Bug 775672 Opened 7 years ago Updated 11 months ago

Bookmark tags support

Categories

(Firefox for Android :: Awesomescreen, enhancement, P3)

All
Android
enhancement

Tracking

()

People

(Reporter: alexandreprovencio, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:14.0) Gecko/20100101 Firefox/14.0.1
Build ID: 20120713224749

Steps to reproduce:

Edit a bookmark added from mobile or a synced one


Actual results:

There's no option to add/remove/edit tags



Expected results:

Along with the normal tag operations above, tag sorting is also essential for bookmark management
Summary: bookmark tags suport → bookmark tags support
Hi,

You should be able to edit and add a bookmark tag by long-tap holding on a bookmark listed in the Bookmarks tab.

Can you report back here if that works or doesn't work for you?
Hello Aaron,

from the awesome screen, I tap the location (or title) bar which brings me a 3 tabbed screen with the following tabs:
- top sites
- bookmarks
- history

By long tapping a bookmark on the bookmarks tab I have the following options:
- open in a new tab
- share
- edit
- remove
- add to the home screen

By tapping 'edit', it gives 3 possibilities:
- title
- url
- keyword

So your saying that there should be also a tag option on this menu?
It sounds like what you are looking for is keywords instead?

1) go to bugzilla.mozilla.org
2) long tap on a field

Expected: "Add a keyword to this search"
Actual: no selection of the expected

This would allow people to search for "bug <bug number>" in the field name rather than having to type in https://bugzilla.mozilla.org/show_bug.cgi?id=775672 in the url field.
Although it would be another nice feature, bookmark keywords != bookmark tags. At least for now you can create keywords on desktop firefox and sync with the mobile, while you can't even access tags created on another firefox.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 807402
tracking-fennec: --- → ?
please renom once product and UX weigh in
tracking-fennec: ? → ---
Interesting that this issue hasn't attracted more requests. (It's been my top wish/complaint in FF for Android since beginning of times.) Anyways, happy to see that this is a known issue. That's a start.
Also happy to see that the Keyword has been attempted to add to the mobile FF.

Now, 
1) Tags: This would be great. Hopefully Someone with coding skills can pick this up sooner than in X years. I think it would _massively_ increase the usefulness/productivity of FF mobile usage.
As noted this is really the very top item on my FF for Android wishlist. Is there anything I could do to help this happen? Is there some established crowdfunding/alike for desired features??

2) Keywords: I assume this should be in a separate ticket as I don't see that it would actually work (so that I could add a Keyword using mobile). At least not the way how Naoki described on 2012-07-23. I also tried to create a bookmark with a keyword by changing the URL so that the search parameter would be replaced with %s (Which is what I remember that it would have been before) and then writing a Keyword to the keyword field in the mobile bookmarks. I wonder if I understood @nhirata's description correctly?

Anyways. Huge thanks to all developers / who have otherwise pitched into the development of FF for Android. It's (by a large margin) my favorite mobile browser!
Flags: needinfo?(nhirata.bugzilla)
You can add a search provider by long-pressing a search field anywhere on the web then tapping the magnifying-glass-with-+ icon; no need for manual bookmark editing.

I see the bookmark > Edit > Keyword UI in my Fx41 Nightly.

This bug is currently getting about 2 votes per year, and it's not even a blip in user feedback, so I think you're unlikely to find a contributor who is willing to do the work. If you find someone who is willing, I'd accept a simple patch for the bookmark editing dialog.
Component: General → Awesomescreen
Flags: needinfo?(nhirata.bugzilla)
OS: Linux → Android
Hardware: x86_64 → All
Summary: bookmark tags support → Bookmark tags support
Version: Firefox 14 → Trunk
Jaakko, I couldn't have said it better.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
How is this working? I still don't see tags, only keywords.
Flags: needinfo?(alexandreprovencio)
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Status: REOPENED → NEW
(In reply to Reuben Peterkin from comment #10)
> How is this working? I still don't see tags, only keywords.

I'm sorry about closing this that way. However I'm not interested on this anymore, nor seem the developers as for the long time since the request, so I've changed my approach to other solutions.
Flags: needinfo?(alexandreprovencio)
> I'm sorry about closing this that way. However I'm not interested on this
> anymore, nor seem the developers as for the long time since the request, so
> I've changed my approach to other solutions.

Shouldn't it then be left open, just without an assigned developer?

Also, which "other solutions" do you have in mind?
(In reply to Tomislav Nakic-Alfirevic from comment #12)

> Shouldn't it then be left open, just without an assigned developer?
Sure that was my mistake.
> 
> Also, which "other solutions" do you have in mind?
I just send myself links of my interest and if they're somehow useful they are kept on my personal wiki.
(In reply to Alexandre Provencio from comment #13)

> > Also, which "other solutions" do you have in mind?
> I just send myself links of my interest and if they're somehow useful they
> are kept on my personal wiki.

Ah yes, well, I already do that and it doesn't really cut it for me.
Any word on this? The ability to tag bookmarks is THE feature keeping me from switching to Chrome; and the more I browse on my phone instead of my PC, the less useful Firefox's bookmark tagging becomes.
I don't think there's anything new to report here.
Priority: -- → P3
can I close this guys?
Status: NEW → RESOLVED
Closed: 4 years ago3 years ago
Resolution: --- → WORKSFORME
No
(In reply to Alexandre Provencio from comment #17)
> can I close this guys?

No
Perhaps you should consider enabling "Ignore Bug Mail: 	(never email me about this bug)"  if you are not interested in it any more.
(In reply to Alexandre Provencio from comment #17)
> can I close this guys?

Please no. And it would be very kind of you to change the resolution back. It is NOT RESOLVED and it does NOT WORK FOR YOU. An alternative approach may work for you, but it is not the same.

Many wants this to be implemented. What is more, it would be a great feature which may keep many using Firefox and move many to Firefox from Chrome.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Status: REOPENED → NEW
(In reply to Ivan Ogai from comment #20)
> (In reply to Alexandre Provencio from comment #17)
> > can I close this guys?
> 
> Please no. And it would be very kind of you to change the resolution back.
> It is NOT RESOLVED and it does NOT WORK FOR YOU. An alternative approach may
> work for you, but it is not the same.
> 
> Many wants this to be implemented. What is more, it would be a great feature
> which may keep many using Firefox and move many to Firefox from Chrome.

I'm sorry I didn't know I actually changed the status.
Hello all,
just my 2 cents about the "bookmark edit form" on FF for Android.

I definitly believe that the ability of adding a "keyword" and not a "tag" is a mistake.

Let me explain :

If you read the article "how-search-from-address-bar" (1), it says that "smart keyword" are only related to a specific "search field" in the bookmarked page. It is a very special use case that is : "the user wants to create a shortcut for searching into a specific website".
When I'm creating a bookmark in FF for Android, I'm creating a "normal bookmark", not a "search field bookmark" (2). So "smart keyword" should not be asked, but tags should.


(1) https://support.mozilla.org/en-US/kb/how-search-from-address-bar
(2) the way to create a "search field bookmark" on FF desktop is very special : Ctrl + clic a search field, then choose "add keyword the this search", then enter only ONE keyword in the tags field.


PS : FF is a super browser and bookmark tags are such a great underestimated/underused feature. :)
Duplicate of this bug: 1308518
Is there any update on this issue? I use FF on Ubuntu/Android/Windows and this issue makes life so difficult. I actually bothered to read the FF documentation which basically tells you tags are better than folders so that's what I did.

https://support.mozilla.org/en-US/kb/categorizing-bookmarks-make-them-easy-to-find

Now I'm screwed and it'll take hours to re-organise all my bookmarks.

FF for android would obviously benefit from the ability to manage tags but that isn't what is absolutely necessary. What's necessary is for the "awesome bar" or address bar in android to at the very least show bookmarks tagged with "shop" when you type "shop". That requires practically zero UI/UX work.
Duplicate of this bug: 1368243
Duplicate of this bug: 1368243
Duplicate of this bug: 1368243
Duplicate of this bug: 1378498
The bugs Kevin Brosnan has closed weren't duplicates of this. This bug requests the ability to add/edit/remove tags. Regardless of that the awesome screen should return bookmarks tagged with "manufacturer" or "shop" when you type those terms in, it's an oversight / unexpected that it doesn't.

Just because a feature isn't important to one person doesn't mean it isn't important to others. Issue reported in bugs 1368243, 1378498 should only be disregarded if it is first decided to remove tag functionality from firefox and remove the documentation that recommends the use of tags. No attempt at an explanation of the decision to lock bugs despite request. Damaging to the community and reputation of Mozilla.

https://support.mozilla.org/en-US/kb/categorizing-bookmarks-make-them-easy-to-find
We are doing a bunch of work with bookmarks recently - in Fennec itself with an introduction of Full Bookmark Management (Bug 1329127, Bug 1232439, etc), and across all clients, improving how we sync bookmarks (too many cross-client bugs to list). I feel that this work could, at least partially, ride in the wake of those efforts.

The fact that we do not include bookmark tags in our awesomebar search to me feels like a product oversight, given that tagging is a well-exposed feature in desktop's bookmark editing UI. As long as we don't regress search performance, this could be a nice low hanging fruit. (On a sidenote, I can't seem to get desktop nightly awesomebar to actually search by tags...)

Another aspect of this request is actually editing bookmark tags in Fennec. That is a larger task, if only because we'll need to work through implications for bookmark Sync - staying consistent with how desktop reconciles conflicts, etc.

Turning this into a [meta] and splitting off some concrete work into bugs would be a good start. As always, core Fennec team has very limited resources, but at the very least I could mentor the work.

CC'ing Joe for product visibility.
Blocks: 1329127
Managing my bookmarks/tags/folders happens every few months and only ever on my laptop. Searching bookmarks happens multiple times per day and I rely more on bookmarks on android compared to desktop as on desktop I'm more likely to use a search engine as I can type faster and my connection is faster so multiple page loads doesn't matter. It would be a huge time saver for tags to show up in awesomebar search on android.
(In reply to :Grisha Kruglov from comment #30)

> The fact that we do not include bookmark tags in our awesomebar search to me
> feels like a product oversight, given that tagging is a well-exposed feature
> in desktop's bookmark editing UI. As long as we don't regress search
> performance, this could be a nice low hanging fruit.

I concur. We do support bookmark _keywords_ in Fennec's awesomebar, even though those aren't editable.

The vast majority of bookmarks will have an empty tags array, and we're already doing a full table scan for substring search, so this might be as simple as JSON-escaping the typed input and appending to the query:

OR
(bookmarks.tags IS NOT NULL
 AND NOT bookmarks.tags = '[]'
 AND bookmarks.tags LIKE '%"{}"%')

I don't expect that to noticeably slow down the awesomebar query.
(In reply to Richard Newman [:rnewman] from comment #32)

> I don't expect that to noticeably slow down the awesomebar query.

And if it does, I'm happy to mentor work to make it fast. (See also Bug 808872.)
See Also: → 808872
Duplicate of this bug: 1264834
Sorry, but this is not a duplicate of 1264834, this is about searching/editing/adding tags on android, while 1264834 is about the syncing. 

Please reopen this bug, because this feature is really important and could be so useful!

Firefox bookmarks on desktop is essentially one of the few bookmark tools, which support searching for multiple tags, having the ability to search/edit/add tags on android would be a huge advantage over several other browsers.

I really hope this feature will be implemented soon!
It's the constant issue in IT of people wanting to close tracked bugs/issues/tickets/etc to reduce workload without really caring whether the issue is resolved.

I reiterate, firefox documentation still suggests users organise their bookmarks by TAGS and not folders:

https://support.mozilla.org/en-US/kb/categorizing-bookmarks-make-them-easy-to-find

Yet after you organise your bookmarks by tags, you then find you've wasted your time as fennec is oblivious to tags in every way, so you have to go back and organise everything by folder.

The first important stepping stone of fennec returning bookmarks tagged with "news" when you type "news" in the awesome bar needs to be addressed.
I totally agree, the search would be the first thing to implement, which should be not much work as suggested by the comments above. 

I think that tags can be a really powerful feature, especially when using multiple tags: e.g. if I bookmark a tutorial about artificial intelligence and a news article about AI, I can both tag them with "AI" AND tag the article with "news" and the tutorial with "tutorial", so I can search specifically either for articles about AI or tutorials about AI.

With folders, there is only one category, you can put a bookmark in and you cannot search for it in the awesomebar.
Is there any develpment in planing to add the possibility of editing of taggs and description of bookmarks in the mobile (android) firefox sync???
Duplicate of this bug: 1509000
You need to log in before you can comment on or make changes to this bug.