Closed Bug 775739 Opened 7 years ago Closed 6 years ago

Story - Touch scrolling in frames

Categories

(Tracking Graveyard :: Metro Operations, defect, P1)

x86
Windows 8.1
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 775452

People

(Reporter: jwilde, Unassigned)

References

Details

Attachments

(1 file)

Scrolling (mousewheel or not) doesn't seem to work on internal scrollable frames inside of pages.  Test cases include Etherpad and Google Docs.
Blocks: 776719
QA Contact: jmathies
Whiteboard: [metro-preview?]
Whiteboard: [metro-preview?] → [metro-beta]
Product: Firefox → Firefox for Metro
Version: unspecified → Trunk
Whiteboard: [metro-beta] → [metro-mvp]
Tested etherpad with locally built MetroFx.  This works with mouse wheel.  Using touch causes the text in the etherpad to be selected, which I'm thinking is probably what we want?
(In reply to Tim Abraldes (:tabraldes) from comment #1)
> Tested etherpad with locally built MetroFx.  This works with mouse wheel. 
> Using touch causes the text in the etherpad to be selected, which I'm
> thinking is probably what we want?

We don't have scroll bars so you can scroll with the mouse. Touch should scroll sub frames / select text just like the main content frame.
QA Contact: jmathies
It sounds like all the functionality described in this bug is either working or is described by other bugs.

bug 775718 for mouse scroll bars
bug 741968 for wheel scrolling (which works inside frames)
bug 777610 for touch scroll indicators

Marking as duplicate, reopen if I've missed something.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 775718
The missing piece is scrolling frames/iframes/overflow with touch.  Let's cover that specific part in this bug.  I'm adjusting the description to match.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Summary: Support scrolling inside frames in pages → Support touch scrolling inside frames in pages
Whiteboard: [metro-mvp] → [metro-mvp][LOE:?]
Whiteboard: [metro-mvp][LOE:?] → [metro-mvp][LOE:2]
Depends on: multi-apzc
Blocks: 831565
Status: REOPENED → NEW
Priority: -- → P2
Summary: Support touch scrolling inside frames in pages → Story – Touch scrolling in frames
Whiteboard: [metro-mvp][LOE:2] → [metro-mvp][LOE:2] feature=story u=metro_firefox_user c=Content_features
Whiteboard: [metro-mvp][LOE:2] feature=story u=metro_firefox_user c=Content_features → feature=story u=metro_firefox_user c=Content_features p=0
Priority: P2 → P3
Priority: P3 → P2
Marking as 1 "story point" because we expect this will mostly require integrating with common AsyncPanZoomController code that is already implemented.
Whiteboard: feature=story u=metro_firefox_user c=Content_features p=0 → feature=story u=metro_firefox_user c=Content_features p=1
Tentatively blocking on metro-omtc for now.
Depends on: metro-omtc
Depends on: metrov1omtc&apzc
No longer depends on: metro-omtc
Summary: Story – Touch scrolling in frames → Story - Touch scrolling in frames
Component: General → Metro Operations
Product: Firefox for Metro → Tracking
Version: Trunk → ---
Duplicate of this bug: 844833
Priority: P2 → P3
Depends on: 849266
No longer depends on: metrov1omtc&apzc
Depends on: Async_Pan_Zoom
No longer depends on: 849266
No longer blocks: 776719
Duplicate of this bug: 845419
Duplicate of this bug: 843460
Priority: P3 → P1
Depends on: 801154
No longer depends on: Async_Pan_Zoom
Depends on: metro-apzc
No longer depends on: 801154
No longer depends on: metro-apzc
Whiteboard: feature=story u=metro_firefox_user c=Content_features p=1 → feature=story u=metro_firefox_user c=Content_features p=0
Blocks: 898049
No longer blocks: 898049
Depends on: 898049
No longer depends on: multi-apzc
Removing bug 898049, I was hoping this could be done via multi-apzc but that work is not going to be finished by gfx at best for fx26.  Current APZC code only works with one scrollable layer. So we should find another way to do this.  Thoughts?
No longer depends on: 898049
Flags: needinfo?(mbrubeck)
Flags: needinfo?(asa)
Asa said in an email that temporary solutions are fine, I think that's the best way to go for this story since gfx won't have things in until the earliest Fx26 for multi-apzc. 

From kats on #windev:
For the subdocument scrolling you may want to try to use dom/browser-element/BrowserElementPanning.js instead of copying from the fennec frontend, it seems more straightforward and it's what B2G is using
Flags: needinfo?(mbrubeck)
Flags: needinfo?(asa)
Whiteboard: feature=story u=metro_firefox_user c=Content_features p=0 → [Metro Preview] feature=story u=metro_firefox_user c=Content_features p=0
Summary: Story - Touch scrolling in frames → [MP] Story - Touch scrolling in frames
Depends on: 901607
Assignee: nobody → jmathies
Whiteboard: [Metro Preview] feature=story u=metro_firefox_user c=Content_features p=0 → [Metro Preview] feature=story u=metro_firefox_user c=Content_features p=3
Blocks: metrov1it13
No longer blocks: metrov1backlog
Status: NEW → ASSIGNED
QA Contact: jbecerra
Duplicate of this bug: 907400
Blocks: metrov1it14
No longer blocks: metrov1it13
Blocks: metrov1backlog
No longer blocks: metrov1it14
Status: ASSIGNED → NEW
Whiteboard: [Metro Preview] feature=story u=metro_firefox_user c=Content_features p=3 → [preview] feature=story u=metro_firefox_user c=Content_features p=3
Assignee: jmathies → nobody
Kats, is it still looking like bug 775452 won't be ready soon? Should we go ahead and look at dom/browser-element/BrowserElementPanning.js for this? Thanks!
Flags: needinfo?(bugmail.mozilla)
For the most part subframe scrolling works, at least on B2G. If you have a test case that doesn't work on Metro it would be best to file a bug for it and I can take a look.
Flags: needinfo?(bugmail.mozilla)
ok cc-ing on bug 906043
No longer blocks: MetroPreviewRelease
Summary: [MP] Story - Touch scrolling in frames → Story - Touch scrolling in frames
Whiteboard: [preview] feature=story u=metro_firefox_user c=Content_features p=3 → feature=story u=metro_firefox_user c=Content_features p=3
Status: NEW → RESOLVED
Closed: 7 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: multi-apzc
No longer blocks: metrov1backlog, 831565
Whiteboard: feature=story u=metro_firefox_user c=Content_features p=3
OS: Windows 8 Metro → Windows 8.1
Product: Tracking → Tracking Graveyard
You need to log in before you can comment on or make changes to this bug.