Add ARMv6 and x86 build download links to /firefox/channel/#aurora

RESOLVED FIXED in Future

Status

RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: lsblakk, Assigned: kohei)

Tracking

(Blocks: 1 bug)

unspecified
Future
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kb=1361232] u=dev c=downloads p=2, URL)

Attachments

(2 attachments)

Comment 1

6 years ago
+cmore to help us out
(Reporter)

Comment 2

6 years ago
To be clear, this shouldn't be enabled without checking with Release Management first to make sure we're officially releasing this.  I just need to know how long until the work could be done to have this ready.  Thank you.

Comment 3

6 years ago
I also just wondered how stable we think those are already and if we find them release-worthy to the Aurora audience. If so, that would indeed be a great and welcome step! :)

Comment 4

6 years ago
Lukas: What is the status of this? Since you are in Release Management, we could do this after you give us a date that it could be released. We do weekly releases, but we plan our work in bi-weekly sprints.

Were you thinking about just changing the logic of the Android button so it serves up either the ARMv6 or arm versions automatically based on user agent sniffing?

Comment 5

6 years ago
(In reply to Chris More [:cmore] from comment #4)
> Were you thinking about just changing the logic of the Android button so it
> serves up either the ARMv6 or arm versions automatically based on user agent
> sniffing?

I don't believe most Android user agents (outside of Fennec) have actually ever provided platform architecture (see [1]). The easiest thing would be to instead have 2 APK downloads a la [2]. 

[1] http://www.useragentstring.com/pages/Mobile%20Browserlist/
[2] https://nightly.mozilla.org/
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org

Comment 6

6 years ago
Lukas: How do thinks look on your end to add a link to the ARMv6 build?

I wonder if it would be easier to just have something linked off of this page since that is where all other system links are at:

http://www.mozilla.org/en-US/firefox/all.html

Adding links to the /firefox/channel/#aurora page would require adjusting the design of the page to accommodate these links and it may not really look right with the existing green buttons.
(Reporter)

Comment 7

6 years ago
We need different styles of buttons to reflect the availability of a second Android download option in different templates since we have two download pages for each channel:


Aurora

http://www.mozilla.org/en-US/firefox/channel/#aurora
http://www.mozilla.org/en-US/mobile/aurora/


Beta:

http://www.mozilla.org/en-US/mobile/beta/
http://www.mozilla.org/en-US/firefox/channel/#beta

In terms of a timeline, we have ARMv6 builds for both channels now that can be made available to download so getting template changes done and signed off should happen right away so we can push the page changes live when we push 16.0b1 (Thursday) and unthrottle Aurora updates (Friday).
(Reporter)

Comment 8

6 years ago
update: this is going to be pushed to beta 2, so the aurora pages should take priority (by Friday would be best) and then the beta pages ready by next Thursday 9/6.

Updated

6 years ago
Whiteboard: u=dev c=downloads
Target Milestone: --- → Future

Updated

6 years ago
Whiteboard: u=dev c=downloads → u=dev c=downloads p=2

Comment 9

6 years ago
Can we proceed to get these buttons changes up on Mozilla.org? This is less of a technical issue and more of a UX one given that we would need two buttons to give the user a choice between platforms.

Comment 10

6 years ago
(In reply to Lukas Blakk [:lsblakk] from comment #8)
> update: this is going to be pushed to beta 2, so the aurora pages should
> take priority (by Friday would be best) and then the beta pages ready by
> next Thursday 9/6.

Lukas: How big of a priority is this to do on the the Aurora page? P1, P2, or P3? Is there a specific date this should be done?
(In reply to Chris More [:cmore] from comment #10)
> (In reply to Lukas Blakk [:lsblakk] from comment #8)
> > update: this is going to be pushed to beta 2, so the aurora pages should
> > take priority (by Friday would be best) and then the beta pages ready by
> > next Thursday 9/6.
> 
> Lukas: How big of a priority is this to do on the the Aurora page? P1, P2,
> or P3? Is there a specific date this should be done?

It's a matter of consistency, as Nightly has a link and the Beta Play Store page serves both ARMv6/7. I'd say this is a P2, since it's difficult to point users at the Aurora ARMv6 download. May go up to a P1 soon as we make more Aurora-specific ARMv6 changes that we need to communicate to testers.
We are making a few updates to the Aurora download page this quarter. 

Are there any updates regarding the comments in this bug, or can I use them as reference when updating this page?

Comment 13

6 years ago
Question: Why do we need a second button? In the GPS we have a single sdk, and that andles both armv6 and armv7 correct? Do we need an additional "armv6" button only!
(In reply to Sam Mott from comment #13)
> Question: Why do we need a second button? In the GPS we have a single sdk,
In google play we have 2 APKs, but the store serves the right one to the device
> and that andles both armv6 and armv7 correct? Do we need an additional
> "armv6" button only!
It may be possible to use UA sniffing to figure out if the user is on an ARMv6 or ARMv7 device and hide the other button. But we'll need to fall back to having 2 buttons if the user comes to the page using a desktop browser or if we can't detect the right version.

Comment 15

6 years ago
(In reply to Holly Habstritt [:Habber] from comment #12)
> We are making a few updates to the Aurora download page this quarter. 
> 
> Are there any updates regarding the comments in this bug, or can I use them
> as reference when updating this page?

If we are going to be touching the Aurora page, we should make sure it includes the ARMv6 downloads. Are we going to keep it in php or move it to bedrock?
cmore, as far as I know we are keeping it where it is since this is supposed to be a quick update, but I need to talk with the developer for the Aurora updates before I confirm that. It would be ideal to move it to bedrock as long as we are making changes, but this project was a last minute request, so we are going to do what we can before the end of the quarter.

Bug reference for Aurora updates: https://bugzilla.mozilla.org/show_bug.cgi?id=807781
I'd like to pick this back up in February 2013 along with 807781
(Assignee)

Updated

6 years ago
Duplicate of this bug: 788292
(Assignee)

Updated

5 years ago
Blocks: 813052
(Assignee)

Comment 19

5 years ago
AFAIK, ARMv6 users now can download Firefox from Google Play, so we no longer need a direct link to the APK file.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX

Comment 20

5 years ago
(In reply to Kohei Yoshino [:kohei] from comment #19)
> AFAIK, ARMv6 users now can download Firefox from Google Play

Not for Aurora.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Side note; this would also be needed for x86 builds at the same time.
(Assignee)

Comment 22

5 years ago
Oh, I see... I'll take a look.
Assignee: nobody → kohei.yoshino.bugs
Status: REOPENED → ASSIGNED
OS: Mac OS X → All
Hardware: x86 → All
(Assignee)

Comment 23

5 years ago
The download button code is messy... The simplest solution would be like this (sniffing both navigator.platform and navigator.userAgent) but we have to add a noscript support and eventually refactor the code.

>    if (navigator.platform.indexOf('armv6l') !== -1 ||
>            navigator.userAgent.indexOf('armv6l') !== -1) {
>        $('.download-link[href$=".apk"]').attr('href', function(i, val) {
>            return val.replace('android-arm', 'android-arm-armv6')
>                      .replace('aurora-android', 'aurora-android-armv6');
>        });
>    }

Comment 24

5 years ago
Well, that is if a browser even sends the architecture in the UA string. If the user is going there on Firefox (say, they have release or beta and want to try Aurora, or they have Nightly and want to move to the more stable Aurora), then we don't see the architecture at all.
We still want to offer ARMv6 and x86 Aurora for those people in some way.
(Assignee)

Comment 25

5 years ago
navigator.userAgent won't tell us about the platform but
navigator.platform will usually be "Linux armv6l" on ARMv6 devices?

Comment 26

5 years ago
(In reply to Kohei Yoshino [:kohei] from comment #25)
> navigator.userAgent won't tell us about the platform but
> navigator.platform will usually be "Linux armv6l" on ARMv6 devices?

Ah, right, that's possible, I tend to forget that nowadays those properties still exist and have values while they're not 1:1 represented in the UA any more.
(Assignee)

Updated

5 years ago
Component: General → Pages & Content
(Assignee)

Updated

5 years ago
Duplicate of this bug: 899601
(Assignee)

Comment 28

5 years ago
I'm working on this.
(Assignee)

Comment 29

5 years ago
Created attachment 8357514 [details] [review]
Pull Request on GitHub
(Assignee)

Comment 30

5 years ago
Created attachment 8358031 [details]
screenshot

Here's a screenshot.

* non-Android platform
* Android default (ARMv7)
* Android (ARMv6)
* Android (x86)
(Assignee)

Comment 31

5 years ago
Note that this Channel page is not responsive yet, so it looks the same on Android phone and tablet, except the download buttons.
(Assignee)

Updated

5 years ago
Summary: Please add an ARMv6 build download link to http://www.mozilla.org/en-US/firefox/channel/#aurora → Add ARMv6 and x86 build download links to /firefox/channel/#aurora
(Assignee)

Comment 32

5 years ago
There's a JavaScript user agent check to show/hide elements. Can someone test it with one of the physical ARMv6 devices listed here? https://wiki.mozilla.org/index.php?title=Mobile/Platforms/Android&oldid=504407
Whiteboard: u=dev c=downloads p=2 → [kb=871426] u=dev c=downloads p=2
(Assignee)

Comment 33

5 years ago
retornam: your WebQA team has any ARMv6 or x86 devices for testing?
Flags: needinfo?(mozbugs.retornam)
(In reply to Kohei Yoshino [:kohei] from comment #33)
> retornam: your WebQA team has any ARMv6 or x86 devices for testing?

We don't have any ARM6 devices. I'll ask the Mobile QA team if they have any.
Flags: needinfo?(mozbugs.retornam)
(Assignee)

Comment 35

5 years ago
Thanks :retornam!
Do you still need a device? Can someone test this for you? This is somewhat problematic for x86 devices.
Flags: needinfo?(kohei.yoshino)
(Assignee)

Comment 37

4 years ago
(In reply to Gian-Carlo Pascutto [:gcp] from comment #36)
> Do you still need a device? Can someone test this for you? This is somewhat
> problematic for x86 devices.

I have already tested this on an x86 build on my Intel-based Galaxy Tab 3. It worked well. Still needs an ARMv6 device for test.
Flags: needinfo?(kohei.yoshino)
Can someone with an ARMv6 device test this for you then? What needs to happen to close this bug?
Flags: needinfo?(kohei.yoshino)
(Assignee)

Comment 39

4 years ago
Ah, I have already tested with the ARMv6 user agent string too. So yes, my pull request is ready. I'll ask someone for review.
https://github.com/mozilla/bedrock/pull/1572#issuecomment-39487227
Flags: needinfo?(kohei.yoshino)

Comment 40

4 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/dea93b77213f5c51ea23d8133cd28ac9bcaa3bbb
Fix Bug 776101 - Add ARMv6 and x86 build download links to /firefox/channel/#aurora

https://github.com/mozilla/bedrock/commit/b5c80ba16566b36e1787fb428d3194bb070859f6
Merge pull request #1572 from kyoshino/bug-776101-aurora-armv6

Fix Bug 776101 - Add ARMv6 and x86 build download links to /firefox/channel/#aurora

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Whiteboard: [kb=871426] u=dev c=downloads p=2 → [kb=1361232] u=dev c=downloads p=2
Blocks: 1048910
You need to log in before you can comment on or make changes to this bug.