Last Comment Bug 776431 - Share panel profile information doesn't appear in the first window, doesn't look great on Mac
: Share panel profile information doesn't appear in the first window, doesn't l...
Status: RESOLVED FIXED
[fx16]
:
Product: Firefox
Classification: Client Software
Component: SocialAPI (show other bugs)
: Trunk
: All Mac OS X
: -- normal (vote)
: Firefox 17
Assigned To: Jared Wein [:jaws] (please needinfo? me)
:
Mentors:
Depends on: 786207
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-22 20:55 PDT by :Gavin Sharp [email: gavin@gavinsharp.com]
Modified: 2012-08-28 03:48 PDT (History)
1 user (show)
jaws: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix the updating issue (1.54 KB, patch)
2012-07-22 20:56 PDT, :Gavin Sharp [email: gavin@gavinsharp.com]
no flags Details | Diff | Splinter Review
Patch (2.28 KB, patch)
2012-07-24 18:02 PDT, Jared Wein [:jaws] (please needinfo? me)
gavin.sharp: review+
Details | Diff | Splinter Review

Description :Gavin Sharp [email: gavin@gavinsharp.com] 2012-07-22 20:55:11 PDT
Combining two minor issues into one, to minimize aurora-uplift-tracking pain!

- The share panel profile information block is only updated on window load, so if the provider sends the profile data after that, it doesn't get updated. In practice, this means it doesn't really ever show up in the first window.

- When it does show up, on Mac, it doesn't look great, because the text is black-on-grey: http://cl.ly/image/081K3H3s1s3J
Comment 1 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-07-22 20:56:54 PDT
Created attachment 644824 [details] [diff] [review]
fix the updating issue

This fixes the first issue.
Comment 2 Jared Wein [:jaws] (please needinfo? me) 2012-07-22 21:28:31 PDT
The second issue looks to be because -moz-appearance:none on an OSX button still keeps the font color black.

See here: https://mxr.mozilla.org/mozilla-central/source/browser/themes/pinstripe/browser.css#1270

Either hard-coding white, or some other solution will be needed here for OSX.
Comment 3 Jared Wein [:jaws] (please needinfo? me) 2012-07-24 18:02:15 PDT
Created attachment 645608 [details] [diff] [review]
Patch

This includes the fixes for both parts of this bug.

The |color:#fff;| is the same that is used by @hudButton@ which is referenced by the #identity-popup-more-info-button so I think it will be OK to use here.
Comment 4 Jared Wein [:jaws] (please needinfo? me) 2012-07-25 10:39:33 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/673e19fc23eb
Comment 5 Ed Morley [:emorley] 2012-07-26 05:11:12 PDT
https://hg.mozilla.org/mozilla-central/rev/673e19fc23eb

Note You need to log in before you can comment on or make changes to this bug.